aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2011-04-10 20:27:34 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2011-04-10 20:27:34 +0000
commitd9a639ef21264f7f65d138854fc1b49a1a71caf5 (patch)
tree8f891934fc32dc3ad44c636bde7dc76f748a6941 /graphics
parent54bfdd16042e387b95c2c86b2a61676f58546a82 (diff)
downloadports-d9a639ef21264f7f65d138854fc1b49a1a71caf5.tar.gz
ports-d9a639ef21264f7f65d138854fc1b49a1a71caf5.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/qiviewer/Makefile49
-rw-r--r--graphics/qiviewer/distinfo2
-rw-r--r--graphics/qiviewer/pkg-descr4
3 files changed, 55 insertions, 0 deletions
diff --git a/graphics/qiviewer/Makefile b/graphics/qiviewer/Makefile
new file mode 100644
index 000000000000..e4174397bbb5
--- /dev/null
+++ b/graphics/qiviewer/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: qiviewer
+# Date created: 2011-04-02
+# Whom: Gvozdikov Veniamin <g.veniamin@googlemail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= qiviewer
+PORTVERSION= 0.4.0
+CATEGORIES= graphics
+MASTER_SITES= GOOGLE_CODE
+
+MAINTAINER= g.veniamin@googlemail.com
+COMMENT= Fast and lightweight image viewer
+
+LICENSE= GPLv2
+
+USE_BZIP2= yes
+USE_QT_VER= 4
+QT_COMPONENTS= gui xml dbus linguist_build qmake_build moc_build \
+ rcc_build uic_build
+QMAKEFLAGS+= PREFIX="${PREFIX}"
+
+PLIST_FILES= bin/qiviewer \
+ share/applications/qiviewer.desktop \
+ share/qiviewer/locale/es_AR.qm \
+ share/qiviewer/locale/es_ES.qm
+PLIST_DIRS= share/qiviewer/locale \
+ share/qiviewer \
+ share/applications
+
+WRKSRC= ${WRKDIR}/${PORTNAME}/src
+
+OPTIONS= WEBP "Support for WebP image format (experimental)" off
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_WEBP)
+QMAKEFLAGS+= CONFIG+=enable-webp
+.endif
+
+do-configure:
+ @cd ${WRKSRC} && ${QMAKE} ${QMAKEFLAGS}
+
+post-configure:
+ ${REINPLACE_CMD} -e 's|lrelease|lrelease-qt4|g' \
+ ${WRKSRC}/Makefile
+
+.include <bsd.port.post.mk>
diff --git a/graphics/qiviewer/distinfo b/graphics/qiviewer/distinfo
new file mode 100644
index 000000000000..3915447c56e8
--- /dev/null
+++ b/graphics/qiviewer/distinfo
@@ -0,0 +1,2 @@
+SHA256 (qiviewer-0.4.0.tar.bz2) = 83d0dfee9d6caa36261c882b6f3ca9b466423b7fae1057c22ace4f953c3b951b
+SIZE (qiviewer-0.4.0.tar.bz2) = 105777
diff --git a/graphics/qiviewer/pkg-descr b/graphics/qiviewer/pkg-descr
new file mode 100644
index 000000000000..cd93547af07b
--- /dev/null
+++ b/graphics/qiviewer/pkg-descr
@@ -0,0 +1,4 @@
+This program has been written with help of Qt library, to be a
+lightweight image viewer, similar to eog or viewnior for Gnome.
+
+WWW: http://code.google.com/p/qiviewer/