aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-05-15 16:02:09 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-05-15 16:02:09 +0000
commitf6313fe9e7c55415bd2b9c384a1b4b39fcba0918 (patch)
tree703f0dad95df833fb451a33a94423aedb8b7b525 /graphics
parentc43741621cc1e3add1565b373817de0077065699 (diff)
downloadports-f6313fe9e7c55415bd2b9c384a1b4b39fcba0918.tar.gz
ports-f6313fe9e7c55415bd2b9c384a1b4b39fcba0918.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/jgraph/Makefile5
-rw-r--r--graphics/jgraph/files/patch-makefile16
2 files changed, 9 insertions, 12 deletions
diff --git a/graphics/jgraph/Makefile b/graphics/jgraph/Makefile
index 2045941ce8e0..d7174dd4f8a8 100644
--- a/graphics/jgraph/Makefile
+++ b/graphics/jgraph/Makefile
@@ -3,6 +3,7 @@
PORTNAME= jgraph
PORTVERSION= 8.3
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://web.eecs.utk.edu/~plank/plank/jgraph/
DISTFILES= ${PORTNAME}.shar.Z
@@ -20,8 +21,4 @@ MAKEFILE= makefile
MAKE_ENV+= DATADIR=${DATADIR}
CFLAGS+= -Wno-return-type
-post-patch:
- @${REINPLACE_CMD} -E -e 's,(PREFIX|DATADIR)},DESTDIR}$${&,' \
- -e 's|-o bin -g bin||' ${WRKSRC}/makefile
-
.include <bsd.port.mk>
diff --git a/graphics/jgraph/files/patch-makefile b/graphics/jgraph/files/patch-makefile
index d958f69de137..3e74ce280ade 100644
--- a/graphics/jgraph/files/patch-makefile
+++ b/graphics/jgraph/files/patch-makefile
@@ -1,6 +1,6 @@
---- makefile.orig 2013-02-19 10:47:01.000000000 +0100
-+++ makefile 2013-02-19 10:47:23.000000000 +0100
-@@ -18,6 +18,34 @@
+--- makefile.orig 2015-05-15 15:48:34 UTC
++++ makefile
+@@ -18,6 +18,34 @@ OBJS = draw.o \
show.o \
token.o
@@ -35,7 +35,7 @@
EXAMPLES = \
acc.jps \
acc.eps \
-@@ -58,15 +86,21 @@
+@@ -58,15 +86,21 @@ examples: $(EXAMPLES)
.tex.dvi:
latex $*.tex
.c.o:
@@ -51,10 +51,10 @@
cc -o sin sin.o -lm
+install: jgraph
-+ install -c -m 555 -o bin -g bin jgraph ${PREFIX}/bin
-+ install -c -m 444 -o bin -g bin jgraph.1 ${PREFIX}/man/man1
-+ -mkdir -p -m 755 ${DATADIR}
-+ install -c -m 444 -o bin -g bin $(EXAMPLE_SRC) ${DATADIR}
++ ${BSD_INSTALL_PROGRAM} jgraph ${DESTDIR}${PREFIX}/bin
++ ${BSD_INSTALL_MAN} jgraph.1 ${DESTDIR}${PREFIX}/man/man1
++ -mkdir -p -m 755 ${DESTDIR}${DATADIR}
++ ${BSD_INSTALL_DATA} $(EXAMPLE_SRC) ${DESTDIR}${DATADIR}
+
ad.jps: cube.eps disk.eps
bailey.jps: bailey.pts