aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-09-06 22:24:02 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-09-06 22:24:02 +0000
commitcd27d6a4a403cda54a58e349430f176921e4b05c (patch)
treef9895f6eb0310c0f38b5f8e6d5f48d07f91dee28 /graphics
parentfc2206a61e03b817d721ed9b827f3055a5ad6ad1 (diff)
downloadports-cd27d6a4a403cda54a58e349430f176921e4b05c.tar.gz
ports-cd27d6a4a403cda54a58e349430f176921e4b05c.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/vv/Makefile37
-rw-r--r--graphics/vv/distinfo3
-rw-r--r--graphics/vv/files/patch-registration_CMakeLists.txt19
-rw-r--r--graphics/vv/pkg-descr9
5 files changed, 69 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index fb03fade79e1..a2ff57590dfd 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -1126,6 +1126,7 @@
SUBDIR += volpack
SUBDIR += vp
SUBDIR += vulkan-loader
+ SUBDIR += vv
SUBDIR += waffle
SUBDIR += waifu2x-converter-cpp
SUBDIR += wayland
diff --git a/graphics/vv/Makefile b/graphics/vv/Makefile
new file mode 100644
index 000000000000..d252a19a8885
--- /dev/null
+++ b/graphics/vv/Makefile
@@ -0,0 +1,37 @@
+# $FreeBSD$
+
+PORTNAME= vv
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.4.0-271
+DISTVERSIONSUFFIX= -g24b75af3
+CATEGORIES= graphics
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Fast and simple 4D image viewer
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+LIB_DEPENDS= libexpat.so:textproc/expat2 \
+ libfreetype.so:print/freetype2 \
+ libgdcmCommon.so:devel/gdcm \
+ libhdf5_cpp.so:science/hdf5 \
+ libITKLabelMap-4.13.so:science/InsightToolkit \
+ libpng16.so:graphics/png \
+ libsz.so:science/szip \
+ libtiff.so:graphics/tiff \
+ libvtkIOSQL-8.1.so:math/vtk8
+
+USES= cmake:outsource compiler:c++11-lang jpeg qt:5
+USE_GITHUB= yes
+GH_ACCOUNT= open-vv
+USE_QT= core designer gui network sql widgets xml buildtools_build qmake_build
+USE_XORG= ice sm x11 xext xt
+USE_CXXSTD= c++11
+
+PLIST_FILES= bin/vv
+
+post-configure: # need to investigate where these strings come from
+ @${REINPLACE_CMD} 's| -lGTest::GTest -lGTest::Main | |' ${BUILD_WRKSRC}/build.ninja
+
+.include <bsd.port.mk>
diff --git a/graphics/vv/distinfo b/graphics/vv/distinfo
new file mode 100644
index 000000000000..17e2238d2618
--- /dev/null
+++ b/graphics/vv/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1536257892
+SHA256 (open-vv-vv-v1.4.0-271-g24b75af3_GH0.tar.gz) = 8f5b3ab357870a4c14913ef45cc318a776865b75dd18627468ba36986793d9e8
+SIZE (open-vv-vv-v1.4.0-271-g24b75af3_GH0.tar.gz) = 4837976
diff --git a/graphics/vv/files/patch-registration_CMakeLists.txt b/graphics/vv/files/patch-registration_CMakeLists.txt
new file mode 100644
index 000000000000..95aa8095b6fc
--- /dev/null
+++ b/graphics/vv/files/patch-registration_CMakeLists.txt
@@ -0,0 +1,19 @@
+workaround for https://github.com/open-vv/vv/issues/65
+
+--- registration/CMakeLists.txt.orig 2018-09-06 21:47:05 UTC
++++ registration/CMakeLists.txt
+@@ -1,5 +1,6 @@
+ #=========================================================
+
++if(CLITK_BUILD_REGISTRATION)
+ # Add Libraries used in vv and clitk to avoid recompilation
+ WRAP_GGO(clitkAffineRegistration_GGO_C clitkAffineRegistration.ggo)
+ add_library(clitkAffineRegistrationLib
+@@ -10,7 +11,6 @@ add_library(clitkAffineRegistrationLib
+
+ #=========================================================
+
+-if(CLITK_BUILD_REGISTRATION)
+ ############################## registration algorithms
+ add_executable(clitkAffineRegistration clitkAffineRegistration.cxx)
+ target_link_libraries(clitkAffineRegistration clitkAffineRegistrationLib clitkCommon)
diff --git a/graphics/vv/pkg-descr b/graphics/vv/pkg-descr
new file mode 100644
index 000000000000..d3c4c56bf9f2
--- /dev/null
+++ b/graphics/vv/pkg-descr
@@ -0,0 +1,9 @@
+Open-source and cross platform image viewer, designed for fast and simple
+visualization of spatio-temporal images: 2D, 2D+t, 3D and 3D+t (or 4D) images.
+
+VV is designed for qualitative evaluation of image registration and deformation
+field visualization. It contains several tools for superimposing images using
+complementary colors or transparency, visualizing vector fields and defining
+landmarks.
+
+WWW: https://www.creatis.insa-lyon.fr/rio/vv/