aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMatthew Rezny <rezny@FreeBSD.org>2017-02-25 14:55:21 +0000
committerMatthew Rezny <rezny@FreeBSD.org>2017-02-25 14:55:21 +0000
commitcffc145aad6297ed82f152b4c438755d7d00ca29 (patch)
tree6306b40f889d517d4ecdc348753a7a74c845f79b /graphics
parent46060e3ac370f784d4f52e28e02daf231dfeac80 (diff)
downloadports-cffc145aad6297ed82f152b4c438755d7d00ca29.tar.gz
ports-cffc145aad6297ed82f152b4c438755d7d00ca29.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/libEGL/Makefile2
-rw-r--r--graphics/libGL/Makefile2
-rw-r--r--graphics/libGL/Makefile.common34
-rw-r--r--graphics/libGL/distinfo6
-rw-r--r--graphics/libglesv2/Makefile2
-rw-r--r--graphics/libosmesa/Makefile2
6 files changed, 20 insertions, 28 deletions
diff --git a/graphics/libEGL/Makefile b/graphics/libEGL/Makefile
index 4b0000a8d50d..2e4925685b48 100644
--- a/graphics/libEGL/Makefile
+++ b/graphics/libEGL/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libEGL
PORTVERSION= ${MESAVERSION}
-PORTREVISION= 1
+PORTREVISION= 0
CATEGORIES= graphics
COMMENT= OpenEGL library
diff --git a/graphics/libGL/Makefile b/graphics/libGL/Makefile
index 85197cc7f743..fbb085966d6e 100644
--- a/graphics/libGL/Makefile
+++ b/graphics/libGL/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libGL
PORTVERSION= ${MESAVERSION}
-PORTREVISION= 1
+PORTREVISION= 0
CATEGORIES= graphics
COMMENT= OpenGL library that renders using GLX or DRI
diff --git a/graphics/libGL/Makefile.common b/graphics/libGL/Makefile.common
index ff659963b224..df1466ca395c 100644
--- a/graphics/libGL/Makefile.common
+++ b/graphics/libGL/Makefile.common
@@ -18,7 +18,7 @@
MESAVERSION= ${MESABASEVERSION}${MESASUBVERSION:C/^(.)/.\1/}
MESADISTVERSION=${MESABASEVERSION}${MESASUBVERSION:C/^(.)/-\1/}
-MESABASEVERSION= 13.0.4
+MESABASEVERSION= 13.0.5
# if there is a subversion, don't include the '-' between 7.11-rc2.
MESASUBVERSION=
@@ -79,9 +79,7 @@ CONFIGURE_ARGS+= --enable-gbm
CONFIGURE_ARGS+= --enable-egl --with-egl-platforms=x11,drm
# we don't care about GLes v1
-CONFIGURE_ARGS+= --disable-gles1
-
-CONFIGURE_ARGS+= --enable-gles2
+CONFIGURE_ARGS+= --disable-gles1 --enable-gles2
# Clover (OpenCL).
.if ${OPSYS} == DragonFly || \
@@ -104,8 +102,7 @@ clover-pre-configure:
fi
.endif
-CONFIGURE_ARGS+= --enable-opencl \
- --enable-opencl-icd
+CONFIGURE_ARGS+= --enable-opencl --enable-opencl-icd
.else
CONFIGURE_ARGS+= --disable-opencl
.endif
@@ -140,27 +137,22 @@ PLIST_SUB+= VDPAU="@comment "
# VAAPI support?
CONFIGURE_ARGS+=--disable-va
-ALL_DRI_DRIVERS=I915 I965 R200 RADEON SWRAST
-ALL_GALLIUM_DRIVERS=R300 R600 RADEONSI SVGA SWRAST
+ALL_DRI_DRIVERS= I915 I965 RADEON R200 SWRAST
+ALL_GALLIUM_DRIVERS= R300 R600 RADEONSI SVGA SWRAST
-.if ${ARCH} == amd64 || ${ARCH} == i386 || ${ARCH} == ia64
-DRI_DRIVERS= ${ALL_DRI_DRIVERS}
-GALLIUM_DRIVERS= ${ALL_GALLIUM_DRIVERS}
+.if ${ARCH} == amd64 || ${ARCH} == i386
+DRI_DRIVERS= I915 I965 RADEON R200
+GALLIUM_DRIVERS= R300 R600 RADEONSI SVGA
.endif
.if ${ARCH} == powerpc || ${ARCH} == powerpc64
-DRI_DRIVERS= RADEON R200 SWRAST
-GALLIUM_DRIVERS= R300 R600 RADEONSI SWRAST
-.endif
-
-.if ${ARCH} == sparc64 || ${ARCH} == armv6
-DRI_DRIVERS= SWRAST
-GALLIUM_DRIVERS= SWRAST
+DRI_DRIVERS= RADEON R200
+GALLIUM_DRIVERS= R300 R600 RADEONSI
.endif
-# empty for unsupported arches
-DRI_DRIVERS+=
-GALLIUM_DRIVERS+=
+# software rendering for all arches
+DRI_DRIVERS+= SWRAST
+GALLIUM_DRIVERS+= SWRAST
.for _d in ${ALL_DRI_DRIVERS}
. if ${DRI_DRIVERS:M${_d}}
diff --git a/graphics/libGL/distinfo b/graphics/libGL/distinfo
index 6af249eb9851..ad6ae0736a69 100644
--- a/graphics/libGL/distinfo
+++ b/graphics/libGL/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1486052718
-SHA256 (mesa-13.0.4.tar.xz) = a95d7ce8f7bd5f88585e4be3144a341236d8c0fc91f6feaec59bb8ba3120e726
-SIZE (mesa-13.0.4.tar.xz) = 9164612
+TIMESTAMP = 1487852413
+SHA256 (mesa-13.0.5.tar.xz) = bfcea7e2c801525a60895c8aff11aa68457ee9aa35d01a4638e1f310a3f5ef87
+SIZE (mesa-13.0.5.tar.xz) = 9171480
diff --git a/graphics/libglesv2/Makefile b/graphics/libglesv2/Makefile
index d4045761701d..da1d4c54df2e 100644
--- a/graphics/libglesv2/Makefile
+++ b/graphics/libglesv2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libglesv2
PORTVERSION= ${MESAVERSION}
-PORTREVISION= 1
+PORTREVISION= 0
CATEGORIES= graphics
COMMENT= OpenGL ES v2 library
diff --git a/graphics/libosmesa/Makefile b/graphics/libosmesa/Makefile
index 37c307d66a19..ecf633abecd9 100644
--- a/graphics/libosmesa/Makefile
+++ b/graphics/libosmesa/Makefile
@@ -12,7 +12,7 @@ LIB_DEPENDS= libexpat.so:textproc/expat2 \
libglapi.so:graphics/libglapi
USES= ssl
-USE_XORG= x11 xau xcb xdmcp xvmc
+USE_XORG= dri2proto dri3proto glproto presentproto x11 xau xcb xdmcp xvmc
# libosmesa doesn't link agains libGL but osmesa.h needs GL/gl.h
# and both headers are intalled by libGL ....
USE_GL= gl