aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-08-04 18:25:04 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-08-04 18:25:04 +0000
commit06719e2885bbe96b18b4891a22df2f80a1b30fdf (patch)
tree627070a49d1174e81887ca91e1eeff2aa7195568 /graphics
parenta05e3779266d3dd1b779ce0b31e8f647b9880a12 (diff)
downloadports-06719e2885bbe96b18b4891a22df2f80a1b30fdf.tar.gz
ports-06719e2885bbe96b18b4891a22df2f80a1b30fdf.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-traitsui/Makefile26
-rw-r--r--graphics/py-traitsui/distinfo3
-rw-r--r--graphics/py-traitsui/pkg-descr12
4 files changed, 42 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 51bb43c89c8a..787c90a09a6f 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -879,6 +879,7 @@
SUBDIR += py-soya3d
SUBDIR += py-stltools
SUBDIR += py-toyplot
+ SUBDIR += py-traitsui
SUBDIR += py-wand
SUBDIR += py-webcolors
SUBDIR += py3-cairo
diff --git a/graphics/py-traitsui/Makefile b/graphics/py-traitsui/Makefile
new file mode 100644
index 000000000000..11b866f0e5be
--- /dev/null
+++ b/graphics/py-traitsui/Makefile
@@ -0,0 +1,26 @@
+# Created by: Vladimir Chukharev
+# $FreeBSD$
+
+PORTNAME= traitsui
+PORTVERSION= 5.1.0
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= Vladimir.Chukharev@gmail.com
+COMMENT= Enthought traits-capable user interfaces
+
+LICENSE= BSD3CLAUSE LGPL21 EPL
+LICENSE_COMB= multi
+LICENSE_FILE_BSD3CLAUSE= ${WRKSRC}/LICENSE.txt
+LICENSE_FILE_LGPL21= ${WRKSRC}/image_LICENSE_Nuvola.txt
+LICENSE_FILE_EPL= ${WRKSRC}/image_LICENSE_Eclipse.txt
+# See ${WRKSRC}/image_LICENSE.txt for per file license information
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}apptools>=4.3.0:devel/py-apptools
+
+USES= python:-2.7
+USE_PYTHON= autoplist distutils
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/py-traitsui/distinfo b/graphics/py-traitsui/distinfo
new file mode 100644
index 000000000000..e5dc891fe8ac
--- /dev/null
+++ b/graphics/py-traitsui/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1470333921
+SHA256 (traitsui-5.1.0.tar.gz) = 8f68b4a4fcc23837fda89af66a0100fb23f0574204838b4790f5109a69924fb8
+SIZE (traitsui-5.1.0.tar.gz) = 5106303
diff --git a/graphics/py-traitsui/pkg-descr b/graphics/py-traitsui/pkg-descr
new file mode 100644
index 000000000000..64dceb917c66
--- /dev/null
+++ b/graphics/py-traitsui/pkg-descr
@@ -0,0 +1,12 @@
+The traitsui project contains a toolkit-independent GUI abstraction
+layer, which is used to support the "visualization" features of the
+Traits package. Thus, you can write code in terms of the Traits
+API (views, items, editors, etc.), and let traitsui and your selected
+toolkit and back-end take care of the details of displaying them.
+
+The following GUI backends are supported:
+ * wxPython
+ * PyQt
+ * PySide
+
+WWW: https://docs.enthought.com/traitsui