aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-06-08 16:54:25 +0000
committerWill Andrews <will@FreeBSD.org>2001-06-08 16:54:25 +0000
commit0ca07ff1bf719c82e2ba65e97614da6ec6b7d82c (patch)
tree083b54041cfde969f1bb1f6a5c3a9838370f60fd /graphics
parent1e0227f9f44a68fdd05f837b44f42e7cf3ca3c3c (diff)
downloadports-0ca07ff1bf719c82e2ba65e97614da6ec6b7d82c.tar.gz
ports-0ca07ff1bf719c82e2ba65e97614da6ec6b7d82c.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/opendis/Makefile31
-rw-r--r--graphics/opendis/distinfo1
-rw-r--r--graphics/opendis/files/patch-configure.in11
-rw-r--r--graphics/opendis/files/patch-ods.c11
-rw-r--r--graphics/opendis/pkg-comment1
-rw-r--r--graphics/opendis/pkg-descr17
-rw-r--r--graphics/opendis/pkg-plist8
8 files changed, 81 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index e2f094af0667..2da4a8677639 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -157,6 +157,7 @@
SUBDIR += netpbm
SUBDIR += netshow
SUBDIR += nurbs++
+ SUBDIR += opendis
SUBDIR += opendx
SUBDIR += opendx-samples
SUBDIR += opengl-man
diff --git a/graphics/opendis/Makefile b/graphics/opendis/Makefile
new file mode 100644
index 000000000000..54aa3ff3832b
--- /dev/null
+++ b/graphics/opendis/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: opendis
+# Date created: 22 May 2001
+# Whom: Anders Nordby <anders@fix.no>
+#
+# $FreeBSD$
+#
+
+PORTNAME= opendis
+PORTVERSION= 0.0.3
+CATEGORIES= graphics
+MASTER_SITES= http://ods.sourceforge.net/dl/ \
+ ftp://ftp.nuug.no/pub/anders/distfiles/
+
+MAINTAINER= anders@fix.no
+
+USE_AUTOCONF= yes
+GNU_CONFIGURE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}"
+
+DOCS= NEWS AUTHORS doc/ERRATA doc/PHILOSOPHY doc/THUMB
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${INSTALL} -d -o root -g wheel -m 0755 ${PREFIX}/share/doc/${PORTNAME}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/${PORTNAME}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/opendis/distinfo b/graphics/opendis/distinfo
new file mode 100644
index 000000000000..44962e02b2b5
--- /dev/null
+++ b/graphics/opendis/distinfo
@@ -0,0 +1 @@
+MD5 (opendis-0.0.3.tar.gz) = 150bbf038ccb6220d7aff43d712224ed
diff --git a/graphics/opendis/files/patch-configure.in b/graphics/opendis/files/patch-configure.in
new file mode 100644
index 000000000000..a7a70acf8414
--- /dev/null
+++ b/graphics/opendis/files/patch-configure.in
@@ -0,0 +1,11 @@
+--- configure.in.old Tue May 22 13:16:35 2001
++++ configure.in Tue May 22 13:16:58 2001
+@@ -10,7 +10,7 @@
+
+ if test "$GCC" = yes; then
+ dnl Add some extra flags when compiling with gcc.
+- gcc_extra_cflags="-D_GNU_SOURCE -Wall -ansi -pedantic -W"
++ gcc_extra_cflags="-D_GNU_SOURCE -ansi -pedantic"
+ AC_SUBST(gcc_extra_cflags)
+ fi
+
diff --git a/graphics/opendis/files/patch-ods.c b/graphics/opendis/files/patch-ods.c
new file mode 100644
index 000000000000..67b48846a9dc
--- /dev/null
+++ b/graphics/opendis/files/patch-ods.c
@@ -0,0 +1,11 @@
+--- src/ods.c.orig Tue May 22 13:32:19 2001
++++ src/ods.c Tue May 22 13:32:38 2001
+@@ -199,7 +199,7 @@
+ printf("OPTIONS are now supported.\n\n");
+
+ printf(" -d DEV, --device=DEV Look for camera at device DEV. Defaults\n");
+- printf(" to /dev/ttyS0.\n");
++ printf(" to /dev/cuaa0.\n");
+ printf(" -r RATE, --rate=RATE Use bit-rate RATE for serial device. Defaults\n");
+ printf(" to 9600. Not applicable to USB or IrDA.\n");
+ printf(" -t TYPE, --type=TYPE Specifies device type, one of: \"serial\"\n");
diff --git a/graphics/opendis/pkg-comment b/graphics/opendis/pkg-comment
new file mode 100644
index 000000000000..37a580eafd96
--- /dev/null
+++ b/graphics/opendis/pkg-comment
@@ -0,0 +1 @@
+Access Flashpoint Digita-based cameras, download images and more
diff --git a/graphics/opendis/pkg-descr b/graphics/opendis/pkg-descr
new file mode 100644
index 000000000000..ae4dd5fa6dd6
--- /dev/null
+++ b/graphics/opendis/pkg-descr
@@ -0,0 +1,17 @@
+ODS, the Open Digita Services project, is an effort to write Open Source tools
+for accessing Digita cameras from Linux and other unix operating systems.
+
+ODS has been tested with and is known to work with the following cameras:
+
+Kodak DC-220
+Kodak DC-260
+Kodak DC-265
+Kodak DC-290
+
+The Minolta EX-1500 has been reported to work with ODS, but the interface needs
+some debugging.
+
+ODS will not support cameras that don't use Digita; this includes the Kodak
+DC-200, DC-210, DC-240, DC-280, and earlier cameras.
+
+WWW: http://ods.sourceforge.net/
diff --git a/graphics/opendis/pkg-plist b/graphics/opendis/pkg-plist
new file mode 100644
index 000000000000..e07b71f3f325
--- /dev/null
+++ b/graphics/opendis/pkg-plist
@@ -0,0 +1,8 @@
+bin/ks
+lib/libods.a
+%%PORTDOCS%%share/doc/opendis/NEWS
+%%PORTDOCS%%share/doc/opendis/AUTHORS
+%%PORTDOCS%%share/doc/opendis/ERRATA
+%%PORTDOCS%%share/doc/opendis/PHILOSOPHY
+%%PORTDOCS%%share/doc/opendis/THUMB
+%%PORTDOCS%%@dirrm share/doc/opendis