aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorDanilo G. Baio <dbaio@FreeBSD.org>2017-09-17 11:32:27 +0000
committerDanilo G. Baio <dbaio@FreeBSD.org>2017-09-17 11:32:27 +0000
commit1a5aa0e29de9a2d3a1bad11d4bb953b93e1616a0 (patch)
tree2f7da16611227e9a776c8032fe5134f1c5ec16e5 /graphics
parenta1a677814a803d8949a13115e42aecd6ccdb32a4 (diff)
downloadports-1a5aa0e29de9a2d3a1bad11d4bb953b93e1616a0.tar.gz
ports-1a5aa0e29de9a2d3a1bad11d4bb953b93e1616a0.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-graphviz/Makefile27
-rw-r--r--graphics/py-graphviz/distinfo3
-rw-r--r--graphics/py-graphviz/pkg-descr13
4 files changed, 44 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index dc745b2744f3..c3a9ac061fba 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -862,6 +862,7 @@
SUBDIR += py-graph
SUBDIR += py-graph-core
SUBDIR += py-graph-dot
+ SUBDIR += py-graphviz
SUBDIR += py-graphy
SUBDIR += py-gvgen
SUBDIR += py-imageio
diff --git a/graphics/py-graphviz/Makefile b/graphics/py-graphviz/Makefile
new file mode 100644
index 000000000000..693c8c0b312c
--- /dev/null
+++ b/graphics/py-graphviz/Makefile
@@ -0,0 +1,27 @@
+# Created by: lbartoletti <lbartoletti@tuxfamily.org>
+# $FreeBSD$
+
+PORTNAME= graphviz
+PORTVERSION= 0.8
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= lbartoletti@tuxfamily.org
+COMMENT= Simple Python interface for Graphviz
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= dot:graphics/graphviz
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-cov>=0:devel/py-pytest-cov \
+ ${PYTHON_PKGNAMEPREFIX}pytest-mock>=0:devel/py-pytest-mock
+
+NO_ARCH= yes
+USES= python zip
+USE_PYTHON= autoplist concurrent distutils
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} run-tests.py
+
+.include <bsd.port.mk>
diff --git a/graphics/py-graphviz/distinfo b/graphics/py-graphviz/distinfo
new file mode 100644
index 000000000000..3c4ee125cd02
--- /dev/null
+++ b/graphics/py-graphviz/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1505065239
+SHA256 (graphviz-0.8.zip) = 889c720d9955b804d56a8e842621558cbb5cbbdd93cbdf55862371311646e344
+SIZE (graphviz-0.8.zip) = 132752
diff --git a/graphics/py-graphviz/pkg-descr b/graphics/py-graphviz/pkg-descr
new file mode 100644
index 000000000000..27d7d99b89f4
--- /dev/null
+++ b/graphics/py-graphviz/pkg-descr
@@ -0,0 +1,13 @@
+This package facilitates the creation and rendering of graph descriptions in the
+DOT language of the Graphviz graph drawing software (repo) from Python.
+
+Create a graph object, assemble the graph by adding nodes and edges, and
+retrieve its DOT source code string. Save the source code to a file and render
+it with the Graphviz installation of your system.
+
+Use the view option/method to directly inspect the resulting (PDF, PNG, SVG,
+etc.) file with its default application. Graphs can also be rendered and
+displayed within Jupyter notebooks (a.k.a. IPython notebooks, example) as well
+as the Jupyter Qt Console.
+
+WWW: https://github.com/xflr6/graphviz