aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-04-28 18:19:57 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-04-28 18:19:57 +0000
commit70d1f485a4d296da8fe6d94cdb7fae9d9c2cde26 (patch)
tree525066c065d26e78b787a80972d2cfc5b562f40c /graphics
parentad97d9a77489cdbca48bc58688b2bfa46c1b26b5 (diff)
downloadports-70d1f485a4d296da8fe6d94cdb7fae9d9c2cde26.tar.gz
ports-70d1f485a4d296da8fe6d94cdb7fae9d9c2cde26.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/reallyslick/Makefile37
-rw-r--r--graphics/reallyslick/pkg-plist23
2 files changed, 36 insertions, 24 deletions
diff --git a/graphics/reallyslick/Makefile b/graphics/reallyslick/Makefile
index 371104524f03..6a99eb1f31e2 100644
--- a/graphics/reallyslick/Makefile
+++ b/graphics/reallyslick/Makefile
@@ -11,39 +11,28 @@ DISTNAME= rss-glx_${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= OpenGL screensaver collection
-LIB_DEPENDS= MagickWand:${PORTSDIR}/graphics/ImageMagick \
- GLC.0:${PORTSDIR}/graphics/quesoglc
+LIB_DEPENDS= libMagickWand.so:${PORTSDIR}/graphics/ImageMagick \
+ libGLC.so:${PORTSDIR}/graphics/quesoglc
-OPTIONS_DEFINE= FREEALUT GLEW
-FREEALUT_DESC= Enable freealut support
-GLEW_DESC= Enable GLEW support
-
-USE_BZIP2= yes
USE_GL= glut
-USES= pathfix gmake
+USES= gmake pathfix tar:bzip2
GNU_CONFIGURE= yes
-MAN1= biof.1 busyspheres.1 colorfire.1 cyclone.1 drempels.1 \
- euphoria.1 feedback.1 fieldlines.1 flocks.1 flux.1 \
- helios.1 hufo_smoke.1 hufo_tunnel.1 hyperspace.1 lattice.1 \
- lorenz.1 matrixview.1 pixelcity.1 plasma.1 skyrocket.1 \
- solarwinds.1 spirographx.1 sundancer2.1
-
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lXext
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= FREEALUT GLEW
-.if ${PORT_OPTIONS:MFREEALUT}
-USES+= openal:alut
-.else
-CONFIGURE_ARGS+= --disable-sound
-.endif
+FREEALUT_DESC= Enable freealut support
+FREEALUT_CONFIGURE_ENABLE= sound
+FREEALUT_USES= openal:alut
+
+GLEW_DESC= Enable GLEW support
+GLEW_USE= GL=glew
+
+.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MGLEW}
-USE_GL+= glew
-.else
+.if ! ${PORT_OPTIONS:MGLEW}
CONFIGURE_ENV+= ac_cv_header_GL_glew_h=no
.endif
diff --git a/graphics/reallyslick/pkg-plist b/graphics/reallyslick/pkg-plist
index 7f2906d43d30..29ebbda01e37 100644
--- a/graphics/reallyslick/pkg-plist
+++ b/graphics/reallyslick/pkg-plist
@@ -28,3 +28,26 @@ lib/libPixelCity.a
lib/libPixelCity.la
lib/librsMath.a
lib/librsMath.la
+man/man1/biof.1.gz
+man/man1/busyspheres.1.gz
+man/man1/colorfire.1.gz
+man/man1/cyclone.1.gz
+man/man1/drempels.1.gz
+man/man1/euphoria.1.gz
+man/man1/feedback.1.gz
+man/man1/fieldlines.1.gz
+man/man1/flocks.1.gz
+man/man1/flux.1.gz
+man/man1/helios.1.gz
+man/man1/hufo_smoke.1.gz
+man/man1/hufo_tunnel.1.gz
+man/man1/hyperspace.1.gz
+man/man1/lattice.1.gz
+man/man1/lorenz.1.gz
+man/man1/matrixview.1.gz
+man/man1/pixelcity.1.gz
+man/man1/plasma.1.gz
+man/man1/skyrocket.1.gz
+man/man1/solarwinds.1.gz
+man/man1/spirographx.1.gz
+man/man1/sundancer2.1.gz