aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2014-04-26 14:04:28 +0000
committerThierry Thomas <thierry@FreeBSD.org>2014-04-26 14:04:28 +0000
commita9e3fa7d258b07230331223ac944ae7f264c4943 (patch)
treebf682c837c1f847a131f41b79fc1c37a86e716cf /graphics
parent46560bcffa4aeb0256b8fc3367c09c6b7a2844e7 (diff)
downloadports-a9e3fa7d258b07230331223ac944ae7f264c4943.tar.gz
ports-a9e3fa7d258b07230331223ac944ae7f264c4943.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/GraphicsMagick13/Makefile5
-rw-r--r--graphics/GraphicsMagick13/files/patch-configure79
2 files changed, 76 insertions, 8 deletions
diff --git a/graphics/GraphicsMagick13/Makefile b/graphics/GraphicsMagick13/Makefile
index b91e09586423..776ef87902ab 100644
--- a/graphics/GraphicsMagick13/Makefile
+++ b/graphics/GraphicsMagick13/Makefile
@@ -3,7 +3,7 @@
PORTNAME= GraphicsMagick
PORTVERSION= 1.3.19
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics
MASTER_SITES= SF \
ftp://ftp.graphicsmagick.org/pub/GraphicsMagick/1.3/
@@ -25,8 +25,7 @@ CONFLICTS= GraphicsMagick-1.[12].* GraphicsMagick12-*
PORTSCOUT= limit:^1\.3\.
-USE_BZIP2= yes
-USES= iconv
+USES= iconv tar:bzip2
USE_GNOME= libxml2
USE_GHOSTSCRIPT=yes
GNU_CONFIGURE= yes
diff --git a/graphics/GraphicsMagick13/files/patch-configure b/graphics/GraphicsMagick13/files/patch-configure
index 1d6054e6d81a..1680e29eafa8 100644
--- a/graphics/GraphicsMagick13/files/patch-configure
+++ b/graphics/GraphicsMagick13/files/patch-configure
@@ -1,6 +1,75 @@
---- configure.orig 2013-03-10 00:21:59.000000000 +0100
-+++ configure 2013-12-27 11:48:19.000000000 +0100
-@@ -24637,15 +24637,16 @@
+--- configure.orig 2013-12-31 20:58:17.000000000 +0100
++++ configure 2014-04-26 15:53:04.000000000 +0200
+@@ -12919,7 +12919,6 @@
+ # FreeBSD 3 and greater uses gcc -shared to do shared libraries.
+ freebsd* | dragonfly*)
+ archive_cmds='$CC -shared $pic_flag -o $lib $libobjs $deplibs $compiler_flags'
+- hardcode_libdir_flag_spec='-R$libdir'
+ hardcode_direct=yes
+ hardcode_shlibpath_var=no
+ ;;
+@@ -23889,60 +23888,6 @@
+ X_CFLAGS="$X_CFLAGS -I$x_includes"
+ fi
+
+- # It would also be nice to do this for all -L options, not just this one.
+- if test -n "$x_libraries"; then
+- X_LIBS="$X_LIBS -L$x_libraries"
+- # For Solaris; some versions of Sun CC require a space after -R and
+- # others require no space. Words are not sufficient . . . .
+- { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether -R must be followed by a space" >&5
+-$as_echo_n "checking whether -R must be followed by a space... " >&6; }
+- ac_xsave_LIBS=$LIBS; LIBS="$LIBS -R$x_libraries"
+- ac_xsave_c_werror_flag=$ac_c_werror_flag
+- ac_c_werror_flag=yes
+- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+-/* end confdefs.h. */
+-
+-int
+-main ()
+-{
+-
+- ;
+- return 0;
+-}
+-_ACEOF
+-if ac_fn_c_try_link "$LINENO"; then :
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+-$as_echo "no" >&6; }
+- X_LIBS="$X_LIBS -R$x_libraries"
+-else
+- LIBS="$ac_xsave_LIBS -R $x_libraries"
+- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+-/* end confdefs.h. */
+-
+-int
+-main ()
+-{
+-
+- ;
+- return 0;
+-}
+-_ACEOF
+-if ac_fn_c_try_link "$LINENO"; then :
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
+-$as_echo "yes" >&6; }
+- X_LIBS="$X_LIBS -R $x_libraries"
+-else
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: neither works" >&5
+-$as_echo "neither works" >&6; }
+-fi
+-rm -f core conftest.err conftest.$ac_objext \
+- conftest$ac_exeext conftest.$ac_ext
+-fi
+-rm -f core conftest.err conftest.$ac_objext \
+- conftest$ac_exeext conftest.$ac_ext
+- ac_c_werror_flag=$ac_xsave_c_werror_flag
+- LIBS=$ac_xsave_LIBS
+- fi
+
+ # Check for system-dependent libraries X programs must link with.
+ # Do this before checking for the system-independent R6 libraries
+@@ -24637,15 +24582,16 @@
# Cygwin doesn't deliver -lXt as a DLL, which prevents a DLL build.
# Adobe DPS (as delivered on Solaris) doesn't require -lXt.
# GraphicsMagick itself doesn't use -lXt.
@@ -19,7 +88,7 @@
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
-@@ -27095,7 +27096,7 @@
+@@ -27095,7 +27041,7 @@
#
# Subdirectory under lib to place GraphicsMagick lib files
@@ -28,7 +97,7 @@
cat >>confdefs.h <<_ACEOF
#define MagickLibSubdir "$MagickLibSubdir"
-@@ -27199,7 +27200,7 @@
+@@ -27199,7 +27145,7 @@
#
# Path to GraphicsMagick share files