aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2012-03-13 16:15:36 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2012-03-13 16:15:36 +0000
commitb59621d3ae883bef429a8fae6073bfa293a55222 (patch)
treeb415c7b2903cf47ada68c5557c3c6ac33a25fc41 /graphics
parente93c09b8f3675471a176b72ae1e6f085f7a607ad (diff)
downloadports-b59621d3ae883bef429a8fae6073bfa293a55222.tar.gz
ports-b59621d3ae883bef429a8fae6073bfa293a55222.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/p5-CAD-Drawing/Makefile10
-rw-r--r--graphics/p5-Geometry-Primitive/Makefile8
-rw-r--r--graphics/p5-Graph-ReadWrite/Makefile9
-rw-r--r--graphics/p5-GraphViz/Makefile5
-rw-r--r--graphics/p5-GraphViz2/Makefile9
-rw-r--r--graphics/p5-Image-Info/Makefile9
-rw-r--r--graphics/p5-Image-Pngslimmer/Makefile9
-rw-r--r--graphics/p5-Image-Size/Makefile9
-rw-r--r--graphics/p5-PGPLOT/Makefile6
-rw-r--r--graphics/p5-SWF-File/Makefile9
10 files changed, 75 insertions, 8 deletions
diff --git a/graphics/p5-CAD-Drawing/Makefile b/graphics/p5-CAD-Drawing/Makefile
index 57af5fb9bb3e..56fb3c9aed12 100644
--- a/graphics/p5-CAD-Drawing/Makefile
+++ b/graphics/p5-CAD-Drawing/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= ${SITE_PERL}/Math/Vec.pm:${PORTSDIR}/math/p5-Math-Vec \
${SITE_PERL}/${PERL_ARCH}/Image/Magick.pm:${PORTSDIR}/graphics/ImageMagick \
${SITE_PERL}/Stream/FileInputStream.pm:${PORTSDIR}/devel/p5-Stream \
${SITE_PERL}/Math/Geometry/Planar.pm:${PORTSDIR}/math/p5-Math-Geometry-Planar
-BUILD_DEPENDS:= ${RUN_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
MAN3= CAD::Drawing.3 \
CAD::Drawing::Calculate.3 \
@@ -38,4 +38,10 @@ MAN3= CAD::Drawing.3 \
PERL_MODBUILD= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500903
+RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/p5-Geometry-Primitive/Makefile b/graphics/p5-Geometry-Primitive/Makefile
index edb22b42583c..5bf72a85b540 100644
--- a/graphics/p5-Geometry-Primitive/Makefile
+++ b/graphics/p5-Geometry-Primitive/Makefile
@@ -37,4 +37,10 @@ MAN3= Geometry::Primitive.3 \
Geometry::Primitive::Rectangle.3 \
Geometry::Primitive::Shape.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+RUN_DEPENDS+= p5-Math-Complex>=1.56:${PORTSDIR}/math/p5-Math-Complex
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/p5-Graph-ReadWrite/Makefile b/graphics/p5-Graph-ReadWrite/Makefile
index a93b23d5ca49..163055a57c95 100644
--- a/graphics/p5-Graph-ReadWrite/Makefile
+++ b/graphics/p5-Graph-ReadWrite/Makefile
@@ -36,4 +36,11 @@ MAN3= Graph::Reader.3 \
post-patch:
@${REINPLACE_CMD} -e 's|Graph-ReadWrite|Graph::ReadWrite|' ${WRKSRC}/Makefile.PL
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+BUILD_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
+RUN_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/p5-GraphViz/Makefile b/graphics/p5-GraphViz/Makefile
index 47ae850037d9..3ccd46cd10ae 100644
--- a/graphics/p5-GraphViz/Makefile
+++ b/graphics/p5-GraphViz/Makefile
@@ -37,4 +37,9 @@ MAN3= Devel::GraphVizProf.3 \
GraphViz::Small.3 \
GraphViz::XML.3
+.if defined(MAINTAINER_MODE)
+regression-test: build
+ cd ${WRKSRC} && ${MAKE} test
+.endif
+
.include <bsd.port.mk>
diff --git a/graphics/p5-GraphViz2/Makefile b/graphics/p5-GraphViz2/Makefile
index 6a0009024619..c6f44f45aea0 100644
--- a/graphics/p5-GraphViz2/Makefile
+++ b/graphics/p5-GraphViz2/Makefile
@@ -58,6 +58,15 @@ MAN3= GraphViz2.3 \
.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 501001
+BUILD_DEPENDS+= p5-File-Temp>=0.22:${PORTSDIR}/devel/p5-File-Temp
+RUN_DEPENDS+= p5-File-Temp>=0.22:${PORTSDIR}/devel/p5-File-Temp
+.endif
+
+.if ${PERL_LEVEL} < 501200
+TEST_DEPENDS+= p5-Test-Simple>=0.94:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
.if ${PERL_LEVEL} < 501400
BUILD_DEPENDS+= p5-HTTP-Tiny>=0.012:${PORTSDIR}/www/p5-HTTP-Tiny \
p5-PathTools>=3.3300:${PORTSDIR}/devel/p5-PathTools \
diff --git a/graphics/p5-Image-Info/Makefile b/graphics/p5-Image-Info/Makefile
index 15bdda07875f..41001c57c1d0 100644
--- a/graphics/p5-Image-Info/Makefile
+++ b/graphics/p5-Image-Info/Makefile
@@ -35,4 +35,11 @@ MAN3= Bundle::Image::Info::Everything.3 \
Image::Info::XBM.3 \
Image::Info::XPM.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501000
+RUN_DEPENDS+= p5-IO-Compress>=0:${PORTSDIR}/archivers/p5-IO-Compress
+BUILD_DEPENDS+= p5-IO-Compress>=0:${PORTSDIR}/archivers/p5-IO-Compress
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/p5-Image-Pngslimmer/Makefile b/graphics/p5-Image-Pngslimmer/Makefile
index d9a6ec99b4e4..90843aabc5cb 100644
--- a/graphics/p5-Image-Pngslimmer/Makefile
+++ b/graphics/p5-Image-Pngslimmer/Makefile
@@ -19,4 +19,11 @@ PERL_CONFIGURE= yes
MAN3= Image::Pngslimmer.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500903
+RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+BUILD_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/p5-Image-Size/Makefile b/graphics/p5-Image-Size/Makefile
index 8584cf425a3e..78910d4be50d 100644
--- a/graphics/p5-Image-Size/Makefile
+++ b/graphics/p5-Image-Size/Makefile
@@ -20,4 +20,11 @@ PERL_CONFIGURE= yes
MAN1= imgsize.1
MAN3= Image::Size.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500903
+RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+BUILD_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/p5-PGPLOT/Makefile b/graphics/p5-PGPLOT/Makefile
index f44c85b38b04..57305a955f67 100644
--- a/graphics/p5-PGPLOT/Makefile
+++ b/graphics/p5-PGPLOT/Makefile
@@ -33,4 +33,10 @@ post-install:
cd ${WRKSRC}/ && ${INSTALL_DATA} LICENSE test* ${EXAMPLESDIR}/
.endif
+.if defined(MAINTAINER_MODE) && !defined(BATCH)
+check regression-test test: build
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} \
+ ${_MAKE_JOBS} ${MAKE_ARGS} test
+.endif
+
.include <bsd.port.mk>
diff --git a/graphics/p5-SWF-File/Makefile b/graphics/p5-SWF-File/Makefile
index 76894f24f437..faccb60514ae 100644
--- a/graphics/p5-SWF-File/Makefile
+++ b/graphics/p5-SWF-File/Makefile
@@ -32,4 +32,11 @@ post-patch:
post-configure:
@${PERL} -pi -e 's/^(POD2MAN_EXE.*)$$/\1 --lax/;' ${WRKSRC}/Makefile
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500903
+RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+BUILD_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+.endif
+
+.include <bsd.port.post.mk>