aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-12-09 06:01:36 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-12-09 06:01:36 +0000
commitccb1f64f7c161b3f6bfb8cb886d87b7d61dda879 (patch)
treea833de960554b2ccc3caf7dd3a380ddb808b29b5 /graphics
parent2738be1d75ad04ba1f2d9af2dad4520a2655fc1f (diff)
downloadports-ccb1f64f7c161b3f6bfb8cb886d87b7d61dda879.tar.gz
ports-ccb1f64f7c161b3f6bfb8cb886d87b7d61dda879.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gdal/Makefile11
-rw-r--r--graphics/gdal/distinfo4
-rw-r--r--graphics/gdal/files/patch-frmts-gif-gifdatasetp.cpp55
3 files changed, 6 insertions, 64 deletions
diff --git a/graphics/gdal/Makefile b/graphics/gdal/Makefile
index 915f265af0b6..8b3d32674d6e 100644
--- a/graphics/gdal/Makefile
+++ b/graphics/gdal/Makefile
@@ -1,13 +1,8 @@
-# New ports collection makefile for: Geospatial Data Abstraction Library
-# Date created: 27 Aug 2001
-# Whom: Randall Hopper
-#
+# Created by: Randall Hopper
# $FreeBSD$
-#
PORTNAME= gdal
-PORTVERSION= 1.9.1
-PORTREVISION= 1
+PORTVERSION= 1.9.2
CATEGORIES= graphics geography
MASTER_SITES= http://download.osgeo.org/gdal/ \
ftp://ftp.remotesensing.org/pub/gdal/ \
@@ -34,6 +29,8 @@ USE_AUTOTOOLS= libtool
USE_GMAKE= yes
USE_LDCONFIG= yes
+SLAVEDIRS= graphics/p5-Geo-GDAL graphics/php-gdal graphics/py-gdal graphics/ruby-gdal
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MCFITSIO}
diff --git a/graphics/gdal/distinfo b/graphics/gdal/distinfo
index 362a722e3f60..b73eaf8d2a3d 100644
--- a/graphics/gdal/distinfo
+++ b/graphics/gdal/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gdal-1.9.1.tar.gz) = 5b829e91c5d6c6c9af23fe6322e51bae9339e8805d52724cb0ad0b741aef7fa9
-SIZE (gdal-1.9.1.tar.gz) = 9487505
+SHA256 (gdal-1.9.2.tar.gz) = 9f3b9ae968eaa8d06ee5448e5b65e7bfa940e2e345282a29d95275421f36c688
+SIZE (gdal-1.9.2.tar.gz) = 9495381
diff --git a/graphics/gdal/files/patch-frmts-gif-gifdatasetp.cpp b/graphics/gdal/files/patch-frmts-gif-gifdatasetp.cpp
deleted file mode 100644
index af1dd987debe..000000000000
--- a/graphics/gdal/files/patch-frmts-gif-gifdatasetp.cpp
+++ /dev/null
@@ -1,55 +0,0 @@
-Ref: http://trac.osgeo.org/gdal/ticket/4675
-
---- frmts/gif/gifdataset.cpp.orig 2012-05-17 11:30:54.000000000 +0800
-+++ frmts/gif/gifdataset.cpp 2012-06-05 00:23:12.988213306 +0800
-@@ -469,6 +469,28 @@
- return poDS;
- }
-
-+ /************************************************************************/
-+/* GDALPrintGifError() */
-+/************************************************************************/
-+
-+static void GDALPrintGifError(const char* pszMsg)
-+{
-+/* GIFLIB_MAJOR is only defined in libgif >= 4.2.0 */
-+/* libgif 4.2.0 has retired PrintGifError() and added GifErrorString() */
-+#if defined(GIFLIB_MAJOR) && defined(GIFLIB_MINOR) && \
-+ ((GIFLIB_MAJOR == 4 && GIFLIB_MINOR >= 2) || GIFLIB_MAJOR > 4)
-+ /* Static string actually, hence the const char* cast */
-+ const char* pszGIFLIBError = (const char*) GifErrorString();
-+ if (pszGIFLIBError == NULL)
-+ pszGIFLIBError = "Unknown error";
-+ CPLError( CE_Failure, CPLE_AppDefined,
-+ "%s. GIFLib Error : %s", pszMsg, pszGIFLIBError );
-+#else
-+ PrintGifError();
-+ CPLError( CE_Failure, CPLE_AppDefined, "%s", pszMsg );
-+#endif
-+}
-+
- /************************************************************************/
- /* CreateCopy() */
- /************************************************************************/
-@@ -596,9 +618,7 @@
- psGifCT->ColorCount, 255, psGifCT) == GIF_ERROR)
- {
- FreeMapObject(psGifCT);
-- PrintGifError();
-- CPLError( CE_Failure, CPLE_AppDefined,
-- "Error writing gif file." );
-+ GDALPrintGifError("Error writing gif file.");
- EGifCloseFile(hGifFile);
- VSIFCloseL( fp );
- return NULL;
-@@ -622,9 +642,7 @@
-
- if (EGifPutImageDesc(hGifFile, 0, 0, nXSize, nYSize, bInterlace, NULL) == GIF_ERROR )
- {
-- PrintGifError();
-- CPLError( CE_Failure, CPLE_AppDefined,
-- "Error writing gif file." );
-+ GDALPrintGifError("Error writing gif file.");
- EGifCloseFile(hGifFile);
- VSIFCloseL( fp );
- return NULL;