aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-06-08 05:36:37 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-06-08 05:36:37 +0000
commitcd8662b6c790a90fd0511d1169d26f0ca1b57418 (patch)
treeb29e02d2c38eecc0fa0412f0c9b96b0c3f0f3726 /graphics
parent9b3444d89743eb70e1db950aacfe425f862ad178 (diff)
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/smoke/Makefile21
1 files changed, 6 insertions, 15 deletions
diff --git a/graphics/smoke/Makefile b/graphics/smoke/Makefile
index 073931b7b36c..cd9c4e104751 100644
--- a/graphics/smoke/Makefile
+++ b/graphics/smoke/Makefile
@@ -31,26 +31,17 @@ TMAKEPATH?= ${LOCALBASE}/share/tmake/freebsd-g++
PORTDOCS= README
-.include <bsd.port.pre.mk>
-
-.if exists(${FREETYPE_CONFIG})
-FREETYPE_INCLUDEPATH!= ${FREETYPE_CONFIG} --cflags | ${SED} -e 's|-I||g'
-.endif
-.if exists(${SDL_CONFIG})
-SDL_INCLUDEPATH!= ${SDL_CONFIG} --cflags | ${SED} -e 's|-I||g; s|-D[[:graph:]]*||g'
-.endif
-
pre-everything::
@${ECHO_MSG} "This port depends on SDL with OpenGL support."
@${ECHO_MSG} "If your SDL does not support OpenGL, hit ^C now and reinstall SDL"
@${ECHO_MSG} "with OpenGL support turned on."
post-patch:
- @${REINPLACE_CMD} -e 's|%%FREETYPE_CONFIG%%|${FREETYPE_CONFIG}|g; \
- s|%%SDL_CONFIG%%|${SDL_CONFIG}|g; \
- s|%%FREETYPE_INCLUDEPATH%%|${FREETYPE_INCLUDEPATH}|g; \
- s|%%SDL_INCLUDEPATH%%|${SDL_INCLUDEPATH}|g; \
- s|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|g' \
+ @${REINPLACE_CMD} -e "s|%%FREETYPE_CONFIG%%|${FREETYPE_CONFIG}|g; \
+ s|%%SDL_CONFIG%%|${SDL_CONFIG}|g; \
+ s#%%FREETYPE_INCLUDEPATH%%#`${FREETYPE_CONFIG} --cflags | ${SED} -e 's|-I||g'`#; \
+ s#%%SDL_INCLUDEPATH%%#`${SDL_CONFIG} --cflags | ${SED} -e 's|-I||g; s|-D[[:graph:]]*||g'`#; \
+ s|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|g" \
${WRKSRC}/project
pre-build:
@@ -67,4 +58,4 @@ do-install:
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>