aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-08-07 15:08:25 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-08-07 15:08:25 +0000
commit2395820beb103135262eba7b6a974416be201f90 (patch)
tree1e4d9de269a9ba258aeab4406002144901df591f /graphics
parent2c2689b5c6a1f1a78d9b5f42d769c48d1cce182f (diff)
downloadports-2395820beb103135262eba7b6a974416be201f90.tar.gz
ports-2395820beb103135262eba7b6a974416be201f90.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/mplayer/Makefile13
-rw-r--r--graphics/mplayer/distinfo2
-rw-r--r--graphics/mplayer/files/patch-ad40
-rw-r--r--graphics/mplayer/files/patch-ae8
-rw-r--r--graphics/mplayer/pkg-plist4
5 files changed, 39 insertions, 28 deletions
diff --git a/graphics/mplayer/Makefile b/graphics/mplayer/Makefile
index 8093f2cbecb2..fbc0e1ee748a 100644
--- a/graphics/mplayer/Makefile
+++ b/graphics/mplayer/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= mplayer
-PORTVERSION= 0.90.0.5
-PORTREVISION= 1
+PORTVERSION= 0.90.0.6
CATEGORIES= graphics
MASTER_SITES= http://ftp.mplayerhq.hu/MPlayer/releases/ \
http://www.mplayerhq.hu/MPlayer/releases/ \
@@ -17,7 +16,7 @@ MASTER_SITES= http://ftp.mplayerhq.hu/MPlayer/releases/ \
ftp://ftp2.mplayerhq.hu/MPlayer/releases/ \
ftp://ftp.lug.udel.edu/MPlayer/releases/ \
http://www.rrr.de/~riggs/mplayer/
-DISTNAME= MPlayer-0.90pre5
+DISTNAME= MPlayer-0.90pre6
MAINTAINER= riggs@rrr.de
@@ -41,9 +40,9 @@ MLINKS= mplayer.1 mencoder.1
MANCOMPRESSED= no
CONFFILES= codecs.conf example.conf input.conf
-DOCFILES= DVB bugreports.html cd-dvd.html codecs-in.html \
+DOCFILES= bugreports.html cd-dvd.html codecs-in.html \
codecs.html documentation.html faq.html skin-en.html \
- encoding.html formats.html sound.html tech/tech-eng.txt \
+ encoding.html formats.html sound.html \
users_against_developers.html \
video.html
@@ -61,6 +60,10 @@ WITH_SVGALIB= yes
WITH_SDL= yes
.endif
+.if exists(${LOCALBASE}/lib/libvorbis.so.2)
+WITH_VORBIS= yes
+.endif
+
.if exists(${LOCALBASE}/lib/libjpeg.so.9)
LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg
.endif
diff --git a/graphics/mplayer/distinfo b/graphics/mplayer/distinfo
index 34f07d2846f8..10d26e07bc53 100644
--- a/graphics/mplayer/distinfo
+++ b/graphics/mplayer/distinfo
@@ -1 +1 @@
-MD5 (MPlayer-0.90pre5.tar.bz2) = e5655c304af41b23701653eb7a810d3f
+MD5 (MPlayer-0.90pre6.tar.bz2) = 819b4db6133291886df34cadcc03e09d
diff --git a/graphics/mplayer/files/patch-ad b/graphics/mplayer/files/patch-ad
index 6550647eebf3..be62aea43499 100644
--- a/graphics/mplayer/files/patch-ad
+++ b/graphics/mplayer/files/patch-ad
@@ -1,6 +1,6 @@
---- configure.orig Mon Jun 10 20:46:18 2002
-+++ configure Mon Jun 10 20:48:32 2002
-@@ -469,19 +469,10 @@
+--- configure.orig Mon Aug 5 19:23:22 2002
++++ configure Wed Aug 7 12:47:05 2002
+@@ -480,19 +480,10 @@
# Try to find the available options for the current CPU
if x86 || ppc; then
@@ -20,7 +20,18 @@
pname=`$_cpuinfo | grep 'model name' | cut -d ':' -f 2 | head -1`
pvendor=`$_cpuinfo | grep 'vendor_id' | cut -d ':' -f 2 | cut -d ' ' -f 2 | head -1`
-@@ -1485,13 +1476,7 @@
+@@ -1246,8 +1237,8 @@
+ ;;
+
+ *)
+- echo "Unknown parameter: $ac_option"
+- exit
++ echo -n "Unknown parameter: $ac_option"
++ echo " (ignoring)"
+ ;;
+
+ esac
+@@ -1588,13 +1579,7 @@
echocheck "memalign()"
@@ -34,7 +45,7 @@
if test "$_memalign" = yes ; then
_def_memalign='#define HAVE_MEMALIGN 1'
else
-@@ -1568,31 +1553,7 @@
+@@ -1671,31 +1656,7 @@
echocheck "pthread"
@@ -57,47 +68,48 @@
- elif ( cc_check -pthread ) ; then
- _ld_pthread='-pthread'
- else
-- die "Static lib pthread not found. (needed by windows and networking stuff)"
+- die "Static lib pthread not found (needed by Windows and networking stufff)."
- fi
- else
-- die "Lib pthread not found. (needed by windows and networking stuff)"
+- die "Lib pthread not found (needed by Windows and networking stuff)."
- fi
-fi
+_ld_pthread="${PTHREAD_LIBS}"
echores "yes (using $_ld_pthread)"
-@@ -3219,11 +3180,7 @@
+@@ -3413,11 +3374,7 @@
echocheck "iconv"
if test "$_iconv" = auto ; then
- if freebsd ; then
- _iconv_tmp='#include <giconv.h>'
- else
- _iconv_tmp='#include <iconv.h>'
+- _iconv_tmp='#include <iconv.h>'
- fi
++ _iconv_tmp='#include <iconv.h>'
cat > $TMPC << EOF
#include <stdio.h>
#include <unistd.h>
-@@ -3257,7 +3214,7 @@
+@@ -3451,7 +3408,7 @@
EOF
_iconv=no
if freebsd ; then
- cc_check -lm -lgiconv && _iconv=yes
+ cc_check -lm -liconv && _iconv=yes
- elif bsdos ; then
+ elif bsdos || openbsd ; then
cc_check -lm -liconv && _iconv=yes
else
-@@ -3266,7 +3223,7 @@
+@@ -3460,7 +3417,7 @@
fi
if test "$_iconv" = yes ; then
_def_iconv='#define USE_ICONV 1'
- freebsd && _ld_iconv='-lgiconv'
+ freebsd && _ld_iconv='-liconv'
bsdos && _ld_iconv='-liconv'
+ openbsd && _ld_iconv='-liconv'
else
- _def_iconv='#undef USE_ICONV'
-@@ -3733,7 +3690,7 @@
+@@ -3979,7 +3936,7 @@
CFLAGS="$CFLAGS -D_REENTRANT"
elif bsd ; then
# FIXME bsd needs this so maybe other OS'es
diff --git a/graphics/mplayer/files/patch-ae b/graphics/mplayer/files/patch-ae
index f6d513c0d3f9..ad5ea9731aab 100644
--- a/graphics/mplayer/files/patch-ae
+++ b/graphics/mplayer/files/patch-ae
@@ -1,5 +1,5 @@
---- Makefile.orig Mon Jun 10 20:49:19 2002
-+++ Makefile Mon Jun 10 20:51:43 2002
+--- Makefile.orig Thu Jul 25 05:37:27 2002
++++ Makefile Wed Aug 7 13:07:21 2002
@@ -24,12 +24,12 @@
endif
@@ -14,7 +14,7 @@
-INSTALL = install
+INSTALL = @${BSD_INSTALL_PROGRAM}
- SRCS_COMMON = xacodec.c cpudetect.c codec-cfg.c cfgparser.c my_profile.c spudec.c playtree.c playtreeparser.c asxparser.c vobsub.c subreader.c find_sub.c
+ SRCS_COMMON = xacodec.c cpudetect.c codec-cfg.c cfgparser.c my_profile.c spudec.c playtree.c playtreeparser.c asxparser.c vobsub.c subreader.c sub_cc.c find_sub.c
SRCS_MENCODER = mencoder.c mp_msg-mencoder.c $(SRCS_COMMON) libao2/afmt.c divx4_vbr.c libvo/aclib.c libvo/osd.c libvo/sub.c libvo/font_load.c me-opt-reg.c
@@ -226,44 +226,11 @@
ifeq ($(VIDIX),yes)
@@ -54,7 +54,7 @@
-endif
-endif
-ifeq ($(CSS_USE),yes)
-- @echo "Following task requires root privs. If it fails don't panic"
+- @echo "The following task requires root privileges. If it fails don't panic,"
- @echo "however it means you can't use fibmap_mplayer."
- @echo "Without this (or without running mplayer as root) you won't be"
- @echo "able to play encrypted DVDs."
diff --git a/graphics/mplayer/pkg-plist b/graphics/mplayer/pkg-plist
index 26872a2ffad3..36514b014f5c 100644
--- a/graphics/mplayer/pkg-plist
+++ b/graphics/mplayer/pkg-plist
@@ -2,15 +2,12 @@ bin/mplayer
bin/mencoder
lib/libdha-0.1.so
lib/libdha.so
-lib/mplayer/vidix/genfb_vid.so
lib/mplayer/vidix/mach64_vid.so
lib/mplayer/vidix/mga_crtc2_vid.so
lib/mplayer/vidix/mga_vid.so
-lib/mplayer/vidix/nvidia_vid.so
lib/mplayer/vidix/pm3_vid.so
lib/mplayer/vidix/radeon_vid.so
lib/mplayer/vidix/rage128_vid.so
-%%PORTDOCS%%share/doc/mplayer/DVB
%%PORTDOCS%%share/doc/mplayer/bugreports.html
%%PORTDOCS%%share/doc/mplayer/cd-dvd.html
%%PORTDOCS%%share/doc/mplayer/codecs-in.html
@@ -22,7 +19,6 @@ lib/mplayer/vidix/rage128_vid.so
%%PORTDOCS%%share/doc/mplayer/skin-en.html
%%PORTDOCS%%share/doc/mplayer/sound.html
%%PORTDOCS%%share/doc/mplayer/video.html
-%%PORTDOCS%%share/doc/mplayer/tech-eng.txt
%%PORTDOCS%%share/doc/mplayer/users_against_developers.html
share/mplayer/codecs.conf
share/mplayer/example.conf