aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-03-10 06:29:13 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-03-10 06:29:13 +0000
commit957534e4ba2001e498cf832fc046da34e55a8e00 (patch)
treec67d3535ac39c55a1cb7fcd3ea10aeadb69e1dec /graphics
parent0d6c210a24165a76384526ee4187bad927a195fc (diff)
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gnash/Makefile16
-rw-r--r--graphics/gnash/pkg-plist3
2 files changed, 19 insertions, 0 deletions
diff --git a/graphics/gnash/Makefile b/graphics/gnash/Makefile
index de7d152f5c48..ca3764966f8b 100644
--- a/graphics/gnash/Makefile
+++ b/graphics/gnash/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnash
PORTVERSION= 0.8.8
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= GNU/${PORTNAME}/${PORTVERSION}/ \
http://mirror.amdmi3.ru/distfiles/
@@ -64,6 +65,7 @@ OPTIONS= PLUGIN "Enable browser plugin" on \
AGG "Renderer: AGG" on \
OPENGL "Renderer: OpenGL (broken)" off \
CAIRO "Renderer: Cairo (experimental)" off \
+ VAAPI "Enable VAAPI support (requres FFMPEG)" off \
FFMPEG "Media handler: ffmpeg (+SDL sound output)" on \
GSTREAMER "Media handler: GStreamer" off
@@ -197,6 +199,20 @@ IGNORE= needs at least one renderer enabled. Please rerun 'make config' and en
CONFIGURE_ARGS+= --enable-renderer=`${ECHO} ${GNASH_RENDERERS} | ${TR} ' ' ,`
#
+# Hardware acceleration options processing
+#
+.if defined(WITH_VAAPI) && !defined(WITHOUT_FFMPEG)
+. if !defined(WITH_VAAPI)
+IGNORE= VAAPI currently works only with FFMPEG. Please rerun 'make config' and enable FFMPEG.
+. endif
+LIB_DEPENDS+= va.1:${PORTSDIR}/multimedia/libva
+PLIST_SUB+= VAAPI=""
+.else
+CONFIGURE_ARGS+= --enable-hwaccel=none # XVideo
+PLIST_SUB+= VAAPI="@comment "
+.endif
+
+#
# Media handler options processing
#
.if defined(WITH_FFMPEG) && !defined(WITH_GSTREAMER)
diff --git a/graphics/gnash/pkg-plist b/graphics/gnash/pkg-plist
index f91edfe8aa98..a2cf59a9122a 100644
--- a/graphics/gnash/pkg-plist
+++ b/graphics/gnash/pkg-plist
@@ -224,6 +224,9 @@ lib/gnash/libgnashrender.so.0
lib/gnash/libgnashsound-%%GNASHVER%%.so
lib/gnash/libgnashsound.la
lib/gnash/libgnashsound.so
+%%VAAPI%%lib/gnash/libgnashvaapi-%%GNASHVER%%.so
+%%VAAPI%%lib/gnash/libgnashvaapi.la
+%%VAAPI%%lib/gnash/libgnashvaapi.so
@comment %%NPAPI%%lib/gnash/libmozsdk.la
@comment %%NPAPI%%lib/gnash/libmozsdk.so
@comment %%NPAPI%%lib/gnash/libmozsdk.so.0