aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-12-15 21:19:29 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-12-15 21:19:29 +0000
commitde4fbd451d80f12553933dcda7ccc9603f97fea2 (patch)
tree164c37b5fb2d687a6063cc997aa80d0dae06e0da /graphics
parent7f29f09f5694ade8d7e1a1f868a8b02fd711c0ac (diff)
downloadports-de4fbd451d80f12553933dcda7ccc9603f97fea2.tar.gz
ports-de4fbd451d80f12553933dcda7ccc9603f97fea2.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/sdl_gfx/Makefile14
-rw-r--r--graphics/sdl_gfx/distinfo2
-rw-r--r--graphics/sdl_gfx/pkg-plist2
3 files changed, 8 insertions, 10 deletions
diff --git a/graphics/sdl_gfx/Makefile b/graphics/sdl_gfx/Makefile
index 308e84c50090..f3870999e7f1 100644
--- a/graphics/sdl_gfx/Makefile
+++ b/graphics/sdl_gfx/Makefile
@@ -7,9 +7,9 @@
#
PORTNAME= sdl_gfx
-PORTVERSION= 2.0.9
+PORTVERSION= 2.0.10
CATEGORIES= graphics
-MASTER_SITES= http://www.ferzkopp.net/Software/%SUBDIR%/
+MASTER_SITES= http://www.ferzkopp.net/~aschiffler/Software/%SUBDIR%/
MASTER_SITE_SUBDIR= SDL_gfx-${PORTVERSION:R}
DISTNAME= SDL_gfx-${PORTVERSION}
@@ -20,7 +20,8 @@ USE_SDL= yes
USE_REINPLACE= yes
USE_GMAKE= yes
USE_LIBTOOL= yes
-CONFIGURE_ARGS= --disable-mmx
+CONFIGURE_ARGS= --includedir=${PREFIX}/include/SDL11 \
+ --disable-mmx
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
INSTALLS_SHLIB= yes
@@ -32,10 +33,7 @@ CFLAGS+= -DUSE_MMX
.endif
post-patch:
- @${REINPLACE_CMD} 's|^libSDL_gfxincludedir.*|&/SDL11|' \
- ${WRKSRC}/Makefile.in
-.for file in configure SDL_gfxPrimitives.h SDL_framerate.h SDL_rotozoom.h
- @${REINPLACE_CMD} 's|<SDL/SDL|<SDL|g' ${WRKSRC}/${file}
-.endfor
+ @${GREP} -lR "<SDL/SDL" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|<SDL/SDL|<SDL|g'
.include <bsd.port.post.mk>
diff --git a/graphics/sdl_gfx/distinfo b/graphics/sdl_gfx/distinfo
index e3a9512a4dd2..0b8ad49ef1a0 100644
--- a/graphics/sdl_gfx/distinfo
+++ b/graphics/sdl_gfx/distinfo
@@ -1 +1 @@
-MD5 (SDL_gfx-2.0.9.tar.gz) = ed54191818990c092553a08e488ad35e
+MD5 (SDL_gfx-2.0.10.tar.gz) = 291b06426a3afe42ecac8473be2505d1
diff --git a/graphics/sdl_gfx/pkg-plist b/graphics/sdl_gfx/pkg-plist
index 8cb7a4111967..8f92f4a02a82 100644
--- a/graphics/sdl_gfx/pkg-plist
+++ b/graphics/sdl_gfx/pkg-plist
@@ -5,4 +5,4 @@ include/SDL11/SDL_imageFilter.h
include/SDL11/SDL_rotozoom.h
lib/libSDL_gfx.a
lib/libSDL_gfx.so
-lib/libSDL_gfx.so.9
+lib/libSDL_gfx.so.10