aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2006-03-15 07:10:44 +0000
committerVasil Dimov <vd@FreeBSD.org>2006-03-15 07:10:44 +0000
commit02dd6f1e33a32f2c45c67c69198ac9caeb2a2a40 (patch)
tree370f8d543e4f4b32f4f13a4f885b59540c8aba18 /graphics
parent4fcab4c05c03c841e042469c350da2b0dd3fcd49 (diff)
downloadports-02dd6f1e33a32f2c45c67c69198ac9caeb2a2a40.tar.gz
ports-02dd6f1e33a32f2c45c67c69198ac9caeb2a2a40.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile2
-rw-r--r--graphics/quickpics/Makefile35
-rw-r--r--graphics/quickpics/distinfo3
-rw-r--r--graphics/quickpics/files/patch-aa36
-rw-r--r--graphics/quickpics/files/patch-ab47
-rw-r--r--graphics/quickpics/files/patch-ac19
-rw-r--r--graphics/quickpics/files/patch-src-dir.c17
-rw-r--r--graphics/quickpics/pkg-descr12
-rw-r--r--graphics/quickpics/pkg-plist3
-rw-r--r--graphics/threeDS/Makefile36
-rw-r--r--graphics/threeDS/distinfo3
-rw-r--r--graphics/threeDS/pkg-descr5
-rw-r--r--graphics/threeDS/pkg-plist6
13 files changed, 0 insertions, 224 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 70b6957e854b..cb10ef8d4451 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -500,7 +500,6 @@
SUBDIR += quat
SUBDIR += quat-gui
SUBDIR += quesa
- SUBDIR += quickpics
SUBDIR += qvplay
SUBDIR += ray++
SUBDIR += rayshade
@@ -564,7 +563,6 @@
SUBDIR += telak
SUBDIR += tgif
SUBDIR += tgif-nls
- SUBDIR += threeDS
SUBDIR += tif22pnm
SUBDIR += tiff
SUBDIR += tiff2png
diff --git a/graphics/quickpics/Makefile b/graphics/quickpics/Makefile
deleted file mode 100644
index 7b521d548546..000000000000
--- a/graphics/quickpics/Makefile
+++ /dev/null
@@ -1,35 +0,0 @@
-# New ports collection makefile for: QuickPics
-# Date Created: 10 March 2000
-# Whom: Stever <stever@transmission23.com>
-#
-# $FreeBSD$
-#
-
-PORTNAME= quickpics
-PORTVERSION= 1.8
-PORTREVISION= 1
-CATEGORIES= graphics
-MASTER_SITES= #
-DISTNAME= QuickPics-${PORTVERSION}
-
-MAINTAINER= bifrost@kizmiaz.dis.org
-COMMENT= A really handy tool for large image collections and digital cameras
-
-DEPRECATED= mastersite disappeared, no longer maintained by author
-EXPIRATION_DATE= 2006-02-28
-
-LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
-
-WRKSRC= ${WRKDIR}/${DISTNAME}/src
-
-GNU_CONFIGURE= yes
-ALL_TARGET= qp
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/qp ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/qp
- ${INSTALL_DATA} ${WRKSRC}/../README ${PREFIX}/share/doc/qp
-.endif
-
-.include <bsd.port.mk>
diff --git a/graphics/quickpics/distinfo b/graphics/quickpics/distinfo
deleted file mode 100644
index 408d2c4bfaaa..000000000000
--- a/graphics/quickpics/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (QuickPics-1.8.tar.gz) = 5f11c29d7dabeeceb56a81a0292a9dbf
-SHA256 (QuickPics-1.8.tar.gz) = eb1b62dc2765dee29d2cf397a490de961dac4e0b63706d10e32976fbe21f7d28
-SIZE (QuickPics-1.8.tar.gz) = 588304
diff --git a/graphics/quickpics/files/patch-aa b/graphics/quickpics/files/patch-aa
deleted file mode 100644
index df9b1276f81f..000000000000
--- a/graphics/quickpics/files/patch-aa
+++ /dev/null
@@ -1,36 +0,0 @@
---- Makefile.in.orig Fri Sep 18 23:23:19 1998
-+++ Makefile.in Sun Apr 30 18:42:42 2000
-@@ -7,18 +7,19 @@
- #############################################################################
-
- # Executable name
--INST_NAME = ../qp
-+INST_NAME = qp
-
- DEFINES = -DHAVE_CONFIG_H
-
- # Do you have libjpeg already on your system? If so, set this.
--LIBJPEGPATH = ../jpeg-6a
-+LIBJPEGPATH = ${PREFIX}/lib
-+INCJPEGPATH = ${PREFIX}/include
-
-+CC ?= gcc
-+CFLAGS ?= -fno-strength-reduce -Wall -Wno-implicit @CFLAGS@
-
--CC = gcc
--CFLAGS = -fno-strength-reduce -Wall -Wno-implicit @CFLAGS@
- CLINKFLAGS = @LIBS@
--INCLUDEDIRS = -I. -I$(LIBJPEGPATH)
-+INCLUDEDIRS = -I. -I$(INCJPEGPATH)
-
-
- # No need to change anything below this line
-@@ -28,7 +29,7 @@
- SOURCES = html.c qp.c image.c dir.c utility.c main.c
-
- $(INST_NAME): $(OBJECTS)
-- $(CC) -o $(INST_NAME) $(OBJECTS) $(LIBJPEGPATH)/libjpeg.a $(CLINKFLAGS)
-+ $(CC) -o $(INST_NAME) $(OBJECTS) $(CLINKFLAGS) -ljpeg
- @echo ""
- @echo "Successful compile: $(INST_NAME)"
- @echo ""
diff --git a/graphics/quickpics/files/patch-ab b/graphics/quickpics/files/patch-ab
deleted file mode 100644
index ac80e6a70341..000000000000
--- a/graphics/quickpics/files/patch-ab
+++ /dev/null
@@ -1,47 +0,0 @@
---- main.c.orig Sun Apr 30 18:43:28 2000
-+++ main.c Sun Apr 30 18:44:14 2000
-@@ -21,7 +21,7 @@
- /* Prototypes */
- void do_arg(char *arg);
-
--void main(int argc, char **argv)
-+int main(int argc, char **argv)
- {
- char cwd[MAXTEXTLEN], yn[1024];
- int first_time = 0, i;
-@@ -53,7 +53,7 @@
- if(!IsDirectory(QP.rootdir))
- {
- printf("*** ERROR: \"%s\" is not a directory.\n",QP.rootdir);
-- return;
-+ return 1;
- }
- chmod(QP.rootdir,0755);
-
-@@ -62,7 +62,7 @@
- if(chdir(QP.rootdir) != 0)
- {
- printf("*** ERROR: Unable to change to directory \"%s\".\n",QP.rootdir);
-- return;
-+ return 1;
- }
-
- /* Read configfile from specified directory. */
-@@ -102,7 +102,7 @@
- printf(" Execution halted.\n");
- printf(" Config file is: %s/%s.\n",BaseFilename(QP.rootdir),QP.configfile);
- printf("\n");
-- return;
-+ return 1;
- }
-
- printf("\n");
-@@ -169,7 +169,7 @@
- printf(" Use the link \"%s/%s\" to view the gallery.\n",BaseFilename(QP.rootdir),QP.index_html);
- printf(" Have fun!\n");
- printf("\n");
-- return;
-+ return 0;
- }
-
- void do_arg(char *arg)
diff --git a/graphics/quickpics/files/patch-ac b/graphics/quickpics/files/patch-ac
deleted file mode 100644
index 1c8d6b4bd980..000000000000
--- a/graphics/quickpics/files/patch-ac
+++ /dev/null
@@ -1,19 +0,0 @@
-*** image.c.orig Tue Sep 25 09:25:40 2001
---- image.c Tue Sep 25 09:26:26 2001
-***************
-*** 205,211 ****
- cinfo.image_width = output_width;
- cinfo.image_height = output_height;
- cinfo.input_components = out_color_components;
-! cinfo.in_color_space = JCS_RGB;
-
- /* compression parameters */
- jpeg_set_defaults(&cinfo);
---- 205,211 ----
- cinfo.image_width = output_width;
- cinfo.image_height = output_height;
- cinfo.input_components = out_color_components;
-! cinfo.in_color_space = dinfo.out_color_space;
-
- /* compression parameters */
- jpeg_set_defaults(&cinfo);
diff --git a/graphics/quickpics/files/patch-src-dir.c b/graphics/quickpics/files/patch-src-dir.c
deleted file mode 100644
index 6f427b5f2cf2..000000000000
--- a/graphics/quickpics/files/patch-src-dir.c
+++ /dev/null
@@ -1,17 +0,0 @@
---- dir.c.orig Tue Apr 7 03:31:14 1998
-+++ dir.c Fri Aug 23 20:08:24 2002
-@@ -479,12 +479,12 @@
- rmspace(description);
- if(!description[0])
- {
-- sprintf(description,"Description of %s goes here.",
-+ sprintf(description,"%s",
- img->name);
- }
- }
- else
-- sprintf(description,"Description of %s goes here.",
-+ sprintf(description,"%s",
- img->name);
-
- imgrec_setdescription(img,description);
diff --git a/graphics/quickpics/pkg-descr b/graphics/quickpics/pkg-descr
deleted file mode 100644
index 223720286735..000000000000
--- a/graphics/quickpics/pkg-descr
+++ /dev/null
@@ -1,12 +0,0 @@
-QuickPics is a unix-based application that creates an HTML web gallery
-based on the directory structure and the images therein. All thumbnails
-are created by the program using direct calls to the jpeg library for
-fast thumbnail creation. One of my main requirements is that it will not
-not have to rely on CGI access to run. It also does not need require
-Perl or other jpeg libraries. Only the executable 'qp' is needed to
-create any gallery of any size.
-
-If you have an image gallery and you are tired of editing all the HTML
-pages and resizing thumbnails, try QuickPics.
-
-by Steve Rider - stever@retina.net
diff --git a/graphics/quickpics/pkg-plist b/graphics/quickpics/pkg-plist
deleted file mode 100644
index d5f82caaed3a..000000000000
--- a/graphics/quickpics/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-bin/qp
-share/doc/qp/README
-@dirrm share/doc/qp
diff --git a/graphics/threeDS/Makefile b/graphics/threeDS/Makefile
deleted file mode 100644
index 55bf6258d442..000000000000
--- a/graphics/threeDS/Makefile
+++ /dev/null
@@ -1,36 +0,0 @@
-# New ports collection makefile for: threeDS
-# Date created: 5 December 2000
-# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= threeDS
-PORTVERSION= 0.3.1
-PORTREVISION= 1
-CATEGORIES= graphics python
-MASTER_SITES= http://www.demonseed.net/~jp/code/threeDS/
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A Python module and viewer for loading and displaying models in 3DS format
-
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/OpenGL/__init__.py:${PORTSDIR}/graphics/py-opengl
-
-USE_PYTHON= yes
-
-DEPRECATED= dead project
-EXPIRATION_DATE= 2006-02-28
-IGNORE= does not run
-
-do-build:
- ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py -l ${WRKSRC}
-
-do-install:
- ${MKDIR} ${PREFIX}/share/threeDS
- ${MKDIR} ${PREFIX}/lib/${PYTHON_VERSION}/site-packages
- ${RM} -f ${WRKSRC}/*.orig
- ${INSTALL_DATA} ${WRKSRC}/threeDS.py* ${PREFIX}/lib/${PYTHON_VERSION}/site-packages
- ${INSTALL_SCRIPT} ${WRKSRC}/view3ds.py* ${PREFIX}/share/threeDS
- ${LN} -sf ${PREFIX}/share/threeDS/view3ds.py ${PREFIX}/bin/view3ds
-
-.include <bsd.port.mk>
diff --git a/graphics/threeDS/distinfo b/graphics/threeDS/distinfo
deleted file mode 100644
index 495311146454..000000000000
--- a/graphics/threeDS/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (threeDS-0.3.1.tar.gz) = d615b23a12a0dd0bb9d91d4965ef47dc
-SHA256 (threeDS-0.3.1.tar.gz) = 70795ac6d35c1b3e2aea71d0527afff7a678b65b9b34c9c077c0718c3e009d08
-SIZE (threeDS-0.3.1.tar.gz) = 13047
diff --git a/graphics/threeDS/pkg-descr b/graphics/threeDS/pkg-descr
deleted file mode 100644
index 9ea1bb163a97..000000000000
--- a/graphics/threeDS/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-ThreeDS is a Python module for loading and displaying 3D models in the
-3DStudio Max 3DS format. It comes with view3DS, a simple model viewer written
-in Python.
-
-WWW: http://www.demonseed.net/~jp/code/threeDS/index.html
diff --git a/graphics/threeDS/pkg-plist b/graphics/threeDS/pkg-plist
deleted file mode 100644
index c8c8127e0c00..000000000000
--- a/graphics/threeDS/pkg-plist
+++ /dev/null
@@ -1,6 +0,0 @@
-bin/view3ds
-lib/%%PYTHON_VERSION%%/site-packages/threeDS.py
-lib/%%PYTHON_VERSION%%/site-packages/threeDS.pyc
-share/threeDS/view3ds.py
-share/threeDS/view3ds.pyc
-@dirrm share/threeDS