aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2017-03-28 09:05:39 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2017-03-28 09:05:39 +0000
commit069eb5d63d5e4b6bf5f627b99250eefcee25b759 (patch)
treef856b089e9a3ec600c7c2951efca3b6237d9f466 /graphics
parentb3a7fcbada27616a9478958476078073a9e20e71 (diff)
downloadports-069eb5d63d5e4b6bf5f627b99250eefcee25b759.tar.gz
ports-069eb5d63d5e4b6bf5f627b99250eefcee25b759.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/digikam-kde4/Makefile.common15
-rw-r--r--graphics/kipi-plugin-ipodexport/files/patch-cmake_modules_FindIpod.cmake26
-rw-r--r--graphics/kipi-plugins-kde4/files/extrapatch-CMakeLists.txt7
3 files changed, 47 insertions, 1 deletions
diff --git a/graphics/digikam-kde4/Makefile.common b/graphics/digikam-kde4/Makefile.common
index 5f3d00ff5c04..a2b2d0d40136 100644
--- a/graphics/digikam-kde4/Makefile.common
+++ b/graphics/digikam-kde4/Makefile.common
@@ -144,5 +144,20 @@ BUILD_WRKSRC= ${WRKSRC}/${${KIPI_PLUGIN}_DIR}
INSTALL_WRKSRC= ${BUILD_WRKSRC}
${KIPI_PLUGIN}_DIR?= ${KIPI_PLUGIN}
+
+.if ${KIPI_PLUGIN} != "libkipiplugins"
+# Each plugin is built separately from the same tarball. The upstream build
+# process expects a single build for all plugins, which includes building
+# libkipiplugins itself.
+# Adjust it (together with extrapatch-CMakeLists.txt in
+# graphics/kipi-plugins-kde4) by actually looking for libkipiplugins with
+# find_library() and linking against it instead of ending up just passing
+# "-lkipiplugins" to the linker because of the way we build these ports.
+post-patch: kipi-plugin-post-patch
+kipi-plugin-post-patch:
+ ${FIND} ${BUILD_WRKSRC} -name CMakeLists.txt | ${XARGS} ${REINPLACE_CMD} -e \
+ 's, kipiplugins, $${LIBKIPIPLUGINS_LIBRARIES},' \
+ ${BUILD_WRKSRC}/CMakeLists.txt
+.endif
. endif # defined(KIPI_PLUGIN)
.endif # !defined(NO_BUILD)
diff --git a/graphics/kipi-plugin-ipodexport/files/patch-cmake_modules_FindIpod.cmake b/graphics/kipi-plugin-ipodexport/files/patch-cmake_modules_FindIpod.cmake
new file mode 100644
index 000000000000..62a7a598cde2
--- /dev/null
+++ b/graphics/kipi-plugin-ipodexport/files/patch-cmake_modules_FindIpod.cmake
@@ -0,0 +1,26 @@
+Always look for libgpod using CMake instead of just using the pkg-config call
+directly, as the latter does not use full paths.
+--- cmake/modules/FindIpod.cmake
++++ cmake/modules/FindIpod.cmake
+@@ -14,12 +14,6 @@ if (IPOD_INCLUDE_DIRS AND IPOD_LIBRARIES)
+ SET(IPOD_FOUND TRUE)
+
+ else (IPOD_INCLUDE_DIRS AND IPOD_LIBRARIES)
+- if(NOT WIN32)
+- # use pkg-config to get the directories and then use these values
+- # in the FIND_PATH() and FIND_LIBRARY() calls
+- find_package(PkgConfig)
+- PKG_SEARCH_MODULE(IPOD libgpod-1.0)
+- else(NOT WIN32)
+ find_path(IPOD_INCLUDE_DIRS
+ NAMES
+ gpod/itdb.h
+@@ -32,7 +26,7 @@ else (IPOD_INCLUDE_DIRS AND IPOD_LIBRARIES)
+ if(IPOD_INCLUDE_DIRS AND IPOD_LIBRARIES)
+ set(IPOD_FOUND ON)
+ endif(IPOD_INCLUDE_DIRS AND IPOD_LIBRARIES)
+- endif(NOT WIN32)
++
+ IF (IPOD_FOUND)
+ IF (NOT IPOD_FIND_QUIETLY)
+ MESSAGE(STATUS "Found libgpod-1 ${IPOD_VERSION}")
diff --git a/graphics/kipi-plugins-kde4/files/extrapatch-CMakeLists.txt b/graphics/kipi-plugins-kde4/files/extrapatch-CMakeLists.txt
index 552aa033329b..aa02b2154659 100644
--- a/graphics/kipi-plugins-kde4/files/extrapatch-CMakeLists.txt
+++ b/graphics/kipi-plugins-kde4/files/extrapatch-CMakeLists.txt
@@ -1,10 +1,15 @@
+The first hunk looks for libkipiplugins via CMake, as we split every kipi
+plugin as well as the common code into separate ports. Not using CMake results
+in "kipiplugins" in a target_link_libraries() call becoming a literal
+-lkipiplugins being passed to the linker instead of /path/to/libkipiplugin.so.
--- ./CMakeLists.txt.orig 2015-02-25 22:15:14.659030000 +0100
+++ ./CMakeLists.txt 2015-02-25 22:17:07.071209000 +0100
-@@ -356,7 +356,6 @@
+@@ -391,7 +391,7 @@ if(KIPI_FOUND)
# Plugins which will be always compiled
- add_subdirectory(common)
++ find_library(LIBKIPIPLUGINS_LIBRARIES kipiplugins)
add_subdirectory(timeadjust)
add_subdirectory(jpeglossless)
add_subdirectory(rawconverter)