aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2011-11-22 14:44:50 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2011-11-22 14:44:50 +0000
commit46cfeadee61d579925c34214467ef368c7d8247c (patch)
treed788bb3b14cbfbba369f2fe5d7d5d90168023d7e /graphics
parent0a476a78bf42687c39958da9b88eee7a33d71693 (diff)
downloadports-46cfeadee61d579925c34214467ef368c7d8247c.tar.gz
ports-46cfeadee61d579925c34214467ef368c7d8247c.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/djvulibre-nox11/Makefile3
-rw-r--r--graphics/djvulibre-nox11/files/patch-libdjvu__GSmartPointer.h10
2 files changed, 11 insertions, 2 deletions
diff --git a/graphics/djvulibre-nox11/Makefile b/graphics/djvulibre-nox11/Makefile
index 7bd5102d81cb..73aa8d034af8 100644
--- a/graphics/djvulibre-nox11/Makefile
+++ b/graphics/djvulibre-nox11/Makefile
@@ -29,8 +29,7 @@ CONFIGURE_ENV= JPEG_CFLAGS="-I${LOCALBASE}/include" \
TIFF_LIBS="-L${LOCALBASE}/lib -ltiff" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
- LOCALBASE="${LOCALBASE}" \
- CXX="${CXX}"
+ LOCALBASE="${LOCALBASE}"
CONFIGURE_ARGS= --enable-threads=pthread --enable-shared
USE_LDCONFIG= yes
diff --git a/graphics/djvulibre-nox11/files/patch-libdjvu__GSmartPointer.h b/graphics/djvulibre-nox11/files/patch-libdjvu__GSmartPointer.h
new file mode 100644
index 000000000000..577600f5cd01
--- /dev/null
+++ b/graphics/djvulibre-nox11/files/patch-libdjvu__GSmartPointer.h
@@ -0,0 +1,10 @@
+--- libdjvu/GSmartPointer.h.orig 2011-03-06 12:43:17.000000000 -0500
++++ libdjvu/GSmartPointer.h 2011-11-22 09:16:50.000000000 -0500
+@@ -94,6 +94,7 @@
+ #pragma warning( disable : 4243 )
+ #endif
+
++#include <stddef.h>
+ #include "DjVuGlobal.h"
+ #include "atomic.h"
+