aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2017-03-28 09:32:25 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2017-03-28 09:32:25 +0000
commit4ba3f6931da91e790b18d5204f7d3d2e07d8dbcd (patch)
tree4ccf180ac8b9d39bae274e1f794d59283729a98d /graphics
parent8cf8d910b7e1ec1f2f539aa3d7c1ae26541494bd (diff)
downloadports-4ba3f6931da91e790b18d5204f7d3d2e07d8dbcd.tar.gz
ports-4ba3f6931da91e790b18d5204f7d3d2e07d8dbcd.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/kphotoalbum-kde4/files/patch-git_f785317b29
1 files changed, 29 insertions, 0 deletions
diff --git a/graphics/kphotoalbum-kde4/files/patch-git_f785317b b/graphics/kphotoalbum-kde4/files/patch-git_f785317b
new file mode 100644
index 000000000000..6965b00d5e43
--- /dev/null
+++ b/graphics/kphotoalbum-kde4/files/patch-git_f785317b
@@ -0,0 +1,29 @@
+Fix the build with kdelibs4 4.14.30.
+
+commit f785317ba88528760886b592aa9604b0c4ba62dd
+Author: David Faure <faure@kde.org>
+Date: Sun Jul 26 18:12:24 2015 +0200
+
+ set cmake_min_req to 2.8.9 to match kdelibs4 policy; fix build accordingly
+
+ (working around the lack of ${KDE4_KMEDIAPLAYER_LIBS})
+
+ CCMAIL: kde-buildsystem@kde.org
+
+--- CMakeLists.txt
++++ CMakeLists.txt
+@@ -1,4 +1,4 @@
+-cmake_minimum_required( VERSION 2.6.2 FATAL_ERROR )
++cmake_minimum_required(VERSION 2.8.9)
+ project(kphotoalbum)
+
+ # provide drop-down menu for build-type in cmake-gui:
+@@ -364,7 +364,7 @@ kde4_add_library(Utilities STATIC ${libUtilities_SRCS})
+ target_link_libraries(kphotoalbum Utilities)
+
+ # External components
+-target_link_libraries(kphotoalbum ${KDE4_KIO_LIBS} ${JPEG_LIBRARY} kmediaplayer ${KDE4_PHONON_LIBS})
++target_link_libraries(kphotoalbum ${KDE4_KIO_LIBS} ${JPEG_LIBRARY} ${KDE4_TARGET_PREFIX}kmediaplayer ${KDE4_PHONON_LIBS})
+
+ if(KIPI_FOUND)
+ target_link_libraries(kphotoalbum ${KIPI_LIBRARIES})