aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-04-17 17:56:11 +0000
committerWill Andrews <will@FreeBSD.org>2001-04-17 17:56:11 +0000
commit54c02e5a6c0880d7876497c092ad30b98640b7e0 (patch)
treeb64f91d0f6d34e619e8511682dd8ac25bcc45382 /graphics
parent4b1de5d5399f335d958e097ae2eabb774ad2f2ed (diff)
downloadports-54c02e5a6c0880d7876497c092ad30b98640b7e0.tar.gz
ports-54c02e5a6c0880d7876497c092ad30b98640b7e0.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/iview/Makefile23
-rw-r--r--graphics/iview/distinfo1
-rw-r--r--graphics/iview/pkg-comment1
-rw-r--r--graphics/iview/pkg-descr3
-rw-r--r--graphics/iview/pkg-plist1
-rw-r--r--graphics/vp/Makefile23
-rw-r--r--graphics/vp/distinfo1
-rw-r--r--graphics/vp/pkg-comment1
-rw-r--r--graphics/vp/pkg-descr3
-rw-r--r--graphics/vp/pkg-plist1
11 files changed, 59 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index b9e20f13c027..8b6615647855 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -92,6 +92,7 @@
SUBDIR += imlib2
SUBDIR += ipe
SUBDIR += isreal
+ SUBDIR += iview
SUBDIR += jbigkit
SUBDIR += jgraph
SUBDIR += jgv
diff --git a/graphics/iview/Makefile b/graphics/iview/Makefile
new file mode 100644
index 000000000000..4a9f6fdeeeaf
--- /dev/null
+++ b/graphics/iview/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: iview
+# Date created: Apr 13, 2001
+# Whom: Mark Pulford <mark@kyne.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= iview
+PORTVERSION= 1.01
+CATEGORIES= graphics
+MASTER_SITES= http://math.smsu.edu/~erik/files/
+
+MAINTAINER= mark@kyne.com.au
+
+LIB_DEPENDS= SDL_image.10:${PORTSDIR}/graphics/sdl_image
+
+SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" CPPFLAGS="-I${LOCALBASE}/include"
+
+MAN1= iview.1
+
+.include <bsd.port.mk>
diff --git a/graphics/iview/distinfo b/graphics/iview/distinfo
new file mode 100644
index 000000000000..fbac8677e81a
--- /dev/null
+++ b/graphics/iview/distinfo
@@ -0,0 +1 @@
+MD5 (iview-1.01.tar.gz) = f1e290df5bd9d5b152a1aa9988856dce
diff --git a/graphics/iview/pkg-comment b/graphics/iview/pkg-comment
new file mode 100644
index 000000000000..21519d64c633
--- /dev/null
+++ b/graphics/iview/pkg-comment
@@ -0,0 +1 @@
+An image viewer for X
diff --git a/graphics/iview/pkg-descr b/graphics/iview/pkg-descr
new file mode 100644
index 000000000000..dca9249b0e63
--- /dev/null
+++ b/graphics/iview/pkg-descr
@@ -0,0 +1,3 @@
+Iview is an SDL based image viewer.
+
+WWW: http://math.smsu.edu/~erik/software.php?id=63
diff --git a/graphics/iview/pkg-plist b/graphics/iview/pkg-plist
new file mode 100644
index 000000000000..83cd5d9cd246
--- /dev/null
+++ b/graphics/iview/pkg-plist
@@ -0,0 +1 @@
+bin/iview
diff --git a/graphics/vp/Makefile b/graphics/vp/Makefile
new file mode 100644
index 000000000000..4a9f6fdeeeaf
--- /dev/null
+++ b/graphics/vp/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: iview
+# Date created: Apr 13, 2001
+# Whom: Mark Pulford <mark@kyne.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= iview
+PORTVERSION= 1.01
+CATEGORIES= graphics
+MASTER_SITES= http://math.smsu.edu/~erik/files/
+
+MAINTAINER= mark@kyne.com.au
+
+LIB_DEPENDS= SDL_image.10:${PORTSDIR}/graphics/sdl_image
+
+SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" CPPFLAGS="-I${LOCALBASE}/include"
+
+MAN1= iview.1
+
+.include <bsd.port.mk>
diff --git a/graphics/vp/distinfo b/graphics/vp/distinfo
new file mode 100644
index 000000000000..fbac8677e81a
--- /dev/null
+++ b/graphics/vp/distinfo
@@ -0,0 +1 @@
+MD5 (iview-1.01.tar.gz) = f1e290df5bd9d5b152a1aa9988856dce
diff --git a/graphics/vp/pkg-comment b/graphics/vp/pkg-comment
new file mode 100644
index 000000000000..21519d64c633
--- /dev/null
+++ b/graphics/vp/pkg-comment
@@ -0,0 +1 @@
+An image viewer for X
diff --git a/graphics/vp/pkg-descr b/graphics/vp/pkg-descr
new file mode 100644
index 000000000000..dca9249b0e63
--- /dev/null
+++ b/graphics/vp/pkg-descr
@@ -0,0 +1,3 @@
+Iview is an SDL based image viewer.
+
+WWW: http://math.smsu.edu/~erik/software.php?id=63
diff --git a/graphics/vp/pkg-plist b/graphics/vp/pkg-plist
new file mode 100644
index 000000000000..83cd5d9cd246
--- /dev/null
+++ b/graphics/vp/pkg-plist
@@ -0,0 +1 @@
+bin/iview