aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-02-21 05:22:30 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-02-21 05:22:30 +0000
commitd4885f853388748a2d64ebfa889e470de40863d4 (patch)
tree3799c5388545641dbd92ec72838aae7de9e4544e /graphics
parent569b7740e19a4f8da29ebdf04f06e88a489b75a8 (diff)
downloadports-d4885f853388748a2d64ebfa889e470de40863d4.tar.gz
ports-d4885f853388748a2d64ebfa889e470de40863d4.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/netpbm/Makefile2
-rw-r--r--graphics/netpbm/files/patch-editor-pnmquant39
2 files changed, 40 insertions, 1 deletions
diff --git a/graphics/netpbm/Makefile b/graphics/netpbm/Makefile
index d329351f31c0..779532f55383 100644
--- a/graphics/netpbm/Makefile
+++ b/graphics/netpbm/Makefile
@@ -7,7 +7,7 @@
PORTNAME= netpbm
PORTVERSION= 10.20
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/graphics/netpbm/files/patch-editor-pnmquant b/graphics/netpbm/files/patch-editor-pnmquant
new file mode 100644
index 000000000000..cb5b95577662
--- /dev/null
+++ b/graphics/netpbm/files/patch-editor-pnmquant
@@ -0,0 +1,39 @@
+--- editor/pnmquant Tue Dec 16 17:34:11 2003
++++ editor/pnmquant.new Fri Feb 20 14:31:03 2004
+@@ -13,7 +13,8 @@
+ use Getopt::Long;
+ use File::Temp "tempfile";
+ use File::Spec;
+-use Fcntl ":seek";
++use Fcntl;
++use POSIX qw(SEEK_SET SEEK_CUR SEEK_END);
+
+ my ($TRUE, $FALSE) = (1,0);
+
+@@ -52,7 +53,7 @@
+ my $infile;
+ my $ncolors = $ARGV[0];
+
+- if (!($ncolors =~ m{ ^[[:digit:]]+$ }x ) || $ncolors == 0) {
++ if (!($ncolors =~ m{ ^[\d]+$ }x ) || $ncolors == 0) {
+ print(STDERR
+ "Number of colors argument '$ncolors' is not a positive " .
+ "integer.\n");
+@@ -111,7 +112,7 @@
+ tell(INFH); # Avoids bogus "INFH is not referenced" warning
+ }
+ } else {
+- open(STDIN, "<", $infile)
++ open(STDIN, "<" . $infile)
+ or die("Unable to open input file '$infile'. Errno=$ERRNO");
+ }
+ }
+@@ -152,7 +153,7 @@
+ $spreadOpt = "-spreadbrightness";
+ }
+
+- open(STDOUT, ">", $mapfileSpec);
++ open(STDOUT, ">" . $mapfileSpec);
+
+ my $maprc = system("pnmcolormap", $ncolors, $averageOpt, $spreadOpt);
+