aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-05-14 02:31:03 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-05-14 02:31:03 +0000
commit18b398dc4013a9239364ae1f6de2d35b0dd3796b (patch)
treefc7a24948478de0508e3ba548603a24a2827998d /graphics
parent4db042de35ba4e76f10b6a8ba8955788624ea851 (diff)
downloadports-18b398dc4013a9239364ae1f6de2d35b0dd3796b.tar.gz
ports-18b398dc4013a9239364ae1f6de2d35b0dd3796b.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gphoto2/Makefile25
-rw-r--r--graphics/gphoto2/pkg-plist21
2 files changed, 27 insertions, 19 deletions
diff --git a/graphics/gphoto2/Makefile b/graphics/gphoto2/Makefile
index dd32e53e5a29..6c7c791f162b 100644
--- a/graphics/gphoto2/Makefile
+++ b/graphics/gphoto2/Makefile
@@ -7,26 +7,28 @@
PORTNAME= gphoto2
PORTVERSION= 2.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics
-MASTER_SITES= http://www.gphoto.net/dist/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://www.gphoto.net/dist/
+MASTER_SITE_SUBDIR= gphoto
MAINTAINER= ports@FreeBSD.org
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
LIB_DEPENDS= intl.2:${PORTSDIR}/devel/gettext \
usb-0.1.5:${PORTSDIR}/devel/libusb \
aa.1:${PORTSDIR}/graphics/aalib \
jpeg.9:${PORTSDIR}/graphics/jpeg \
exif.5:${PORTSDIR}/graphics/libexif
-BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
+USE_GLIB= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --without-cdk --without-fig2dev \
- --with-doc-dir=${DOCSDIR}
+CONFIGURE_ARGS= --without-cdk --without-fig2dev
INSTALLS_SHLIB= yes
MAN1= gphoto2.1
@@ -39,6 +41,17 @@ post-patch:
.endfor
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${PERL} -pi -e \
's|\@INSTALL\@|${INSTALL_CMD}|g ; \
- s|AUTHORS COPYING README|AUTHORS README|g'
+ s| install-docDATA||g ; \
+ s| install-figureDATA||g ; \
+ s|`glib-config|`\$$\(GLIB_CONFIG\)|g ; \
+ s|\$$\(libdir\)/pkgconfig|\$$\(prefix\)/libdata/pkgconfig|g'
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in AUTHORS NEWS README doc/FAQ doc/gphoto2-cli.txt doc/gphoto2.txt
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
.include <bsd.port.mk>
diff --git a/graphics/gphoto2/pkg-plist b/graphics/gphoto2/pkg-plist
index d97c2a8fb841..f90a4c4ebadf 100644
--- a/graphics/gphoto2/pkg-plist
+++ b/graphics/gphoto2/pkg-plist
@@ -53,15 +53,13 @@ lib/libgphoto2.so.2
lib/libgphoto2_port.a
lib/libgphoto2_port.so
lib/libgphoto2_port.so.0
-lib/pkgconfig/libgphoto2.pc
-share/doc/gphoto2/AUTHORS
-share/doc/gphoto2/FAQ
-share/doc/gphoto2/NEWS
-share/doc/gphoto2/README
-share/doc/gphoto2/gphoto2-cli.txt
-share/doc/gphoto2/gphoto2.txt
-share/doc/gphoto2/linux-hotplug/usbcam.console
-share/doc/gphoto2/linux-hotplug/usbcam.group
+libdata/pkgconfig/libgphoto2.pc
+%%PORTDOCS%%share/doc/gphoto2/AUTHORS
+%%PORTDOCS%%share/doc/gphoto2/FAQ
+%%PORTDOCS%%share/doc/gphoto2/NEWS
+%%PORTDOCS%%share/doc/gphoto2/README
+%%PORTDOCS%%share/doc/gphoto2/gphoto2-cli.txt
+%%PORTDOCS%%share/doc/gphoto2/gphoto2.txt
share/gphoto2/konica/english
share/gphoto2/konica/french
share/gphoto2/konica/german
@@ -92,10 +90,7 @@ share/locale/zh_CN/LC_MESSAGES/gphoto2.mo
share/locale/zh_CN/LC_MESSAGES/libgphoto2_port.mo
@dirrm share/gphoto2/konica
@dirrm share/gphoto2
-@dirrm share/doc/gphoto2/linux-hotplug
-@dirrm share/doc/gphoto2/html/figures
-@dirrm share/doc/gphoto2/html
-@dirrm share/doc/gphoto2
+%%PORTDOCS%%@dirrm share/doc/gphoto2
@dirrm lib/gphoto2_port/0.0.4
@dirrm lib/gphoto2_port
@dirrm lib/gphoto2/2.0