aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-09-27 00:45:43 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-09-27 00:45:43 +0000
commit34171d18e7d15518b0d4be05014647ae496a03b1 (patch)
tree7afbcbdab7ade0ede36d8144d66e4d152fce3337 /graphics
parentb705cbc95ce7bf042f8953c29453b6528f20a3c6 (diff)
downloadports-34171d18e7d15518b0d4be05014647ae496a03b1.tar.gz
ports-34171d18e7d15518b0d4be05014647ae496a03b1.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/epstool/Makefile10
-rw-r--r--graphics/gimp-manual-html/Makefile10
-rw-r--r--graphics/ocaml-images/Makefile10
-rw-r--r--graphics/openrm/Makefile4
-rw-r--r--graphics/pstoedit/Makefile10
-rw-r--r--graphics/py-chart/Makefile10
-rw-r--r--graphics/renderpark/Makefile4
-rw-r--r--graphics/xrml/Makefile2
8 files changed, 30 insertions, 30 deletions
diff --git a/graphics/epstool/Makefile b/graphics/epstool/Makefile
index c57fa3626490..32d0aafb9b33 100644
--- a/graphics/epstool/Makefile
+++ b/graphics/epstool/Makefile
@@ -26,12 +26,12 @@ MAKEFILE= makefile
MAKE_ARGS= CC="${CC}" CDEBUG="${CFLAGS}" LINK="${CC}" EPSLIB=""
ALL_TARGET= ${PORTNAME}
-pre-fetch:
+pre-everything::
.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
- @${ECHO} ""
- @${ECHO} " Define WITH_GHOSTSCRIPT_AFPL=yes to use"
- @${ECHO} " AFPL Postscript interpreter instead of GNU one"
- @${ECHO} ""
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " Define WITH_GHOSTSCRIPT_AFPL=yes to use"
+ @${ECHO_MSG} " AFPL Postscript interpreter instead of GNU one"
+ @${ECHO_MSG} ""
.endif
post-extract:
diff --git a/graphics/gimp-manual-html/Makefile b/graphics/gimp-manual-html/Makefile
index 10f7dcf461e2..17d1d186c584 100644
--- a/graphics/gimp-manual-html/Makefile
+++ b/graphics/gimp-manual-html/Makefile
@@ -19,17 +19,17 @@ DOCFORMAT=HTML
.else
.if ${DOCFORMAT} != "HTML" && ${DOCFORMAT} != "PDF"
.BEGIN:
- @${ECHO} "ERROR: invalid value for DOCFORMAT: \"${DOCFORMAT}\""
- @${ECHO} "Possible values are: HTML, PDF."
+ @${ECHO_MSG} "ERROR: invalid value for DOCFORMAT: \"${DOCFORMAT}\""
+ @${ECHO_MSG} "Possible values are: HTML, PDF."
@${FALSE}
.endif
.endif
PLIST= ${PKGDIR}/pkg-plist_${DOCFORMAT}
-pre-fetch:
- @${ECHO} "This manual is available in two formats: HTML and PDF."
- @${ECHO} "Note that the manual is pretty darn big."
+pre-everything::
+ @${ECHO_MSG} "This manual is available in two formats: HTML and PDF."
+ @${ECHO_MSG} "Note that the manual is pretty darn big."
PREFIX?= ${X11BASE} # This port itself does not require Xlib
EXTRACT_ONLY= #empty
diff --git a/graphics/ocaml-images/Makefile b/graphics/ocaml-images/Makefile
index 6629140afa9f..840e16de274c 100644
--- a/graphics/ocaml-images/Makefile
+++ b/graphics/ocaml-images/Makefile
@@ -43,12 +43,12 @@ CONFIGURE_ENV= \
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
USE_GMAKE= yes
-pre-fetch:
+pre-everything::
.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
- @${ECHO} ""
- @${ECHO} " Define WITH_GHOSTSCRIPT_AFPL=yes to use"
- @${ECHO} " AFPL Postscript interpreter instead of GNU one"
- @${ECHO} ""
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " Define WITH_GHOSTSCRIPT_AFPL=yes to use"
+ @${ECHO_MSG} " AFPL Postscript interpreter instead of GNU one"
+ @${ECHO_MSG} ""
.endif
.include <bsd.port.mk>
diff --git a/graphics/openrm/Makefile b/graphics/openrm/Makefile
index 2fc0392480f3..2fdef5c6c94a 100644
--- a/graphics/openrm/Makefile
+++ b/graphics/openrm/Makefile
@@ -48,9 +48,9 @@ PLIST_SUB= WITH_DEMOS="@comment "
PLIST_SUB= WITH_DEMOS=""
.endif
-.ifndef (WITH_DEMOS)
pre-everything::
- @${ECHO} "You can define WITH_DEMOS=yes to fetch and install available demos"
+.ifndef (WITH_DEMOS)
+ @${ECHO_MSG} "You can define WITH_DEMOS=yes to fetch and install available demos"
.endif
post-patch:
diff --git a/graphics/pstoedit/Makefile b/graphics/pstoedit/Makefile
index 41eaa89e9ac8..5095e3db679d 100644
--- a/graphics/pstoedit/Makefile
+++ b/graphics/pstoedit/Makefile
@@ -36,12 +36,12 @@ CPPFLAGS= -I${LOCALBASE}/include/ming -I${LOCALBASE}/include \
-I${X11BASE}/include
LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib
-pre-fetch:
+pre-everything::
.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
- @${ECHO} ""
- @${ECHO} " Define WITH_GHOSTSCRIPT_AFPL=yes to use"
- @${ECHO} " AFPL Postscript interpreter instead of GNU one"
- @${ECHO} ""
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " Define WITH_GHOSTSCRIPT_AFPL=yes to use"
+ @${ECHO_MSG} " AFPL Postscript interpreter instead of GNU one"
+ @${ECHO_MSG} ""
.endif
post-install:
diff --git a/graphics/py-chart/Makefile b/graphics/py-chart/Makefile
index 5a6586238d74..a02ef19d0005 100644
--- a/graphics/py-chart/Makefile
+++ b/graphics/py-chart/Makefile
@@ -27,12 +27,12 @@ RUN_DEPENDS= gs:${PORTSDIR}/${GSPORT}
USE_PYTHON= yes
USE_PYDISTUTILS= yes
-pre-fetch:
+pre-everything::
.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
- @${ECHO} ""
- @${ECHO} " Define WITH_GHOSTSCRIPT_AFPL=yes to use"
- @${ECHO} " AFPL Postscript interpreter instead of GNU one"
- @${ECHO} ""
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " Define WITH_GHOSTSCRIPT_AFPL=yes to use"
+ @${ECHO_MSG} " AFPL Postscript interpreter instead of GNU one"
+ @${ECHO_MSG} ""
.endif
.include <bsd.port.mk>
diff --git a/graphics/renderpark/Makefile b/graphics/renderpark/Makefile
index 558128f04b16..00eeb1100523 100644
--- a/graphics/renderpark/Makefile
+++ b/graphics/renderpark/Makefile
@@ -45,10 +45,10 @@ PLIST_SUB= WITH_SCENES=""
pre-everything::
.ifndef (WITH_XRML)
- @${ECHO} "Defining WITH_XRML=yes will allow you to read XRML input files"
+ @${ECHO_MSG} "Defining WITH_XRML=yes will allow you to read XRML input files"
.endif
.ifndef (WITH_SCENES)
- @${ECHO} "Define WITH_SCENES=yes to install additional scenes package"
+ @${ECHO_MSG} "Define WITH_SCENES=yes to install additional scenes package"
.endif
pre-patch:
diff --git a/graphics/xrml/Makefile b/graphics/xrml/Makefile
index 7bc474bda9b2..1948a180b0df 100644
--- a/graphics/xrml/Makefile
+++ b/graphics/xrml/Makefile
@@ -38,7 +38,7 @@ USE_GCC=2.95
.ifndef (WITH_EXAMPLES)
pre-everything::
- @${ECHO} "You can define WITH_EXAMPLES=yes to install example VRML files"
+ @${ECHO_MSG} "You can define WITH_EXAMPLES=yes to install example VRML files"
.endif
pre-patch: