aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2020-03-31 16:15:16 +0000
committerRene Ladan <rene@FreeBSD.org>2020-03-31 16:15:16 +0000
commit3c6fba3a38899c63d3dbc2bcbc45740cf327c6b3 (patch)
tree3dde9d52f34dfb1247213c04b75eda5c746d1114 /graphics
parent22ddb939272b64b06b07a246858f63dbfaf2906a (diff)
downloadports-3c6fba3a38899c63d3dbc2bcbc45740cf327c6b3.tar.gz
ports-3c6fba3a38899c63d3dbc2bcbc45740cf327c6b3.zip
Clean up ports after FreeBSD 12.0 reached end-of-life.
emulators/mesen is left out for now, as it breaks on 11.3 Submitted by: rene Reviewed by: jbeich, zeising X-Differential Revision: https://reviews.freebsd.org/D24211
Notes
Notes: svn path=/head/; revision=529986
Diffstat (limited to 'graphics')
-rw-r--r--graphics/drm-kmod/Makefile4
-rw-r--r--graphics/gpu-firmware-kmod/Makefile8
-rw-r--r--graphics/rawtherapee/Makefile6
3 files changed, 3 insertions, 15 deletions
diff --git a/graphics/drm-kmod/Makefile b/graphics/drm-kmod/Makefile
index 71ec1eeef89d..e127621875b0 100644
--- a/graphics/drm-kmod/Makefile
+++ b/graphics/drm-kmod/Makefile
@@ -24,10 +24,6 @@ IGNORE= legacy kmod not required on less than 12.0
.else
.if ${OSVERSION} >= 1103000 && ${OSVERSION} < 1200000
RUN_DEPENDS= ${KMODDIR}/drm.ko:graphics/drm-fbsd11.2-kmod
-.elif ${OSVERSION} >= 1200000 && ${OSVERSION} < 1200045
-IGNORE= not supported on older 12, no kernel support
-.elif ${OSVERSION} >= 1200045 && ${OSVERSION} < 1200058
-RUN_DEPENDS= ${KMODDIR}/drm.ko:graphics/drm-fbsd11.2-kmod
.elif ${OSVERSION} >= 1200058 && ${OSVERSION} < 1300000
RUN_DEPENDS= ${KMODDIR}/drm.ko:graphics/drm-fbsd12.0-kmod
.elif ${OSVERSION} >= 1300000 && ${OSVERSION} < 1300029
diff --git a/graphics/gpu-firmware-kmod/Makefile b/graphics/gpu-firmware-kmod/Makefile
index 7fafe6bc427f..37ed688468e8 100644
--- a/graphics/gpu-firmware-kmod/Makefile
+++ b/graphics/gpu-firmware-kmod/Makefile
@@ -24,10 +24,4 @@ GH_ACCOUNT= FreeBSDDesktop
GH_PROJECT= kms-firmware
GH_TAGNAME= c9eb7f3
-.include <bsd.port.pre.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1200000 && ${OSVERSION} < 1200019
-IGNORE= not supported on older CURRENT, no kernel support
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/rawtherapee/Makefile b/graphics/rawtherapee/Makefile
index a325bd1e9391..c442fdc3b605 100644
--- a/graphics/rawtherapee/Makefile
+++ b/graphics/rawtherapee/Makefile
@@ -41,9 +41,7 @@ USE_BINUTILS= yes
# As of 2019-09-29, this port is known to be miscompiled by clang90
# (SIGSEGV or SIBGUS) and 12.1's base clang.
#
-# FreeBSD 11.2/12.0's base clang 6.0.1 emits worse code with
-# considerably higher processing times, and on i386 additional calls to
-# __atomic_*(), so we shall stick to GCC 9.x for now
+# so we shall stick to GCC 9.x for now
USE_GCC= 9+
_LTO_FLAGS= -flto=${MAKE_JOBS_NUMBER}
@@ -116,7 +114,7 @@ ONLY_FOR_ARCHS_REASON= i386 malfunctions on 11.x - upgrade to 12.x
.if (${OPSYS} == FreeBSD) && (${OSVERSION} >= 1300000)
# don't waste everybody's time with Tier-2 and moving targets.
# might add ARM64 or SPARC64 later on if they are established by the
-# time FreeBSD 12 is out.
+# time FreeBSD 13 is out.
ONLY_FOR_ARCHS= amd64
ONLY_FOR_ARCHS_REASON=Only amd64 is supported on non-released FreeBSD versions.
.endif