aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-10-12 13:09:30 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-10-12 13:09:30 +0000
commit7db02abe9a7f204120c42b0ce3842cb66abe9e0a (patch)
tree78664e176bc2cd23f540ce99deeb0bc383dd8226 /graphics
parentd63df3cf32fdd44da190c6f8b2ad500bfa95d5a8 (diff)
Add libsvg 0.1.2, a parser for SVG content in files or buffers.
PR: ports/72406 Submitted by: Michael Johnson <ahze@ahze.net>
Notes
Notes: svn path=/head/; revision=119010
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/libsvg/Makefile40
-rw-r--r--graphics/libsvg/distinfo2
-rw-r--r--graphics/libsvg/pkg-descr3
4 files changed, 46 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 139807cbc76d..5d6c9f9e11f4 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -249,6 +249,7 @@
SUBDIR += libqglviewer
SUBDIR += librsvg
SUBDIR += librsvg2
+ SUBDIR += libsvg
SUBDIR += libtheora
SUBDIR += libungif
SUBDIR += libv3d
diff --git a/graphics/libsvg/Makefile b/graphics/libsvg/Makefile
new file mode 100644
index 000000000000..a2ed37816e1a
--- /dev/null
+++ b/graphics/libsvg/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: libsvg
+# Date created: 2004-10-06
+# Whom: Michael Johnson <ahze@ahze.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libsvg
+PORTVERSION= 0.1.2
+CATEGORIES= graphics
+MASTER_SITES= http://cairographics.org/cairo/snapshots/
+
+MAINTAINER= ahze@ahze.net
+COMMENT= A parser for SVG content in files or buffers
+
+LIB_DEPENDS= fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
+ png.5:${PORTSDIR}/graphics/png \
+ jpeg.9:${PORTSDIR}/graphics/jpeg
+
+USE_LIBTOOL_VER=15
+USE_GNOME= libxml2 gnomehack gnometarget
+USE_ICONV= yes
+USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
+
+PLIST_FILES= include/svg.h \
+ lib/libsvg.a \
+ lib/libsvg.so \
+ lib/libsvg.so.1 \
+ libdata/pkgconfig/libsvg.pc
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+.if ${OSVERSION} < 500000
+ @${REINPLACE_CMD} -e 's|stdint.h|inttypes.h|' \
+ ${WRKSRC}/src/svg_ascii.h
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/libsvg/distinfo b/graphics/libsvg/distinfo
new file mode 100644
index 000000000000..54ad9ae9e547
--- /dev/null
+++ b/graphics/libsvg/distinfo
@@ -0,0 +1,2 @@
+MD5 (libsvg-0.1.2.tar.gz) = c8efa4ceb6a919fae30477ee2d6b41c7
+SIZE (libsvg-0.1.2.tar.gz) = 260350
diff --git a/graphics/libsvg/pkg-descr b/graphics/libsvg/pkg-descr
new file mode 100644
index 000000000000..6152fecfb772
--- /dev/null
+++ b/graphics/libsvg/pkg-descr
@@ -0,0 +1,3 @@
+A parser for SVG content in files or buffers
+
+WWW: http://cairographics.org/