aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-07-26 06:55:13 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-07-26 06:55:13 +0000
commitad67db9b50f9b1b68beb27fb628d7595686654e2 (patch)
tree9e250276422a6bf3456ae3bcc9902dfa36cdbf92 /graphics
parenta1ab42767f1e896f69691b28bf95935759907135 (diff)
downloadports-ad67db9b50f9b1b68beb27fb628d7595686654e2.tar.gz
ports-ad67db9b50f9b1b68beb27fb628d7595686654e2.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gsnapshot/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/graphics/gsnapshot/Makefile b/graphics/gsnapshot/Makefile
index 6f6acdb28df8..c04b4f030d8f 100644
--- a/graphics/gsnapshot/Makefile
+++ b/graphics/gsnapshot/Makefile
@@ -10,14 +10,16 @@ MASTER_SITES= SF/gould/${PORTNAME}/release%20${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= GTK+ based screen capture
-USES= pkgconfig
+OPTIONS_DEFINE= DOCS
+
+USES= pkgconfig gmake
USE_AUTOTOOLS= aclocal autoheader automake autoconf libtool
AUTOMAKE_ARGS= --add-missing
USE_GNOME= gtk20 libwnck libxml2
USE_XORG= x11 xmu
-USE_GMAKE= yes
CFLAGS+= -fPIC -I${LOCALBASE}/include/libxml2
+LDFLAGS+= -lgmodule-2.0
PORTDOCS= AUTHORS COPYING INSTALL README TODO
@@ -28,13 +30,15 @@ DESKTOP_ENTRIES= "gsnapshot" \
"Graphics;GTK;" \
"false"
+.include <bsd.port.options.mk>
+
pre-configure:
@${LN} -sf ${AUTOMAKE_DIR}/install-sh ${WRKSRC}
@${LN} -sf ${AUTOMAKE_DIR}/depcomp ${WRKSRC}
@${LN} -sf ${AUTOMAKE_DIR}/missing ${WRKSRC}
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for doc in ${PORTDOCS}
@${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}