aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorChin-San Huang <chinsan@FreeBSD.org>2008-08-30 21:16:35 +0000
committerChin-San Huang <chinsan@FreeBSD.org>2008-08-30 21:16:35 +0000
commite74eae441d6f41369dd33d7478fbee7276bc02f7 (patch)
tree0ef3a1e77952b96731c02b663d7981773471f030 /graphics
parent22d1890a973cebb57c6d080a4336977a15795150 (diff)
downloadports-e74eae441d6f41369dd33d7478fbee7276bc02f7.tar.gz
ports-e74eae441d6f41369dd33d7478fbee7276bc02f7.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/p5-Graphics-Color/Makefile34
-rw-r--r--graphics/p5-Graphics-Color/distinfo3
-rw-r--r--graphics/p5-Graphics-Color/pkg-descr4
-rw-r--r--graphics/p5-Graphics-Color/pkg-plist12
5 files changed, 54 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 7b177768f3a3..f08856ddf0dd 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -519,6 +519,7 @@
SUBDIR += p5-GraphViz
SUBDIR += p5-GraphViz-Data-Structure
SUBDIR += p5-GraphViz-Traverse
+ SUBDIR += p5-Graphics-Color
SUBDIR += p5-Graphics-ColorNames
SUBDIR += p5-Graphics-ColorNames-WWW
SUBDIR += p5-Image-Caa
diff --git a/graphics/p5-Graphics-Color/Makefile b/graphics/p5-Graphics-Color/Makefile
new file mode 100644
index 000000000000..cddcab9058d5
--- /dev/null
+++ b/graphics/p5-Graphics-Color/Makefile
@@ -0,0 +1,34 @@
+# Ports collection makefile for: p5-Graphics-Color
+# Date created: 2008/08/30
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= Graphics-Color
+PORTVERSION= 0.12
+CATEGORIES= graphics perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= Device and library agnostic color spaces
+
+BUILD_DEPENDS= p5-Moose>=0.25:${PORTSDIR}/devel/p5-Moose \
+ p5-Geometry-Primitive>=0:${PORTSDIR}/graphics/p5-Geometry-Primitive \
+ p5-MooseX-Clone>=0:${PORTSDIR}/devel/p5-MooseX-Clone \
+ p5-Module-Install>=0.64:${PORTSDIR}/devel/p5-Module-Install \
+ p5-Pod-Coverage-Moose>=0:${PORTSDIR}/devel/p5-Pod-Coverage-Moose
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN3= Graphics::Color.3 \
+ Graphics::Color::CMYK.3 \
+ Graphics::Color::Equal.3 \
+ Graphics::Color::HSL.3 \
+ Graphics::Color::RGB.3 \
+ Graphics::Color::YIQ.3 \
+ Graphics::Color::YUV.3
+
+.include <bsd.port.mk>
diff --git a/graphics/p5-Graphics-Color/distinfo b/graphics/p5-Graphics-Color/distinfo
new file mode 100644
index 000000000000..af522f9fe470
--- /dev/null
+++ b/graphics/p5-Graphics-Color/distinfo
@@ -0,0 +1,3 @@
+MD5 (Graphics-Color-0.12.tar.gz) = 8b98faa61856d468ca8121d3df7760f1
+SHA256 (Graphics-Color-0.12.tar.gz) = fccddc0a19c84a254a0e56e86f30aa8625f8362d948490366bc20e045a50c888
+SIZE (Graphics-Color-0.12.tar.gz) = 24357
diff --git a/graphics/p5-Graphics-Color/pkg-descr b/graphics/p5-Graphics-Color/pkg-descr
new file mode 100644
index 000000000000..bd85ee2e117c
--- /dev/null
+++ b/graphics/p5-Graphics-Color/pkg-descr
@@ -0,0 +1,4 @@
+Graphics color is a device and library agnostic system for creating and
+manipulating colors in various color spaces.
+
+WWW: http://search.cpan.org/dist/Graphics-Color/
diff --git a/graphics/p5-Graphics-Color/pkg-plist b/graphics/p5-Graphics-Color/pkg-plist
new file mode 100644
index 000000000000..f1e98d41c3e3
--- /dev/null
+++ b/graphics/p5-Graphics-Color/pkg-plist
@@ -0,0 +1,12 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Graphics/Color/.packlist
+%%SITE_PERL%%/Graphics/Color.pm
+%%SITE_PERL%%/Graphics/Color/CMYK.pm
+%%SITE_PERL%%/Graphics/Color/Equal.pm
+%%SITE_PERL%%/Graphics/Color/HSL.pm
+%%SITE_PERL%%/Graphics/Color/RGB.pm
+%%SITE_PERL%%/Graphics/Color/YIQ.pm
+%%SITE_PERL%%/Graphics/Color/YUV.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Graphics/Color
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Graphics
+@dirrmtry %%SITE_PERL%%/Graphics/Color
+@dirrmtry %%SITE_PERL%%/Graphics