aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2020-08-20 19:21:40 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2020-08-20 19:21:40 +0000
commit1701f3dcbce01626de029e8fdddd9d336ebf103a (patch)
treef0511ab2ab46ed9649f95dbb91259133efbfee55 /graphics
parent848067739bbcaea033feb100293dab4d004539a9 (diff)
downloadports-1701f3dcbce01626de029e8fdddd9d336ebf103a.tar.gz
ports-1701f3dcbce01626de029e8fdddd9d336ebf103a.zip
MFH: r545317
graphics/argyllcms: Fix -fno-common build Fix the build with -fno-common (default with llvm 11) While here, remove a useless REINPLACE_CMD. Approved by: ports-secteam (joenum)
Notes
Notes: svn path=/branches/2020Q3/; revision=545550
Diffstat (limited to 'graphics')
-rw-r--r--graphics/argyllcms/Makefile3
-rw-r--r--graphics/argyllcms/files/patch-gamut_gamut.h11
-rw-r--r--graphics/argyllcms/files/patch-spectro_vinflate.c31
3 files changed, 42 insertions, 3 deletions
diff --git a/graphics/argyllcms/Makefile b/graphics/argyllcms/Makefile
index bcc94734eaa8..92a0bb32bf97 100644
--- a/graphics/argyllcms/Makefile
+++ b/graphics/argyllcms/Makefile
@@ -22,9 +22,6 @@ WRKSRC= ${WRKDIR}/Argyll_V${PORTVERSION}
USES= compiler:c11 cpe jpeg ssl xorg zip
USE_XORG= x11 xau xdmcp xext xinerama xrandr xscrnsaver xxf86vm
-post-patch:
- @${REINPLACE_CMD} 's:711:755:g' ${WRKSRC}/Jambase
-
do-build:
@cd ${WRKSRC} && ${MAKE_ENV} jam -dx -q -fJambase -j${MAKE_JOBS_NUMBER}
diff --git a/graphics/argyllcms/files/patch-gamut_gamut.h b/graphics/argyllcms/files/patch-gamut_gamut.h
new file mode 100644
index 000000000000..2b447b336b7b
--- /dev/null
+++ b/graphics/argyllcms/files/patch-gamut_gamut.h
@@ -0,0 +1,11 @@
+--- gamut/gamut.h.orig 2020-08-19 11:32:00 UTC
++++ gamut/gamut.h
+@@ -36,7 +36,7 @@
+ #define MAXGAMN 10 /* Maximum gamut point neighbors returned */
+ #define NSLOTS 6 /* Number of maximum direction slots */
+
+-struct _vrml *wrl; /* Declared in vrml.h, which may be #included after this */
++extern struct _vrml *wrl; /* Declared in vrml.h, which may be #included after this */
+
+ /* ------------------------------------ */
+ #define NODE_STRUCT \
diff --git a/graphics/argyllcms/files/patch-spectro_vinflate.c b/graphics/argyllcms/files/patch-spectro_vinflate.c
new file mode 100644
index 000000000000..15502529e161
--- /dev/null
+++ b/graphics/argyllcms/files/patch-spectro_vinflate.c
@@ -0,0 +1,31 @@
+--- spectro/vinflate.c.orig 2020-08-19 12:08:33 UTC
++++ spectro/vinflate.c
+@@ -92,7 +92,7 @@ int vinflate(void);
+ */
+
+ #define WSIZE 0x8000
+-unsigned int wp; /* current position in slide */
++extern unsigned int wp; /* current position in slide */
+ uch slide[32768];
+
+ static int vflush_output(unsigned int w) {
+@@ -160,8 +160,8 @@ static ush cpdext[] = { /* Extra bits for dist
+ the stream.
+ */
+
+-ulg bb; /* bit buffer */
+-unsigned bk; /* bits in bit buffer */
++extern ulg bb; /* bit buffer */
++extern unsigned bk; /* bits in bit buffer */
+
+ ush vmask_bits[] = {
+ 0x0000,
+@@ -239,7 +239,7 @@ int vdbits = 6; /* bits in base distance look
+ #define N_MAX 288 /* maximum number of codes in any set */
+
+
+-unsigned hufts; /* track memory usage */
++extern unsigned hufts; /* track memory usage */
+
+ /* Given a list of code lengths and a maximum table size, make a set of
+ tables to decode that set of codes. Return zero on success, one if