aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-06-08 12:18:45 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-06-08 12:18:45 +0000
commit18f63071e3a086bc98f54f9bbdf3467ac111a67a (patch)
treebbf342622e3bf22c813f7929adff80cfe23dadcb /graphics
parent510a704241652ae522dbf7fdf23e14a053b57e58 (diff)
downloadports-18f63071e3a086bc98f54f9bbdf3467ac111a67a.tar.gz
ports-18f63071e3a086bc98f54f9bbdf3467ac111a67a.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/osg-devel/Makefile2
-rw-r--r--graphics/osg/Makefile4
2 files changed, 5 insertions, 1 deletions
diff --git a/graphics/osg-devel/Makefile b/graphics/osg-devel/Makefile
index 2381faf51986..b530281b7cb1 100644
--- a/graphics/osg-devel/Makefile
+++ b/graphics/osg-devel/Makefile
@@ -211,6 +211,8 @@ USE_XORG+= xrandr
.endif
post-patch:
+ @${FIND} ${WRKSRC}/CMakeModules -type f -print0 | ${XARGS} -0 \
+ ${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g'
.for p in ${FORCE_REQUIRE}
@${REINPLACE_CMD} -e '/FIND_PACKAGE.*${p}/ s|)$$| REQUIRED&|' \
${WRKSRC}/CMakeLists.txt
diff --git a/graphics/osg/Makefile b/graphics/osg/Makefile
index 61ff1650be6c..2d8f3eae9eca 100644
--- a/graphics/osg/Makefile
+++ b/graphics/osg/Makefile
@@ -177,7 +177,7 @@ PLIST_SUB+= SVG="@comment "
.if defined(WITH_PDF)
FORCE_PC_REQUIRE+=POPPLER
-LIB_DEPENDS+= poppler-glib.3:${PORTSDIR}/graphics/poppler-gtk
+LIB_DEPENDS+= poppler-glib.4:${PORTSDIR}/graphics/poppler-gtk
PLIST_SUB+= PDF=""
.else
FORCE_PC_IGNORE+=POPPLER
@@ -200,6 +200,8 @@ USE_XORG+= xrandr
.endif
post-patch:
+ @${FIND} ${WRKSRC}/CMakeModules -type f -print0 | ${XARGS} -0 \
+ ${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g'
.for p in ${FORCE_REQUIRE}
@${REINPLACE_CMD} -e '/FIND_PACKAGE.*${p}/ s|)$$| REQUIRED&|' \
${WRKSRC}/CMakeLists.txt