aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2020-07-01 13:45:59 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2020-07-01 13:45:59 +0000
commit3cc6898fe9f6a6ef2f2ce29a61779de9641364b5 (patch)
treef31578a407a63201f4d2da3ae97770b0703ce4ba /graphics
parent5c275142f75493755ab862c2deed8857264a2c06 (diff)
downloadports-3cc6898fe9f6a6ef2f2ce29a61779de9641364b5.tar.gz
ports-3cc6898fe9f6a6ef2f2ce29a61779de9641364b5.zip
Don't force python 2.7 build dependencies when building without DOCS option
PR: 246875 Submitted by: VVD <vvd@unislabs.com> Approved by: Shane <FreeBSD@ShaneWare.Biz> (maintainer)
Notes
Notes: svn path=/head/; revision=540965
Diffstat (limited to 'graphics')
-rw-r--r--graphics/opencolorio/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/graphics/opencolorio/Makefile b/graphics/opencolorio/Makefile
index 80bb066ca5a2..bc83c3da8e47 100644
--- a/graphics/opencolorio/Makefile
+++ b/graphics/opencolorio/Makefile
@@ -70,7 +70,11 @@ PLIST= ${PKGDIR}/pkg-plist-pyglue
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Jinja2>0:devel/py-Jinja2@${PY_FLAVOR}
LIB_DEPENDS= libtinyxml.so:textproc/tinyxml \
libyaml-cpp03.so:devel/yaml-cpp03
+.if ${PORT_OPTIONS:MDOCS}
USES+= python:2.7,build
+.else
+USES+= python:build
+.endif
USE_LDCONFIG= yes
CMAKE_ON+= OCIO_BUILD_SHARED OCIO_BUILD_PYGLUE
CMAKE_OFF+= OCIO_BUILD_APPS