aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2020-06-27 07:11:51 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2020-06-27 07:11:51 +0000
commit3d56f9c7b7aadcef39fde9d598a8f3980fdbddfa (patch)
treef7fa07e492446ff17a7b00567af5356ae7f05c40 /graphics
parente1479a0b400840ccc0469c8b24214a87ad5eede7 (diff)
downloadports-3d56f9c7b7aadcef39fde9d598a8f3980fdbddfa.tar.gz
ports-3d56f9c7b7aadcef39fde9d598a8f3980fdbddfa.zip
qvge is a multi-platform graph editor written in C++/Qt. Its main goal
is to make possible visually edit two-dimensional graphs in a simple and intuitive way. WWW: https://github.com/ArsMasiuk/qvge
Notes
Notes: svn path=/head/; revision=540562
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/qvge/Makefile45
-rw-r--r--graphics/qvge/distinfo3
-rw-r--r--graphics/qvge/files/patch-app.pri21
-rw-r--r--graphics/qvge/files/patch-commonui_ogdf_COGDFLayout.cpp31
-rw-r--r--graphics/qvge/files/patch-qvge_CNodeEditorScene.cpp14
-rw-r--r--graphics/qvge/pkg-descr5
7 files changed, 120 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index ca61b7297e0e..7b72481e4a8e 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -908,6 +908,7 @@
SUBDIR += quat-gui
SUBDIR += quesa
SUBDIR += quesoglc
+ SUBDIR += qvge
SUBDIR += radiance
SUBDIR += radius-engine
SUBDIR += rapid-photo-downloader
diff --git a/graphics/qvge/Makefile b/graphics/qvge/Makefile
new file mode 100644
index 000000000000..851335932ed3
--- /dev/null
+++ b/graphics/qvge/Makefile
@@ -0,0 +1,45 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= qvge
+PORTVERSION= 0.5.5
+CATEGORIES= graphics
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Qt Visual Graph Editor
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/../LICENSE
+
+LIB_DEPENDS= libOGDF.so:math/ogdf
+
+USE_GITHUB= yes
+GH_ACCOUNT= ArsMasiuk
+
+USES= compiler:c++11-lang qt:5 xorg
+USE_QT= buildtools_build qmake_build core gui network opengl \
+ printsupport widgets x11extras xml
+USE_XORG= x11
+
+MAKE_ARGS= INSTALL_ROOT=${STAGEDIR}
+WRKSRC_SUBDIR= src
+
+PLIST_FILES= bin/qvgeapp
+PORTDOCS= CHANGES README.md
+
+OPTIONS_DEFINE= DOCS
+
+post-patch:
+ @${RM} -r ${BUILD_WRKSRC}/3rdParty/ogdf
+ @${REINPLACE_CMD} -e '/CONFIG += c++/s,14,11,' ${WRKSRC}/config.pri
+ @${REINPLACE_CMD} -e '/^USE_OGDF{/,+4d' ${WRKSRC}/qvgeapp.pro
+ @${REINPLACE_CMD} -e '/#include/s,math\.h,cmath,' ${WRKSRC}/qvge/CUtils.cpp
+
+do-configure:
+ cd ${CONFIGURE_WRKSRC} && ${QMAKE_ENV} ${QMAKE} ${QMAKE_ARGS}
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/../,} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/graphics/qvge/distinfo b/graphics/qvge/distinfo
new file mode 100644
index 000000000000..319443c01580
--- /dev/null
+++ b/graphics/qvge/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1592825045
+SHA256 (ArsMasiuk-qvge-0.5.5_GH0.tar.gz) = f4a8155f03653bde37c8c83c1ff1b7325b1dec7e1d4b2589cb38558211bf1f5a
+SIZE (ArsMasiuk-qvge-0.5.5_GH0.tar.gz) = 4225872
diff --git a/graphics/qvge/files/patch-app.pri b/graphics/qvge/files/patch-app.pri
new file mode 100644
index 000000000000..899dc7680a8d
--- /dev/null
+++ b/graphics/qvge/files/patch-app.pri
@@ -0,0 +1,21 @@
+--- app.pri.orig 2020-06-22 11:24:05 UTC
++++ app.pri
+@@ -15,7 +15,7 @@ else{
+ LIBS += -lcommonui -lqvge -lqvgeio -lqtpropertybrowser -lqsint-widgets
+
+ USE_OGDF{
+- LIBS += -logdf
++ LIBS += -lOGDF
+ }
+
+ win32{
+@@ -24,7 +24,8 @@ win32{
+
+ unix{
+ !haiku{
+- LIBS += -lQt5X11Extras -lX11
++ QT += x11extras
++ LIBS += -lX11
+ }
+ }
+
diff --git a/graphics/qvge/files/patch-commonui_ogdf_COGDFLayout.cpp b/graphics/qvge/files/patch-commonui_ogdf_COGDFLayout.cpp
new file mode 100644
index 000000000000..65537183b46b
--- /dev/null
+++ b/graphics/qvge/files/patch-commonui_ogdf_COGDFLayout.cpp
@@ -0,0 +1,31 @@
+--- commonui/ogdf/COGDFLayout.cpp.orig 2020-06-22 11:24:05 UTC
++++ commonui/ogdf/COGDFLayout.cpp
+@@ -6,7 +6,7 @@
+
+ #include <ogdf/basic/Graph.h>
+ #include <ogdf/basic/GraphAttributes.h>
+-#include <ogdf/module/LayoutModule.h>
++#include <ogdf/basic/LayoutModule.h>
+ #include <ogdf/fileformats/GraphIO.h>
+
+ #include <ogdf/misclayout/BalloonLayout.h>
+@@ -246,16 +246,17 @@ bool COGDFLayout::loadGraph(const QString &filename, C
+ {
+ ogdf::Graph G;
+ ogdf::GraphAttributes GA(G, 0xffffff); // all attrs
++ std::ifstream is(filename.toStdString());
+
+ QString format = QFileInfo(filename).suffix().toLower();
+
+ bool ok = false;
+ if (format == "gml")
+- ok = ogdf::GraphIO::readGML(GA, G, filename.toStdString());
++ ok = ogdf::GraphIO::readGML(GA, G, is);
+ else
+ if (format == "dot" || format == "gv")
+ {
+- ok = ogdf::GraphIO::readDOT(GA, G, filename.toStdString());
++ ok = ogdf::GraphIO::readDOT(GA, G, is);
+
+ // normalize node positions
+ if (ok && GA.has(GA.nodeGraphics))
diff --git a/graphics/qvge/files/patch-qvge_CNodeEditorScene.cpp b/graphics/qvge/files/patch-qvge_CNodeEditorScene.cpp
new file mode 100644
index 000000000000..445013d859aa
--- /dev/null
+++ b/graphics/qvge/files/patch-qvge_CNodeEditorScene.cpp
@@ -0,0 +1,14 @@
+--- qvge/CNodeEditorScene.cpp.orig 2020-06-22 11:24:05 UTC
++++ qvge/CNodeEditorScene.cpp
+@@ -189,7 +189,10 @@ bool CNodeEditorScene::toGraph(Graph& g)
+
+
+ // visibility
+- static AttrInfo _vis_({ attr_labels_visIds , "Visible Labels", QVariant::StringList});
++ static AttrInfo _vis_;
++ _vis_.id = attr_labels_visIds;
++ _vis_.name = "Visible Labels";
++ _vis_.defaultValue = QVariant::StringList;
+
+ auto nodeVis = getVisibleClassAttributes("node", false);
+ if (nodeVis.size())
diff --git a/graphics/qvge/pkg-descr b/graphics/qvge/pkg-descr
new file mode 100644
index 000000000000..ffd8c4e7cc37
--- /dev/null
+++ b/graphics/qvge/pkg-descr
@@ -0,0 +1,5 @@
+qvge is a multi-platform graph editor written in C++/Qt. Its main goal
+is to make possible visually edit two-dimensional graphs in a simple and
+intuitive way.
+
+WWW: https://github.com/ArsMasiuk/qvge