aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorCarlo Strub <cs@FreeBSD.org>2014-05-29 18:40:25 +0000
committerCarlo Strub <cs@FreeBSD.org>2014-05-29 18:40:25 +0000
commit408f9a918d4facf86e957d10e45f8aae51cf3be0 (patch)
treeffccb31d6237968b7abfc0b185974a752acfda93 /graphics
parent210599d4629eb4b49edfe295c77bcf0c1bac1d0d (diff)
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/import-pictures/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/graphics/import-pictures/Makefile b/graphics/import-pictures/Makefile
index 9eb05c18c8a1..23a5b5020e82 100644
--- a/graphics/import-pictures/Makefile
+++ b/graphics/import-pictures/Makefile
@@ -3,6 +3,7 @@
PORTNAME= import-pictures
PORTVERSION= 1.4
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://www.nagilum.org/unix/
@@ -15,27 +16,26 @@ RUN_DEPENDS= p5-Image-ExifTool>=0:${PORTSDIR}/graphics/p5-Image-ExifTool \
p5-TimeDate>=0:${PORTSDIR}/devel/p5-TimeDate \
p5-Time-modules>=0:${PORTSDIR}/devel/p5-Time-modules
-USE_BZIP2= yes
-USES= gmake perl5
-
-PLIST_FILES= bin/${PORTNAME}
+USES= gmake perl5 shebangfix tar:bzip2
MAN1= ${PORTNAME}.1
-PORTDOCS= import-pictures.html
+PLIST_FILES= bin/${PORTNAME} man/man1/${PORTNAME}.1.gz
-NO_STAGE= yes
+PORTDOCS= import-pictures.html
+SHEBANG_FILES= ${WRKSRC}/${PORTNAME}
+SHEBANG_LANG= perl
OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
post-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MAN1PREFIX}/man/man1
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${STAGEDIR}${MAN1PREFIX}/man/man1
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>