aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-08-29 15:59:40 +0000
committerKoop Mast <kwm@FreeBSD.org>2015-08-29 15:59:40 +0000
commit510ebc96058b287dcb03326706a32459f280eca5 (patch)
treeadec99c159f393ebe35c165a5d4267190a773142 /graphics
parentc493e70098c73974a7e671a78592edc69fcf550e (diff)
downloadports-510ebc96058b287dcb03326706a32459f280eca5.tar.gz
ports-510ebc96058b287dcb03326706a32459f280eca5.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/darktable/Makefile3
-rw-r--r--graphics/librsvg2/Makefile15
-rw-r--r--graphics/librsvg2/distinfo4
-rw-r--r--graphics/librsvg2/pkg-plist5
4 files changed, 14 insertions, 13 deletions
diff --git a/graphics/darktable/Makefile b/graphics/darktable/Makefile
index b6e59c000f32..3d9f56bb55c6 100644
--- a/graphics/darktable/Makefile
+++ b/graphics/darktable/Makefile
@@ -3,6 +3,7 @@
PORTNAME= darktable
PORTVERSION= 1.6.8
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= https://github.com/darktable-org/${PORTNAME}/releases/download/release-${PORTVERSION}/
@@ -22,7 +23,7 @@ ONLY_FOR_ARCHS_REASON= uses SSE instructions
USES= compiler:c++11-lib cmake:outsource desktop-file-utils \
ninja pkgconfig tar:xz
-USE_GNOME= intltool librsvg2
+USE_GNOME= gtk20 intltool librsvg2
USE_SQLITE= yes
USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}
INSTALLS_ICONS= yes
diff --git a/graphics/librsvg2/Makefile b/graphics/librsvg2/Makefile
index 2807e6e84186..6970d45613b7 100644
--- a/graphics/librsvg2/Makefile
+++ b/graphics/librsvg2/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= librsvg
-PORTVERSION= 2.40.9
+PORTVERSION= 2.40.10
CATEGORIES= graphics gnome
MASTER_SITES= GNOME
PKGNAMESUFFIX= 2
@@ -14,23 +14,20 @@ COMMENT= Library for parsing and rendering SVG vector-graphic files
LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
libpng.so:${PORTSDIR}/graphics/png \
libcroco-0.6.so:${PORTSDIR}/textproc/libcroco
-RUN_DEPENDS= gtk-engines2>=2.7.5_1:${PORTSDIR}/x11-themes/gtk-engines2
USES= gettext gmake libtool pathfix pkgconfig tar:xz
-USE_GNOME= gnomeprefix libgsf gtk20 introspection:build
+USE_GNOME= gnomeprefix libgsf gdkpixbuf2 introspection:build libxml2 \
+ pango
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
-CONFIGURE_ARGS= --with-svgz \
- --disable-vala \
- --with-croco \
- --disable-Bsymbolic \
- --enable-gtk-theme
+CONFIGURE_ARGS= --disable-vala \
+ --disable-Bsymbolic
post-patch:
- @${REINPLACE_CMD} -e 's|GTK3_REQUIRED=3.[0-9].[0-9]|GTK3_REQUIRED=9.90.0|g' \
+ @${REINPLACE_CMD} -e 's|GTK3_REQUIRED=3.[0-9][0-9].[0-9]|GTK3_REQUIRED=9.90.0|g' \
${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/graphics/librsvg2/distinfo b/graphics/librsvg2/distinfo
index 60cdb68e4fe7..5d1aecb7f0fc 100644
--- a/graphics/librsvg2/distinfo
+++ b/graphics/librsvg2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnome2/librsvg-2.40.9.tar.xz) = 13964c5d35357552b47d365c34215eee0a63bf0e6059b689f048648c6bf5f43a
-SIZE (gnome2/librsvg-2.40.9.tar.xz) = 519172
+SHA256 (gnome2/librsvg-2.40.10.tar.xz) = 965c807438ce90b204e930ff80c92eba1606a2f6fd5ccfd09335c99896dd3479
+SIZE (gnome2/librsvg-2.40.10.tar.xz) = 522668
diff --git a/graphics/librsvg2/pkg-plist b/graphics/librsvg2/pkg-plist
index 723c51790fb1..bd2c287f1c31 100644
--- a/graphics/librsvg2/pkg-plist
+++ b/graphics/librsvg2/pkg-plist
@@ -9,7 +9,7 @@ lib/girepository-1.0/Rsvg-2.0.typelib
lib/librsvg-2.a
lib/librsvg-2.so
lib/librsvg-2.so.2
-lib/librsvg-2.so.2.40.9
+lib/librsvg-2.so.2.40.10
libdata/pkgconfig/librsvg-2.0.pc
man/man1/rsvg-convert.1.gz
share/doc/rsvg-2.0/RsvgHandle.html
@@ -26,9 +26,11 @@ share/doc/rsvg-2.0/api-index-full.html
share/doc/rsvg-2.0/home.png
share/doc/rsvg-2.0/index.html
share/doc/rsvg-2.0/index.sgml
+share/doc/rsvg-2.0/left-insensitive.png
share/doc/rsvg-2.0/left.png
share/doc/rsvg-2.0/licence.html
share/doc/rsvg-2.0/object-tree.html
+share/doc/rsvg-2.0/right-insensitive.png
share/doc/rsvg-2.0/right.png
share/doc/rsvg-2.0/rsvg-2.0.devhelp2
share/doc/rsvg-2.0/rsvg-Using-RSVG-with-GIO.html
@@ -37,6 +39,7 @@ share/doc/rsvg-2.0/rsvg-Using-RSVG-with-cairo.html
share/doc/rsvg-2.0/rsvg-Version-check-and-feature-tests.html
share/doc/rsvg-2.0/rsvg.html
share/doc/rsvg-2.0/style.css
+share/doc/rsvg-2.0/up-insensitive.png
share/doc/rsvg-2.0/up.png
share/gir-1.0/Rsvg-2.0.gir
@exec %D/bin/gdk-pixbuf-query-loaders > /dev/null 2>&1 && %D/bin/gdk-pixbuf-query-loaders > %D/lib/gdk-pixbuf-2.0/%%GTK2_VERSION%%/loaders.cache 2>/dev/null || /usr/bin/true