aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2002-03-01 18:22:11 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2002-03-01 18:22:11 +0000
commit58f7605a7aedea0accf1bb54e3264768a1480d3d (patch)
treedc817147b41dc0e9139b43dcf8c52dce927c7cae /graphics
parent3cbbd0bdd21def904417dbbd12002231420d6891 (diff)
downloadports-58f7605a7aedea0accf1bb54e3264768a1480d3d.tar.gz
ports-58f7605a7aedea0accf1bb54e3264768a1480d3d.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/xine_mms_plugin/Makefile31
-rw-r--r--graphics/xine_mms_plugin/distinfo1
-rw-r--r--graphics/xine_mms_plugin/files/patch-ltmain.sh24
-rw-r--r--graphics/xine_mms_plugin/pkg-comment1
-rw-r--r--graphics/xine_mms_plugin/pkg-descr3
-rw-r--r--graphics/xine_mms_plugin/pkg-plist2
7 files changed, 63 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index da375faf74b1..9f131dabe2bb 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -341,6 +341,7 @@
SUBDIR += xgrasp
SUBDIR += xine
SUBDIR += xine_d4d_plugin
+ SUBDIR += xine_mms_plugin
SUBDIR += xli
SUBDIR += xmagv
SUBDIR += xmandel
diff --git a/graphics/xine_mms_plugin/Makefile b/graphics/xine_mms_plugin/Makefile
new file mode 100644
index 000000000000..cc92861853dd
--- /dev/null
+++ b/graphics/xine_mms_plugin/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: xine_mms_plugin
+# Date created: 2001/02/04
+# Whom: Norikatsu Shigemura <nork@cityfujisawa.ne.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xine_mms_plugin
+PORTVERSION= 0.0.3
+CATEGORIES= graphics
+MASTER_SITES= http://www.geocities.com/majormms/
+DISTNAME= ${PORTNAME:S/_mms_plugin/-mms/}-${PORTVERSION}
+
+MAINTAINER= nork@cityfujisawa.ne.jp
+
+LIB_DEPENDS= xine.0:${PORTSDIR}/graphics/libxine
+
+GNU_CONFIGURE= yes
+USE_X_PREFIX= yes
+CONFIGURE_ENV= THREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+ THREAD_LIBS="${PTHREAD_LIBS}"
+INSTALLS_SHLIB= yes
+
+post-patch:
+ @${PERL} -pi -e \
+ 's|THREAD_LIBS=.*$$|THREAD_LIBS="\$$THREAD_LIBS"|g ; \
+ s|THREAD_CFLAGS=.*$$|THREAD_CFLAGS="\$$THREAD_CFLAGS"|g ; \
+ s|-L/usr/local/lib||g ; \
+ s|-I/usr/local/include||g' ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/graphics/xine_mms_plugin/distinfo b/graphics/xine_mms_plugin/distinfo
new file mode 100644
index 000000000000..45b0d5058e09
--- /dev/null
+++ b/graphics/xine_mms_plugin/distinfo
@@ -0,0 +1 @@
+MD5 (xine-mms-0.0.3.tar.gz) = ca6d5f097da255f757107bac6ac2f1f2
diff --git a/graphics/xine_mms_plugin/files/patch-ltmain.sh b/graphics/xine_mms_plugin/files/patch-ltmain.sh
new file mode 100644
index 000000000000..d1cf2ae1bad3
--- /dev/null
+++ b/graphics/xine_mms_plugin/files/patch-ltmain.sh
@@ -0,0 +1,24 @@
+--- ltmain.sh.orig Sat Mar 2 01:46:01 2002
++++ ltmain.sh Sat Mar 2 01:48:30 2002
+@@ -958,6 +958,7 @@
+ ;;
+
+ -avoid-version)
++ build_old_libs=no
+ avoid_version=yes
+ continue
+ ;;
+@@ -4247,11 +4248,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
+-
++ fi
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
+ ;;
diff --git a/graphics/xine_mms_plugin/pkg-comment b/graphics/xine_mms_plugin/pkg-comment
new file mode 100644
index 000000000000..5f207b1187cd
--- /dev/null
+++ b/graphics/xine_mms_plugin/pkg-comment
@@ -0,0 +1 @@
+A Windows Media Player input plugin for xine
diff --git a/graphics/xine_mms_plugin/pkg-descr b/graphics/xine_mms_plugin/pkg-descr
new file mode 100644
index 000000000000..936c39480ba3
--- /dev/null
+++ b/graphics/xine_mms_plugin/pkg-descr
@@ -0,0 +1,3 @@
+A Windows Media Player input plugin for xine.
+
+WWW: http://www.geocities.com/majormms/
diff --git a/graphics/xine_mms_plugin/pkg-plist b/graphics/xine_mms_plugin/pkg-plist
new file mode 100644
index 000000000000..e09b5ef3711c
--- /dev/null
+++ b/graphics/xine_mms_plugin/pkg-plist
@@ -0,0 +1,2 @@
+lib/xine/plugins/xineplug_inp_mms.so
+@unexec rmdir %D/lib/xine/plugins 2>/dev/null || true