aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-09-12 09:01:29 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-09-12 09:01:29 +0000
commit7983db8267cc723de9c86ba11f41cd56cb0ef115 (patch)
tree9a9add8e454c207f5cf16f53afff60f6f4bd8d76 /graphics
parent7f677f7c8883c9a9af0c102720fa29a7405a0813 (diff)
downloadports-7983db8267cc723de9c86ba11f41cd56cb0ef115.tar.gz
ports-7983db8267cc723de9c86ba11f41cd56cb0ef115.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/deegree-wms/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/graphics/deegree-wms/Makefile b/graphics/deegree-wms/Makefile
index 66698ed78fee..5a9f77f9361a 100644
--- a/graphics/deegree-wms/Makefile
+++ b/graphics/deegree-wms/Makefile
@@ -34,14 +34,14 @@ OPTIONS_DEFINE= DOCS
.if ${PORT_OPTIONS:MTOMCAT6}
TOMCATVER= apache-tomcat-6.0
-TCPORT= 8180
+TCPORT= 8180
BUILD_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:www/tomcat6
RUN_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:www/tomcat6
.endif
.if ${PORT_OPTIONS:MTOMCAT7}
TOMCATVER= apache-tomcat-7.0
-TCPORT= 8080
+TCPORT= 8080
BUILD_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:www/tomcat7
RUN_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:www/tomcat7
.endif
@@ -51,9 +51,11 @@ post-extract:
@${TAR} xf ${WRKDIR}/deegree-wms.war -C ${WRKDIR}/${PORTDIRNAME}
do-install:
- ${INSTALL} -d ${STAGEDIR}${WEBAPPDIR}/${PORTDIRNAME}
+ @${MKDIR} ${STAGEDIR}${WEBAPPDIR}/${PORTDIRNAME}
@cd ${WRKDIR}/${PORTDIRNAME} && ${COPYTREE_SHARE} \* ${STAGEDIR}${WEBAPPDIR}/${PORTDIRNAME}
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKDIR}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>