aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2010-04-27 21:58:27 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2010-04-27 21:58:27 +0000
commit805405e3964a2085115a4bf50e79a34c71503d3b (patch)
treeee5451fa7080b87e26fda61d66c845b257fdbb3d /graphics
parenta2ebdc120f17ae91a89c7bae11d08c5175686f01 (diff)
downloadports-805405e3964a2085115a4bf50e79a34c71503d3b.tar.gz
ports-805405e3964a2085115a4bf50e79a34c71503d3b.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/blender/Makefile3
-rw-r--r--graphics/enblend/Makefile5
-rw-r--r--graphics/hugin/Makefile4
-rw-r--r--graphics/py-amanith/Makefile4
-rw-r--r--graphics/py-glewpy/Makefile2
-rw-r--r--graphics/py-soya3d/Makefile3
-rw-r--r--graphics/reallyslick/Makefile2
-rw-r--r--graphics/tulip/Makefile5
8 files changed, 12 insertions, 16 deletions
diff --git a/graphics/blender/Makefile b/graphics/blender/Makefile
index 6d363454002f..83d289f4c8b4 100644
--- a/graphics/blender/Makefile
+++ b/graphics/blender/Makefile
@@ -19,13 +19,12 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libode.a:${PORTSDIR}/devel/ode
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
png.6:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
- GLEW.1:${PORTSDIR}/graphics/glew \
IlmThread.6:${PORTSDIR}/graphics/ilmbase
USE_XORG= x11 xext xmu xi
USE_PYTHON= 2.5+
USE_SDL= sdl
-USE_GL= gl glu
+USE_GL= glew
USE_GMAKE= yes
MAKE_JOBS_UNSAFE= yes
diff --git a/graphics/enblend/Makefile b/graphics/enblend/Makefile
index 77bfd14f7439..d7e84673c254 100644
--- a/graphics/enblend/Makefile
+++ b/graphics/enblend/Makefile
@@ -17,8 +17,7 @@ COMMENT= A tool for image blending with multiresolution splines
BUILD_DEPENDS= ${LOCALBASE}/include/boost/pool/pool.hpp:${PORTSDIR}/devel/boost-libs \
OpenEXR>=1.0:${PORTSDIR}/graphics/OpenEXR
-LIB_DEPENDS= GLEW.1:${PORTSDIR}/graphics/glew \
- jpeg.11:${PORTSDIR}/graphics/jpeg \
+LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
lcms:${PORTSDIR}/graphics/lcms \
xmi.1:${PORTSDIR}/graphics/plotutils \
tiff.4:${PORTSDIR}/graphics/tiff
@@ -32,7 +31,7 @@ USE_AUTOTOOLS= automake:110:env autoconf:262:env
# http://groups.google.com/group/hugin-ptx/browse_thread/thread/725b1581c9889e37/50abe3387d61541a#50abe3387d61541a
# Gerald Pfeifer <gerald@pfeifer.com> asked to use 4.4+ instead of 4.3+
USE_GCC= 4.4+
-USE_GL= glut
+USE_GL= glew glut
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/graphics/hugin/Makefile b/graphics/hugin/Makefile
index 6f7eb1ea2e5c..d371d81fb763 100644
--- a/graphics/hugin/Makefile
+++ b/graphics/hugin/Makefile
@@ -21,8 +21,6 @@ LIB_DEPENDS= tiff:${PORTSDIR}/graphics/tiff \
exiv2:${PORTSDIR}/graphics/exiv2 \
pano13:${PORTSDIR}/graphics/libpano13 \
boost_python:${PORTSDIR}/devel/boost-python-libs \
- GLEW:${PORTSDIR}/graphics/glew \
- glut:${PORTSDIR}/graphics/libglut \
IlmImf:${PORTSDIR}/graphics/OpenEXR \
Imath:${PORTSDIR}/graphics/ilmbase
# gmake is really needed at _runtime_, do not remove it from below
@@ -44,6 +42,8 @@ USE_WX= 2.8+
USE_GETTEXT= yes
+USE_GL= glew glut
+
MAN1= \
PTBatcherGUI.1 \
align_image_stack.1 \
diff --git a/graphics/py-amanith/Makefile b/graphics/py-amanith/Makefile
index 8040264cedd7..adde583be2e6 100644
--- a/graphics/py-amanith/Makefile
+++ b/graphics/py-amanith/Makefile
@@ -17,10 +17,10 @@ DIST_SUBDIR= python
MAINTAINER= acm@FreeBSD.org
COMMENT= Python wrapper for the amanith 2D vector graphics library
-LIB_DEPENDS= GLEW.1:${PORTSDIR}/graphics/glew \
- amanith.1:${PORTSDIR}/graphics/amanith
+LIB_DEPENDS= amanith.1:${PORTSDIR}/graphics/amanith
BUILD_DEPENDS= swig:${PORTSDIR}/devel/swig13
+USE_GL= glew
USE_PYTHON= 2.4+
USE_PYDISTUTILS=yes
PYDISTUTILS_PKGNAME= PyAmanith
diff --git a/graphics/py-glewpy/Makefile b/graphics/py-glewpy/Makefile
index 549df259c962..91a600e3ca55 100644
--- a/graphics/py-glewpy/Makefile
+++ b/graphics/py-glewpy/Makefile
@@ -20,8 +20,8 @@ MAINTAINER= acm@FreeBSD.org
COMMENT= Advanced OpenGL extensions to Python
BUILD_DEPENDS= pyrex>=0.9.6.2:${PORTSDIR}/devel/pyrex
-LIB_DEPENDS= GLEW.1:${PORTSDIR}/graphics/glew
+USE_GL= glew
USE_PYTHON= 2.4+
USE_PYDISTUTILS=yes
diff --git a/graphics/py-soya3d/Makefile b/graphics/py-soya3d/Makefile
index 9b2daf982830..014df2d8cba7 100644
--- a/graphics/py-soya3d/Makefile
+++ b/graphics/py-soya3d/Makefile
@@ -21,7 +21,6 @@ COMMENT= Very high level 3D engine for Python
BUILD_DEPENDS= ${LOCALBASE}/lib/libode.a:${PORTSDIR}/devel/ode \
${PYTHON_SITELIBDIR}/PIL.pth:${PORTSDIR}/graphics/py-imaging
LIB_DEPENDS= cal3d.12:${PORTSDIR}/graphics/cal3d \
- GLEW.1:${PORTSDIR}/graphics/glew \
freetype.9:${PORTSDIR}/print/freetype2
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/editobj/editor.py:${PORTSDIR}/graphics/py-editobj \
${PYTHON_SITELIBDIR}/tofu/client.py:${PORTSDIR}/net/py-tofu \
@@ -31,7 +30,7 @@ USE_BZIP2= yes
USE_PYTHON= yes
USE_PYDISTUTILS= yes
USE_OPENAL= al alut
-USE_GL= gl
+USE_GL= glew
USE_GMAKE= yes
USE_SDL= sdl
diff --git a/graphics/reallyslick/Makefile b/graphics/reallyslick/Makefile
index 5f25e5d86ad5..4205ec8ef814 100644
--- a/graphics/reallyslick/Makefile
+++ b/graphics/reallyslick/Makefile
@@ -46,7 +46,7 @@ CONFIGURE_ARGS+= --disable-sound
.endif
.if defined(WITH_GLEW)
-LIB_DEPENDS+= GLEW.1:${PORTSDIR}/graphics/glew
+USE_GL+= glew
.else
CONFIGURE_ENV+= ac_cv_header_GL_glew_h=no
.endif
diff --git a/graphics/tulip/Makefile b/graphics/tulip/Makefile
index 504d48abbb4b..eef80aef9c89 100644
--- a/graphics/tulip/Makefile
+++ b/graphics/tulip/Makefile
@@ -15,14 +15,13 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= gahr@FreeBSD.org
COMMENT= A system dedicated to the visualization of huge graphs
-LIB_DEPENDS= GLEW.1:${PORTSDIR}/graphics/glew \
- freetype.9:${PORTSDIR}/print/freetype2
+LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
USE_BZIP2= yes
USE_QT_VER= 4
QT_COMPONENTS= corelib moc_build uic_build rcc_build gui opengl xml network \
designer assistant assistantclient
-USE_GL= glut
+USE_GL= glew glut
USE_GMAKE= yes
USE_GNOME= libxml2
USE_AUTOTOOLS= libtool:22