aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-05-27 13:08:56 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-05-27 13:08:56 +0000
commit9750e2deaed3f46293ea90e3b4967c9ce8b23b09 (patch)
tree3bb1d63777da9b52ecd6df367076c99959f38bd3 /graphics
parent931c67cd8bf02fd5807e865bdb3c2823e6a1cf09 (diff)
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/mypaint/Makefile21
1 files changed, 12 insertions, 9 deletions
diff --git a/graphics/mypaint/Makefile b/graphics/mypaint/Makefile
index c27112803d22..06626f5b9089 100644
--- a/graphics/mypaint/Makefile
+++ b/graphics/mypaint/Makefile
@@ -14,23 +14,20 @@ COMMENT= Fast painting/scribbling program
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy \
${PYTHON_SITELIBDIR}/cairo:${PORTSDIR}/graphics/py-cairo \
${PYTHON_PKGNAMEPREFIX}protobuf>0:${PORTSDIR}/devel/py-protobuf
-LIB_DEPENDS= json:${PORTSDIR}/devel/json-c \
- lcms2:${PORTSDIR}/graphics/lcms2
+LIB_DEPENDS= libjson.so:${PORTSDIR}/devel/json-c \
+ liblcms2.so:${PORTSDIR}/graphics/lcms2
BUILD_DEPENDS:= ${RUN_DEPENDS} \
swig:${PORTSDIR}/devel/swig13 \
protoc:${PORTSDIR}/devel/protobuf
-USE_BZIP2= yes
USE_GNOME= glib20 pygtk2
USE_PYTHON= yes
-USE_SCONS= yes
-SCONS_ARGS= prefix="${PREFIX}"
-USES= gettext pkgconfig
+MAKE_ARGS= prefix="${PREFIX}"
+USES= gettext pkgconfig scons tar:bzip2
INSTALLS_ICONS= yes
SUB_FILES= pkg-install
-NO_STAGE= yes
post-patch:
${REINPLACE_CMD} -e 's,<malloc.h>,<stdlib.h>,' \
${WRKSRC}/brushlib/operationqueue.c \
@@ -38,7 +35,13 @@ post-patch:
@${REINPLACE_CMD} 's|-O3||g; s|-g||g' \
${WRKSRC}/SConstruct
-post-install:
- @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+pre-install:
+ @${RM} -rf ${WRKSRC}/sandbox 2>/dev/null || true
+ @cd ${WRKSRC}; ${MAKE_CMD} ${MAKE_ARGS} --install-sandbox=pre-stage
+
+do-install:
+.for d in . po brushlib brushlib/po
+ @cd ${WRKSRC}/${d}/pre-stage; ${PAX} -rw . ${STAGEDIR}
+.endfor
.include <bsd.port.mk>