aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-08-24 21:10:50 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-08-24 21:10:50 +0000
commitc8caaa193291078ac8a8cd3aa003f068944d9849 (patch)
tree78645733d25b00ac1aefb75acbf282ced539b7d3 /graphics
parent74f7a90c2a0f0b038efd23365a89bfc675bbedf9 (diff)
downloadports-c8caaa193291078ac8a8cd3aa003f068944d9849.tar.gz
ports-c8caaa193291078ac8a8cd3aa003f068944d9849.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/giram/Makefile15
-rw-r--r--graphics/giram/files/patch-configure11
-rw-r--r--graphics/giram/files/patch-src+camera.c13
-rw-r--r--graphics/giram/files/patch-src+giram.c12
-rw-r--r--graphics/giram/files/patch-src+view.c6
-rw-r--r--graphics/giram/pkg-plist12
6 files changed, 10 insertions, 59 deletions
diff --git a/graphics/giram/Makefile b/graphics/giram/Makefile
index 7af6f43baf4e..42135a0c3ee6 100644
--- a/graphics/giram/Makefile
+++ b/graphics/giram/Makefile
@@ -3,7 +3,7 @@
PORTNAME= giram
PORTVERSION= 0.3.5
-PORTREVISION= 17
+PORTREVISION= 18
CATEGORIES= graphics
MASTER_SITES= http://freebsd.nsu.ru/distfiles/
@@ -14,23 +14,24 @@ LIB_DEPENDS= lib3ds-1.so:${PORTSDIR}/graphics/lib3ds
BUILD_DEPENDS= povray:${PORTSDIR}/graphics/povray-meta
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= gettext perl5 pkgconfig gmake
+USES= gettext gmake libtool perl5 pkgconfig
USE_PERL5= build
USE_GNOME= gtk20
-USE_AUTOTOOLS= libtool
+GNU_CONFIGURE= yes
CONFIGURE_ENV= INTLTOOL_PERL="${PERL}"
-LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --datadir="${PREFIX}/lib" \
+ --disable-static \
--with-tutorial-path="${DOCSDIR}" \
--with-lib3ds-prefix="${LOCALBASE}"
CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib -lm
OPTIONS_DEFINE= DOCS EXAMPLES
post-patch:
- @${REINPLACE_CMD} -e '36s,static ,,' ${WRKSRC}/src/tools/tool_disc.c
- @${REINPLACE_CMD} -e 's|-D.*_DISABLE_DEPRECATED||g' \
- ${WRKSRC}/configure
+ @${REINPLACE_CMD} '/^giram_LDADD =/s/$$/ -lgmodule-2.0/' \
+ ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} '/DiscWithHoleFlag/d' ${WRKSRC}/src/tools/tool_disc.h
post-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
diff --git a/graphics/giram/files/patch-configure b/graphics/giram/files/patch-configure
index 3f6755793913..b12310a4ac90 100644
--- a/graphics/giram/files/patch-configure
+++ b/graphics/giram/files/patch-configure
@@ -1,19 +1,10 @@
--- configure.orig Sat Mar 8 21:30:47 2003
+++ configure Sun May 25 21:41:54 2003
-@@ -5432,6 +5432,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
-@@ -5843,7 +5844,7 @@
+@@ -5843,7 +5843,6 @@
fi
-CFLAGS="-g -Wall -DGTK_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DG_DISABLE_DEPRECATED $CFLAGS"
-+CFLAGS="-DGTK_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DG_DISABLE_DEPRECATED $CFLAGS"
if test -n "$DEBUGFLAG"; then
CFLAGS="$DEBUGFLAG $CFLAGS"
diff --git a/graphics/giram/files/patch-src+camera.c b/graphics/giram/files/patch-src+camera.c
deleted file mode 100644
index 0e5f8a62beb8..000000000000
--- a/graphics/giram/files/patch-src+camera.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/camera.c.orig Fri Aug 9 18:19:56 2002
-+++ src/camera.c Tue Oct 26 17:04:03 2004
-@@ -19,6 +19,10 @@
-
- #include <stdlib.h>
- #include <stdio.h>
-+
-+#undef GTK_DISABLE_DEPRECATED
-+#warning GTK_DISABLE_DEPRECATED
-+
- #include <math.h>
- #include "giram.h"
- #include "utils.h"
diff --git a/graphics/giram/files/patch-src+giram.c b/graphics/giram/files/patch-src+giram.c
deleted file mode 100644
index 493a74ec48fb..000000000000
--- a/graphics/giram/files/patch-src+giram.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/giram.c.orig Sun Dec 29 02:49:03 2002
-+++ src/giram.c Tue Oct 26 17:04:03 2004
-@@ -26,6 +26,9 @@
- #include <sys/types.h>
- #include <sys/wait.h>
-
-+#undef GTK_DISABLE_DEPRECATED
-+#warning GTK_DISABLE_DEPRECATED
-+
- #ifndef WAIT_ANY
- #define WAIT_ANY (-1)
- #endif /* WAIT_ANY */
diff --git a/graphics/giram/files/patch-src+view.c b/graphics/giram/files/patch-src+view.c
index 721522ad08f3..339577bf34f7 100644
--- a/graphics/giram/files/patch-src+view.c
+++ b/graphics/giram/files/patch-src+view.c
@@ -1,14 +1,10 @@
--- src/view.c.orig Sat Aug 10 02:25:18 2002
+++ src/view.c Tue Oct 26 17:04:03 2004
-@@ -22,8 +22,13 @@
+@@ -22,8 +22,9 @@
#include <unistd.h>
#include <math.h>
#include <string.h>
-#include "giram.h"
-+
-+#undef GTK_DISABLE_DEPRECATED
-+#warning GTK_DISABLE_DEPRECATED
-+
#include <gdk/gdkkeysyms.h>
+#include <gtk/gtkitemfactory.h>
+#include "giram.h"
diff --git a/graphics/giram/pkg-plist b/graphics/giram/pkg-plist
index cd786c768e75..4a7813e90e4f 100644
--- a/graphics/giram/pkg-plist
+++ b/graphics/giram/pkg-plist
@@ -9,23 +9,11 @@ lib/giram/0.3/color/color1.gcf
lib/giram/0.3/finish/finish1
lib/giram/0.3/giram_logo.ppm
lib/giram/0.3/giram_splash.ppm
-lib/giram/0.3/modules/librender_flat.a
-lib/giram/0.3/modules/librender_flat.la
lib/giram/0.3/modules/librender_flat.so
-lib/giram/0.3/modules/librender_gouraud.a
-lib/giram/0.3/modules/librender_gouraud.la
lib/giram/0.3/modules/librender_gouraud.so
-lib/giram/0.3/modules/librender_hiddenfaces.a
-lib/giram/0.3/modules/librender_hiddenfaces.la
lib/giram/0.3/modules/librender_hiddenfaces.so
-lib/giram/0.3/modules/librender_povray.a
-lib/giram/0.3/modules/librender_povray.la
lib/giram/0.3/modules/librender_povray.so
-lib/giram/0.3/modules/librender_raytracing.a
-lib/giram/0.3/modules/librender_raytracing.la
lib/giram/0.3/modules/librender_raytracing.so
-lib/giram/0.3/modules/librender_wireframe.a
-lib/giram/0.3/modules/librender_wireframe.la
lib/giram/0.3/modules/librender_wireframe.so
lib/giram/0.3/normal/normal1
lib/giram/0.3/pigment/pigment1