aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-09-18 17:49:31 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-09-18 17:49:31 +0000
commitfe54d2a7c76c819f48572aaac53161c6073e4bc2 (patch)
treecd3a2332516a8e0f6a9b518a6f6eb3a97af4baa7 /graphics
parentb64acc87813cd14f5610cecd37bb98e52497b3fa (diff)
BROKEN on 5.x: Does not compile
Approved by: portmgr (self)
Notes
Notes: svn path=/head/; revision=118243
Diffstat (limited to 'graphics')
-rw-r--r--graphics/evolvotron/Makefile8
-rw-r--r--graphics/geomview/Makefile8
-rw-r--r--graphics/gimageview/Makefile4
-rw-r--r--graphics/gnofract4d/Makefile8
-rw-r--r--graphics/ivtools/Makefile4
5 files changed, 29 insertions, 3 deletions
diff --git a/graphics/evolvotron/Makefile b/graphics/evolvotron/Makefile
index 756b9b67ef02..7927c3c7761b 100644
--- a/graphics/evolvotron/Makefile
+++ b/graphics/evolvotron/Makefile
@@ -28,6 +28,12 @@ MAKE_ENV= QTDIR="${QT_PREFIX}" \
CONFIGURE_ENV= QTDIR="${QT_PREFIX}" \
QMAKESPEC=${LOCALBASE}/share/qt/mkspecs/freebsd-g++
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's/-pthread/${PTHREAD_LIBS}/' ${WRKSRC}/common.pro
@@ -40,4 +46,4 @@ do-install:
@${INSTALL_DATA} ${WRKSRC}/evolvotron.html ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/geomview/Makefile b/graphics/geomview/Makefile
index e49244927392..12480164b7d2 100644
--- a/graphics/geomview/Makefile
+++ b/graphics/geomview/Makefile
@@ -42,6 +42,12 @@ MAKE_ENV= CPU=FreeBSD MAPLE_LIB=${MAPLE_LIB}
AC_FAKE_FILES= aclocal.m4 config.h.in stamp-h stamp-h.in
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-configure:
cd ${WRKSRC}; ${TOUCH} ${AC_FAKE_FILES}
${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${TOUCH}
@@ -68,4 +74,4 @@ post-install:
${INSTALL_MAN} ${WRKSRC}/doc/html/pix/*.gif ${DOCSDIR}/html/pix
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/gimageview/Makefile b/graphics/gimageview/Makefile
index 33c82934ee18..b020bc91f199 100644
--- a/graphics/gimageview/Makefile
+++ b/graphics/gimageview/Makefile
@@ -26,6 +26,10 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
.if ${HAVE_GNOME:Mimlib}!=""
USE_GNOME+= imlib
PKGNAMESUFFIX= -imlib
diff --git a/graphics/gnofract4d/Makefile b/graphics/gnofract4d/Makefile
index ef6a0d9f6ce3..561ea7af820c 100644
--- a/graphics/gnofract4d/Makefile
+++ b/graphics/gnofract4d/Makefile
@@ -23,4 +23,10 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
INSTALLS_SHLIB= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/ivtools/Makefile b/graphics/ivtools/Makefile
index 2cba4f8b9bf9..b404b0aab70c 100644
--- a/graphics/ivtools/Makefile
+++ b/graphics/ivtools/Makefile
@@ -28,6 +28,10 @@ MAN1= idraw.1 iclass.1 drawtool.1 comterp.1 comdraw.1 flipbook.1 graphdraw.1
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
.if ${ARCH} != "i386"
BROKEN= "fails to configure on ${ARCH}"
.endif