aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2013-10-19 18:21:40 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2013-10-19 18:21:40 +0000
commit17d47988af6ac0b0fa59d1fbbdd3a352fc94d33a (patch)
treeafae911b1d19455cd1d207be4deca312b5f0e4ea /graphics
parent8fb91162233f8b32ff061e15d36c496e36453d63 (diff)
downloadports-17d47988af6ac0b0fa59d1fbbdd3a352fc94d33a.tar.gz
ports-17d47988af6ac0b0fa59d1fbbdd3a352fc94d33a.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/aaphoto/Makefile41
-rw-r--r--graphics/aaphoto/distinfo4
-rw-r--r--graphics/aaphoto/files/patch-Makefile.in2
-rw-r--r--graphics/aaphoto/files/patch-aaphoto.c10
4 files changed, 18 insertions, 39 deletions
diff --git a/graphics/aaphoto/Makefile b/graphics/aaphoto/Makefile
index f081fc70921e..11a2986c33f6 100644
--- a/graphics/aaphoto/Makefile
+++ b/graphics/aaphoto/Makefile
@@ -2,50 +2,39 @@
# $FreeBSD$
PORTNAME= aaphoto
-PORTVERSION= 0.41
-PORTREVISION= 1
+PORTVERSION= 0.43.1
CATEGORIES= graphics
-MASTER_SITES= http://log69.com/downloads/
-DISTNAME= ${PORTNAME}_sources_v${PORTVERSION}
MAINTAINER= mail@log69.com
COMMENT= Auto Adjust Photo, automatic color correction of photos
-LIB_DEPENDS= jasper:${PORTSDIR}/graphics/jasper \
- jpeg:${PORTSDIR}/graphics/jpeg \
- png15:${PORTSDIR}/graphics/png
-
LICENSE= GPLv3
-USE_AUTOTOOLS= autoheader
+LIB_DEPENDS= libjasper.so:${PORTSDIR}/graphics/jasper \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libpng15.so:${PORTSDIR}/graphics/png
+
+USE_GITHUB= yes
+GH_ACCOUNT= log69
+GH_COMMIT= e566f9b
+GH_TAGNAME= v${PORTVERSION}
+
GNU_CONFIGURE= yes
+USES= compiler
+
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-
PLIST_FILES= bin/aaphoto
-PORTDOCS= AUTHORS ChangeLog COPYING COPYRIGHT INSTALL LICENSE \
- NEWS README TODO
-NO_STAGE= yes
.include <bsd.port.pre.mk>
-.if (${ARCH} == "amd64" || ${ARCH} == "i386") && ${OSVERSION} >= 700000
+.if (${ARCH} == "amd64" || ${ARCH} == "i386") && ${OSVERSION} >= 700000 && \
+ ${COMPILER_TYPE} == gcc
CFLAGS+= -fopenmp -D__OPENMP__
.endif
do-install:
-.for FILE in aaphoto
- ${INSTALL_PROGRAM} ${WRKSRC}/${FILE} ${PREFIX}/bin
-.endfor
-
-post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-.for i in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
-.endfor
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/aaphoto ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.post.mk>
diff --git a/graphics/aaphoto/distinfo b/graphics/aaphoto/distinfo
index 9d6bd01c0b1e..68047e90db7c 100644
--- a/graphics/aaphoto/distinfo
+++ b/graphics/aaphoto/distinfo
@@ -1,2 +1,2 @@
-SHA256 (aaphoto_sources_v0.41.tar.gz) = f101ff954bcca194550f35acdcaac8e4b36df072a1c5406e73f2d3bab30d38cb
-SIZE (aaphoto_sources_v0.41.tar.gz) = 138407
+SHA256 (aaphoto-0.43.1.tar.gz) = 75c9ae7232411cf1ff83ebbe5acb9c817b5490cef08ce14cc2bd03097e7936e0
+SIZE (aaphoto-0.43.1.tar.gz) = 135277
diff --git a/graphics/aaphoto/files/patch-Makefile.in b/graphics/aaphoto/files/patch-Makefile.in
index 11c76f23f643..e301b374456c 100644
--- a/graphics/aaphoto/files/patch-Makefile.in
+++ b/graphics/aaphoto/files/patch-Makefile.in
@@ -6,7 +6,7 @@
top_srcdir = @top_srcdir@
-AM_CFLAGS = -Wall -O2 -D__OPENMP__ -fopenmp
-AM_LDFLAGS = -ljasper -ljpeg -lpng -lm -lgomp
-+AM_CFLAGS = -Wall -O2
++AM_CFLAGS = -Wall
+AM_LDFLAGS = -ljasper -ljpeg -lpng -lm
aaphoto_SOURCES = aaphoto.c
INCLUDES =
diff --git a/graphics/aaphoto/files/patch-aaphoto.c b/graphics/aaphoto/files/patch-aaphoto.c
deleted file mode 100644
index adb518502a76..000000000000
--- a/graphics/aaphoto/files/patch-aaphoto.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- aaphoto.c.orig 2011-01-26 16:39:58.000000000 +0100
-+++ aaphoto.c 2012-04-23 19:07:00.000000000 +0200
-@@ -243,6 +243,7 @@
- #ifndef __BMP_ONLY__
- #include <jasper/jasper.h>
- #include <png.h>
-+#include <zlib.h>
- #include <jpeglib.h>
- #endif
-