aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2012-06-04 16:53:46 +0000
committerAndrej Zverev <az@FreeBSD.org>2012-06-04 16:53:46 +0000
commit235b4458e31c1bd16f2db6c015e1d680929d9f7c (patch)
tree8bf9c10eb762439d5e125de2557c9d33353661a3 /graphics
parent968f8f63070fd1dcaa5087b266a7ae8ce0911010 (diff)
downloadports-235b4458e31c1bd16f2db6c015e1d680929d9f7c.tar.gz
ports-235b4458e31c1bd16f2db6c015e1d680929d9f7c.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/p5-CAD-Drawing-Template/Makefile4
-rw-r--r--graphics/p5-CAD-Drawing/Makefile12
-rw-r--r--graphics/p5-Chart-PNGgraph/Makefile4
-rw-r--r--graphics/p5-GD-Barcode/Makefile2
-rw-r--r--graphics/p5-Graph-SocialMap/Makefile10
5 files changed, 16 insertions, 16 deletions
diff --git a/graphics/p5-CAD-Drawing-Template/Makefile b/graphics/p5-CAD-Drawing-Template/Makefile
index b3a3c19ff06b..cc0d7ef88cb4 100644
--- a/graphics/p5-CAD-Drawing-Template/Makefile
+++ b/graphics/p5-CAD-Drawing-Template/Makefile
@@ -15,8 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Replace tags with text and geometry
-BUILD_DEPENDS= ${SITE_PERL}/CAD/Drawing.pm:${PORTSDIR}/graphics/p5-CAD-Drawing \
- ${SITE_PERL}/CAD/Calc.pm:${PORTSDIR}/math/p5-CAD-Calc
+BUILD_DEPENDS= p5-CAD-Drawing>=0:${PORTSDIR}/graphics/p5-CAD-Drawing \
+ p5-CAD-Calc>=0:${PORTSDIR}/math/p5-CAD-Calc
RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= CAD::Drawing::Template.3
diff --git a/graphics/p5-CAD-Drawing/Makefile b/graphics/p5-CAD-Drawing/Makefile
index f6c6a568a2b7..c311aef31519 100644
--- a/graphics/p5-CAD-Drawing/Makefile
+++ b/graphics/p5-CAD-Drawing/Makefile
@@ -15,12 +15,12 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Methods to create, load, and save vector graphics
-RUN_DEPENDS= ${SITE_PERL}/Math/Vec.pm:${PORTSDIR}/math/p5-Math-Vec \
- ${SITE_PERL}/CAD/Calc.pm:${PORTSDIR}/math/p5-CAD-Calc \
- ${SITE_PERL}/Math/MatrixReal.pm:${PORTSDIR}/math/p5-MatrixReal \
- ${SITE_PERL}/${PERL_ARCH}/Image/Magick.pm:${PORTSDIR}/graphics/ImageMagick \
- ${SITE_PERL}/Stream/FileInputStream.pm:${PORTSDIR}/devel/p5-Stream \
- ${SITE_PERL}/Math/Geometry/Planar.pm:${PORTSDIR}/math/p5-Math-Geometry-Planar
+RUN_DEPENDS= p5-Math-Vec>=0:${PORTSDIR}/math/p5-Math-Vec \
+ p5-CAD-Calc>=0:${PORTSDIR}/math/p5-CAD-Calc \
+ p5-MatrixReal>=0:${PORTSDIR}/math/p5-MatrixReal \
+ ImageMagick>=0:${PORTSDIR}/graphics/ImageMagick \
+ p5-Stream>=0:${PORTSDIR}/devel/p5-Stream \
+ p5-Math-Geometry-Planar>=0:${PORTSDIR}/math/p5-Math-Geometry-Planar
BUILD_DEPENDS= ${RUN_DEPENDS}
MAN3= CAD::Drawing.3 \
diff --git a/graphics/p5-Chart-PNGgraph/Makefile b/graphics/p5-Chart-PNGgraph/Makefile
index ba84b7b03e0e..e91d8e93e558 100644
--- a/graphics/p5-Chart-PNGgraph/Makefile
+++ b/graphics/p5-Chart-PNGgraph/Makefile
@@ -15,8 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= A Perl module for generating presentation graphics (i.e., charts)
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD \
- ${SITE_PERL}/GD/Graph.pm:${PORTSDIR}/graphics/p5-GD-Graph
+BUILD_DEPENDS= p5-GD>=0:${PORTSDIR}/graphics/p5-GD \
+ p5-GD-Graph>=0:${PORTSDIR}/graphics/p5-GD-Graph
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= YES
diff --git a/graphics/p5-GD-Barcode/Makefile b/graphics/p5-GD-Barcode/Makefile
index b7114bb22b0f..4a52307b3735 100644
--- a/graphics/p5-GD-Barcode/Makefile
+++ b/graphics/p5-GD-Barcode/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= GD::Barcode - Create barcode image with GD
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD
+BUILD_DEPENDS= p5-GD>=0:${PORTSDIR}/graphics/p5-GD
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/graphics/p5-Graph-SocialMap/Makefile b/graphics/p5-Graph-SocialMap/Makefile
index 8bac5608abd4..68c41498e2e1 100644
--- a/graphics/p5-Graph-SocialMap/Makefile
+++ b/graphics/p5-Graph-SocialMap/Makefile
@@ -15,11 +15,11 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Easy tool to create social network maps
-BUILD_DEPENDS= ${SITE_PERL}/Spiffy.pm:${PORTSDIR}/devel/p5-Spiffy \
- ${SITE_PERL}/Graph.pm:${PORTSDIR}/math/p5-Graph \
- ${SITE_PERL}/Graph/Writer/GraphViz.pm:${PORTSDIR}/graphics/p5-Graph-Writer-GraphViz \
- ${SITE_PERL}/Quantum/Superpositions.pm:${PORTSDIR}/lang/p5-Quantum-Superpositions \
- ${SITE_PERL}/YAML.pm:${PORTSDIR}/textproc/p5-YAML
+BUILD_DEPENDS= p5-Spiffy>=0:${PORTSDIR}/devel/p5-Spiffy \
+ p5-Graph>=0:${PORTSDIR}/math/p5-Graph \
+ p5-Graph-Writer-GraphViz>=0:${PORTSDIR}/graphics/p5-Graph-Writer-GraphViz \
+ p5-Quantum-Superpositions>=0:${PORTSDIR}/lang/p5-Quantum-Superpositions \
+ p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML
RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Graph::SocialMap.3