aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2013-05-11 17:58:55 +0000
committerHiroki Sato <hrs@FreeBSD.org>2013-05-11 17:58:55 +0000
commit4e09def2d4cfcd05ede8b5671ca97a7f676654b2 (patch)
tree4e99b662e9edb02c504f73d22596ea702c0f3d31 /graphics
parentf88394af09ffce9250caa45347e357f79b0100ff (diff)
downloadports-4e09def2d4cfcd05ede8b5671ca97a7f676654b2.tar.gz
ports-4e09def2d4cfcd05ede8b5671ca97a7f676654b2.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/epix/Makefile5
-rw-r--r--graphics/evince/Makefile2
-rw-r--r--graphics/gle-graphics/Makefile2
-rw-r--r--graphics/ipe/Makefile2
-rw-r--r--graphics/kdegraphics3/Makefile2
-rw-r--r--graphics/klatexformula/Makefile5
-rw-r--r--graphics/l2p/Makefile5
-rw-r--r--graphics/okular/Makefile2
-rw-r--r--graphics/py-PyX/Makefile2
9 files changed, 12 insertions, 15 deletions
diff --git a/graphics/epix/Makefile b/graphics/epix/Makefile
index 098739fd0ac8..b6f58ea7fbb8 100644
--- a/graphics/epix/Makefile
+++ b/graphics/epix/Makefile
@@ -18,13 +18,12 @@ COMMENT= Creates math plots and line figures using easy-to-learn syntax
LICENSE= GPLv2 # (or later)
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= dvips:${PORTSDIR}/print/dvipsk-tetex \
- latex-pgf>=0:${PORTSDIR}/print/latex-pgf \
+BUILD_DEPENDS= latex-pgf>=0:${PORTSDIR}/print/latex-pgf \
bash:${PORTSDIR}/shells/bash
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
USE_BZIP2= yes
-USE_TEX= tetex
+USE_TEX= latex dvipsk:build
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-bash=${LOCALBASE}/bin/bash \
diff --git a/graphics/evince/Makefile b/graphics/evince/Makefile
index e7681b702716..2bf0f7e163d9 100644
--- a/graphics/evince/Makefile
+++ b/graphics/evince/Makefile
@@ -55,7 +55,7 @@ DJVU_DESC= DJVU support
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDVI} || ${PORT_OPTIONS:MT1LIB}
-USE_TEX= tetex
+USE_TEX= latex
CONFIGURE_ARGS+= --enable-dvi
GCONF_SCHEMAS+= evince-thumbnailer-dvi.schemas
diff --git a/graphics/gle-graphics/Makefile b/graphics/gle-graphics/Makefile
index 7c6fc4e008c4..b6952e80d8f4 100644
--- a/graphics/gle-graphics/Makefile
+++ b/graphics/gle-graphics/Makefile
@@ -46,7 +46,7 @@ CONFIGURE_ARGS+= --with-jpeg=no --with-png=no -with-tiff=no
.if ${PORT_OPTIONS:MLATEX_GS}
USE_GHOSTSCRIPT_RUN= yes
-USE_TEX= tetex
+USE_TEX= latex
.endif
.if ${PORT_OPTIONS:MX11}
diff --git a/graphics/ipe/Makefile b/graphics/ipe/Makefile
index fd2e6ec9a1eb..85e4ab286e4c 100644
--- a/graphics/ipe/Makefile
+++ b/graphics/ipe/Makefile
@@ -22,7 +22,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
USES= pkgconfig
USE_QT4= gui moc_build qmake_build rcc_build uic_build
-USE_TEX= tetex-base
+USE_TEX= latex
USE_GMAKE= yes
MAKE_ENV= DLL_CFLAGS="-fPIC" \
ICONV_CFLAGS="-I${LOCALBASE}/include" \
diff --git a/graphics/kdegraphics3/Makefile b/graphics/kdegraphics3/Makefile
index 8f5c62ef215c..22b784e0c402 100644
--- a/graphics/kdegraphics3/Makefile
+++ b/graphics/kdegraphics3/Makefile
@@ -34,7 +34,7 @@ PREFIX= ${KDE_PREFIX}
USE_GL= glut
USE_BZIP2= yes
-USE_TEX= tetex
+USE_TEX= latex:build
USE_AUTOTOOLS= libtool
CONFIGURE_ARGS= --without-poppler
USE_GMAKE= yes
diff --git a/graphics/klatexformula/Makefile b/graphics/klatexformula/Makefile
index ec4b4eb03466..355d21fd42c0 100644
--- a/graphics/klatexformula/Makefile
+++ b/graphics/klatexformula/Makefile
@@ -14,12 +14,11 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= makc@FreeBSD.org
COMMENT= Convert LaTeX formula to image
-RUN_DEPENDS= dvips:${PORTSDIR}/print/dvipsk-tetex \
- ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme
+RUN_DEPENDS= ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme
USE_QT4= gui xml dbus designer_build \
qmake_build moc_build rcc_build uic_build
-USE_TEX= tetex
+USE_TEX= latex dvipsk
HAS_CONFIGURE= yes
USE_GHOSTSCRIPT= yes
QMAKE_ARGS= QMAKE=${QMAKE} INSTALLPREFIX=${PREFIX} \
diff --git a/graphics/l2p/Makefile b/graphics/l2p/Makefile
index 2e3862dcdc17..b46d029fa730 100644
--- a/graphics/l2p/Makefile
+++ b/graphics/l2p/Makefile
@@ -15,12 +15,11 @@ MASTER_SITES= http://www.redsymbol.net/software/l2p/dist/ \
MAINTAINER= nivit@FreeBSD.org
COMMENT= Create PNG images from LaTeX math expressions
-RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick \
- dvips:${PORTSDIR}/print/dvipsk-tetex
+RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick
USE_PERL5_RUN= yes
USE_ZIP= yes
-USE_TEX= tetex
+USE_TEX= latex dvipsk
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/graphics/okular/Makefile b/graphics/okular/Makefile
index c0b11b9fac27..1e4a29403fe3 100644
--- a/graphics/okular/Makefile
+++ b/graphics/okular/Makefile
@@ -38,7 +38,7 @@ DVI_DESC= Support DVI files (requires teTeX)
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDVI}
-USE_TEX= tetex
+USE_TEX= latex
.endif
.include <bsd.port.mk>
diff --git a/graphics/py-PyX/Makefile b/graphics/py-PyX/Makefile
index b421e0d2d40d..e776ac4eeb1e 100644
--- a/graphics/py-PyX/Makefile
+++ b/graphics/py-PyX/Makefile
@@ -14,7 +14,7 @@ LICENSE= GPLv2
USE_PYTHON= 2.5+
USE_PYDISTUTILS=yes
-USE_TEX= tetex
+USE_TEX= latex:build
OPTIONS_DEFINE= T1CODE KPATHSEA
OPTIONS_DEFAULT= T1CODE KPATHSEA