aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2014-10-07 16:48:54 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2014-10-07 16:48:54 +0000
commit950071eb62224d37b040d5f7493367650bfccef2 (patch)
tree788308c383bdba9b7b67100818801f75541bdfc8 /graphics
parent5b3bfaf08f4ac44e93ef3155de1dd41105491134 (diff)
downloadports-950071eb62224d37b040d5f7493367650bfccef2.tar.gz
ports-950071eb62224d37b040d5f7493367650bfccef2.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/impressive/Makefile6
-rw-r--r--graphics/impressive/files/patch-impressive.py13
2 files changed, 16 insertions, 3 deletions
diff --git a/graphics/impressive/Makefile b/graphics/impressive/Makefile
index 810f0a01bd70..74bbf9d146ce 100644
--- a/graphics/impressive/Makefile
+++ b/graphics/impressive/Makefile
@@ -3,7 +3,7 @@
PORTNAME= impressive
PORTVERSION= 0.10.3
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/Impressive/${PORTVERSION}/
DISTNAME= Impressive-${PORTVERSION}
@@ -14,14 +14,14 @@ COMMENT= The stylish way of giving presentations
LICENSE= GPLv2
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}opengl>=0:${PORTSDIR}/graphics/py-opengl \
- ${PYTHON_PKGNAMEPREFIX}imaging>0:${PORTSDIR}/graphics/py-imaging \
+ ${PYTHON_PKGNAMEPREFIX}pillow>0:${PORTSDIR}/graphics/py-pillow \
xpdf:${PORTSDIR}/graphics/xpdf \
pdftk:${PORTSDIR}/print/pdftk \
xdg-open:${PORTSDIR}/devel/xdg-utils \
mplayer:${PORTSDIR}/multimedia/mplayer \
${PYGAME}
-USE_PYTHON= yes
+USES= python
USE_GHOSTSCRIPT_RUN= yes
NO_BUILD= yes
PLIST_FILES= bin/${PORTNAME} \
diff --git a/graphics/impressive/files/patch-impressive.py b/graphics/impressive/files/patch-impressive.py
new file mode 100644
index 000000000000..160573fed2df
--- /dev/null
+++ b/graphics/impressive/files/patch-impressive.py
@@ -0,0 +1,13 @@
+--- impressive.py.orig 2014-10-04 23:28:04 UTC
++++ impressive.py
+@@ -182,8 +182,8 @@
+ from OpenGL.GL import *
+ import pygame
+ from pygame.locals import *
+- import Image, ImageDraw, ImageFont, ImageFilter
+- import TiffImagePlugin, BmpImagePlugin, JpegImagePlugin, PngImagePlugin, PpmImagePlugin
++ from PIL import Image, ImageDraw, ImageFont, ImageFilter
++ from PIL import TiffImagePlugin, BmpImagePlugin, JpegImagePlugin, PngImagePlugin, PpmImagePlugin
+ except (ValueError, ImportError), err:
+ print >>sys.stderr, "Oops! Cannot load necessary modules:", err
+ print >>sys.stderr, """To use Impressive, you need to install the following Python modules: