aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-06-10 20:23:30 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-06-10 20:23:30 +0000
commitb5b913a7832daab418359542d5c86925f6d5dfbc (patch)
tree9b74b1663f0988b092ac3f7379cae7a00508cd14 /graphics
parent00a40ddf76faa114603350df258c0a08498a4a73 (diff)
downloadports-b5b913a7832daab418359542d5c86925f6d5dfbc.tar.gz
ports-b5b913a7832daab418359542d5c86925f6d5dfbc.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/gx/Makefile23
-rw-r--r--graphics/gx/distinfo3
-rw-r--r--graphics/gx/pkg-descr5
-rw-r--r--graphics/gx/pkg-plist8
5 files changed, 40 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index cdc1c04c3b07..39eaa62b3f1c 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -252,6 +252,7 @@
SUBDIR += guilib
SUBDIR += gview
SUBDIR += gwenview
+ SUBDIR += gx
SUBDIR += hobbes-icons-xpm
SUBDIR += hpoj
SUBDIR += hppsmtools
diff --git a/graphics/gx/Makefile b/graphics/gx/Makefile
new file mode 100644
index 000000000000..d717d87a565a
--- /dev/null
+++ b/graphics/gx/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: gx
+# Date created: 11 June 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gx
+PORTVERSION= 0.4.0
+CATEGORIES= graphics
+MASTER_SITES= http://perticone.homelinux.net/sergio/c++/gx/src/ CENKES
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Lightweight image viewer
+
+LIB_DEPENDS= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24 \
+ gnomevfsmm-2.6.1:${PORTSDIR}/devel/gnome-vfsmm \
+ gconfmm-2.6.1:${PORTSDIR}/devel/gconfmm26
+
+USE_GETTEXT= yes
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/gx/distinfo b/graphics/gx/distinfo
new file mode 100644
index 000000000000..0ad3ba52e7cd
--- /dev/null
+++ b/graphics/gx/distinfo
@@ -0,0 +1,3 @@
+MD5 (gx-0.4.0.tar.gz) = 4aacbf154469a19cda1c29cfa6338082
+SHA256 (gx-0.4.0.tar.gz) = 4367995f0d7ebe2973a077291e5277ccb2746b32c1088baa705564833cf59e76
+SIZE (gx-0.4.0.tar.gz) = 378729
diff --git a/graphics/gx/pkg-descr b/graphics/gx/pkg-descr
new file mode 100644
index 000000000000..135ece767d35
--- /dev/null
+++ b/graphics/gx/pkg-descr
@@ -0,0 +1,5 @@
+gx is a small image viewer for Unix written in C++ (using gtkmm). It
+can rotate, rescale, and zoom in/out an image.
+
+WWW: http://perticone.homelinux.net/sergio/c++/gx/
+Author: Sergio Perticone <gall0ws@tiscali.it>
diff --git a/graphics/gx/pkg-plist b/graphics/gx/pkg-plist
new file mode 100644
index 000000000000..eb912ff037fa
--- /dev/null
+++ b/graphics/gx/pkg-plist
@@ -0,0 +1,8 @@
+bin/gx
+share/app-install/icons/gx.png
+share/app-install/desktop/gx.desktop
+share/pixmaps/gx.png
+share/pixmaps/gx_logo.png
+@dirrmtry share/app-install/icons
+@dirrmtry share/app-install/desktop
+@dirrmtry share/app-install