aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2010-10-03 17:34:20 +0000
committerThierry Thomas <thierry@FreeBSD.org>2010-10-03 17:34:20 +0000
commite9a532c3a941210453ec38d56af6c811e164c877 (patch)
tree0c394cdd2bbc099d69a0978d32af2b539dc77156 /graphics
parentdfcf8468917d698b7a4e0255f1b4ed30353cb9e8 (diff)
downloadports-e9a532c3a941210453ec38d56af6c811e164c877.tar.gz
ports-e9a532c3a941210453ec38d56af6c811e164c877.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/cimg/Makefile25
-rw-r--r--graphics/cimg/distinfo6
-rw-r--r--graphics/cimg/files/patch-CImg.h20
-rw-r--r--graphics/cimg/files/patch-examples::Makefile64
-rw-r--r--graphics/cimg/pkg-plist92
5 files changed, 143 insertions, 64 deletions
diff --git a/graphics/cimg/Makefile b/graphics/cimg/Makefile
index f351f3215d83..69166483bb4b 100644
--- a/graphics/cimg/Makefile
+++ b/graphics/cimg/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= cimg
-PORTVERSION= 1.3.1
-PORTREVISION= 5
+PORTVERSION= 1.4.3
PORTEPOCH= 2
CATEGORIES= graphics devel
-MASTER_SITES= SF/${PORTNAME}/OldFiles
-DISTNAME= CImg_${DISTVERSION}
+MASTER_SITES= SF/${PORTNAME} \
+ SF/${PORTNAME}/old
+DISTNAME= CImg-${DISTVERSION}
DIST_SUBDIR= ${PORTNAME}-${PORTVERSION},${PORTEPOCH}
MAINTAINER= thierry@FreeBSD.org
@@ -20,14 +20,21 @@ COMMENT= The C++ Template Image Processing Library
ONLY_FOR_ARCHS= i386 amd64
ONLY_FOR_ARCHS_REASON= "invokes i386 asm"
+LICENSE= CeCILL_C CeCILL
+LICENSE_PERMS_CeCILL_C= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+LICENSE_PERMS_CeCILL= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+LICENSE_NAME_CeCILL_C= CeCILL-C
+LICENSE_NAME_CeCILL= CeCILL
+LICENSE_FILE_CeCILL_C= ${WRKSRC}/Licence_CeCILL-C_V1-en.txt
+LICENSE_FILE_CeCILL= ${WRKSRC}/Licence_CeCILL_V2-en.txt
+LICENSE_COMB= dual
+
+USE_ZIP= yes
WRKSRC= ${WRKDIR}/${DISTNAME:C/_/-/}
BUILD_WRKSRC= ${WRKSRC}/examples
MAKE_ENV= CPPFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" \
LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}" \
- X11PATH=${LOCALBASE}
-
-# Disable ffmpeg, does not build with ffmpeg 0.5
-WITHOUT_FFMPEG= yes
+ X11PATH=${LOCALBASE} LOCALBASE=${LOCALBASE}
.if !defined(NOPORTDOCS)
USE_GMAKE= yes
@@ -41,6 +48,8 @@ USE_FORTRAN= yes
LIB_DEPENDS+= png:${PORTSDIR}/graphics/png \
jpeg:${PORTSDIR}/graphics/jpeg \
tiff:${PORTSDIR}/graphics/tiff \
+ cv:${PORTSDIR}/graphics/opencv \
+ IlmImf:${PORTSDIR}/graphics/OpenEXR \
gimp-2.0:${PORTSDIR}/graphics/gimp-app \
fftw3:${PORTSDIR}/math/fftw3 \
GraphicsMagick++:${PORTSDIR}/graphics/GraphicsMagick
diff --git a/graphics/cimg/distinfo b/graphics/cimg/distinfo
index 1dfc39e8970e..c46f366638d6 100644
--- a/graphics/cimg/distinfo
+++ b/graphics/cimg/distinfo
@@ -1,3 +1,3 @@
-MD5 (cimg-1.3.1,2/CImg_1.3.1.tar.gz) = 834129e4dd4c18858bdfbab2a21fd520
-SHA256 (cimg-1.3.1,2/CImg_1.3.1.tar.gz) = 650f1ebdef5e3633d227cf6d6ec1c0292377827d9ccbec208521bf0e9972d651
-SIZE (cimg-1.3.1,2/CImg_1.3.1.tar.gz) = 8002209
+MD5 (cimg-1.4.3,2/CImg-1.4.3.zip) = af3d5d3570115152c425f57abb40e276
+SHA256 (cimg-1.4.3,2/CImg-1.4.3.zip) = dc6aa5c9943b79eebc0f86c5e5674faf41184776c6603eda88ef48d0847b1f45
+SIZE (cimg-1.4.3,2/CImg-1.4.3.zip) = 10255080
diff --git a/graphics/cimg/files/patch-CImg.h b/graphics/cimg/files/patch-CImg.h
deleted file mode 100644
index e19adbf6a4da..000000000000
--- a/graphics/cimg/files/patch-CImg.h
+++ /dev/null
@@ -1,20 +0,0 @@
---- CImg.h.orig 2009-05-26 18:27:28.000000000 +0200
-+++ CImg.h 2010-03-29 18:04:12.000000000 +0200
-@@ -30161,7 +30161,7 @@
- png_read_info(png_ptr,info_ptr);
- png_uint_32 W, H;
- int bit_depth, color_type, interlace_type;
-- png_get_IHDR(png_ptr,info_ptr,&W,&H,&bit_depth,&color_type,&interlace_type,int_p_NULL,int_p_NULL);
-+ png_get_IHDR(png_ptr,info_ptr,&W,&H,&bit_depth,&color_type,&interlace_type,NULL,NULL);
- int new_bit_depth = bit_depth;
- int new_color_type = color_type;
-
-@@ -30172,7 +30172,7 @@
- new_bit_depth = 8;
- }
- if (new_color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8){
-- png_set_gray_1_2_4_to_8(png_ptr);
-+ png_set_expand_gray_1_2_4_to_8(png_ptr);
- new_bit_depth = 8;
- }
- if (png_get_valid(png_ptr, info_ptr, PNG_INFO_tRNS))
diff --git a/graphics/cimg/files/patch-examples::Makefile b/graphics/cimg/files/patch-examples::Makefile
index 1c2db223ef9d..aa312356c8a9 100644
--- a/graphics/cimg/files/patch-examples::Makefile
+++ b/graphics/cimg/files/patch-examples::Makefile
@@ -1,9 +1,9 @@
---- examples/Makefile.orig 2009-05-26 18:27:25.000000000 +0200
-+++ examples/Makefile 2009-05-29 21:57:25.000000000 +0200
-@@ -77,8 +77,8 @@
+--- examples/Makefile.orig 2010-10-01 15:26:30.000000000 +0200
++++ examples/Makefile 2010-10-03 15:09:36.000000000 +0200
+@@ -85,8 +85,8 @@
# Set correct variables and paths
#---------------------------------
- CIMG_VERSION = 1.31
+ CIMG_VERSION = 1.4.3
-X11PATH = /usr/X11R6
-CC = g++
+#X11PATH = /usr/X11R6
@@ -11,27 +11,51 @@
CCVER = `$(CC) -v 2>&1 | tail -n 1`
EXEPFX =
-@@ -105,7 +105,7 @@
+@@ -120,7 +120,7 @@
ifeq ($(CC),icc)
CIMG_OPT_CFLAGS = -O3 -ipo -no-prec-div
else
--CIMG_OPT_CFLAGS = -O3 -ffast-math -fno-tree-pre
-+CIMG_OPT_CFLAGS = -ffast-math -fno-tree-pre
+-CIMG_OPT_CFLAGS = -O3 -fno-tree-pre
++CIMG_OPT_CFLAGS = -fno-tree-pre
endif
# Flags to enable OpenMP support.
-@@ -157,8 +157,8 @@
+@@ -131,7 +131,7 @@
+ endif
+
+ # Flags to enable OpenCV support.
+-CIMG_OPENCV_CFLAGS = -Dcimg_use_opencv -I/usr/include/opencv
++CIMG_OPENCV_CFLAGS = -Dcimg_use_opencv -I$(LOCALBASE)/include/opencv
+ CIMG_OPENCV_LDFLAGS = -lcv -lhighgui
+
+ # Flags used to disable display capablities of CImg
+@@ -141,7 +141,7 @@
+ # (X11 is used by CImg to handle display windows)
+ # !!! For 64bits systems : replace -L$(X11PATH)/lib by -L$(X11PATH)/lib64 !!!
+ CIMG_X11_CFLAGS = -I$(X11PATH)/include
+-CIMG_X11_LDFLAGS = -L$(X11PATH)/lib -lpthread -lX11
++CIMG_X11_LDFLAGS = -L$(X11PATH)/lib -lX11 $(PTHREAD_LIBS)
+
+ # Flags to enable fast image display, using the XSHM library (when using X11).
+ # !!! Seems to randomly crash when used on MacOSX, so do not use it on MacOSX !!!
+@@ -175,13 +175,13 @@
+
+ # Flags to enable native support for EXR image files, using the OpenEXR library.
+ # ( http://www.openexr.com/ )
+-CIMG_EXR_CFLAGS = -Dcimg_use_openexr -I/usr/include/OpenEXR
++CIMG_EXR_CFLAGS = -Dcimg_use_openexr -I$(LOCALBASE)/include/OpenEXR
+ CIMG_EXR_LDFLAGS = -lIlmImf
# Flags to enable native support for various video files, using the FFMPEG library.
# ( http://www.ffmpeg.org/ )
--CIMG_FFMPEG_CFLAGS = -Dcimg_use_ffmpeg -I/usr/include/ffmpeg
--CIMG_FFMPEG_LDFLAGS = -lavcodec -lavformat
-+#CIMG_FFMPEG_CFLAGS = -Dcimg_use_ffmpeg -I$(LOCALBASE)/include/ffmpeg
-+#CIMG_FFMPEG_LDFLAGS = -lavcodec -lavformat
+-CIMG_FFMPEG_CFLAGS = -Dcimg_use_ffmpeg -I/usr/include/libavcodec -I/usr/include/libavformat -I/usr/include/libswscale
+-CIMG_FFMPEG_LDFLAGS = -lavcodec -lavformat -lswscale
++#CIMG_FFMPEG_CFLAGS = -Dcimg_use_ffmpeg -I$(LOCALBASE)/include/libavcodec -I$(LOCALBASE)/include/libavformat -I$(LOCALBASE)/include/libswscale
++#CIMG_FFMPEG_LDFLAGS = -L$(LOCALBASE)/lib -lavcodec -lavformat -lswscale
# Flags to enable native support for compressed .cimgz files, using the Zlib library.
# ( http://www.zlib.net/ )
-@@ -167,8 +167,8 @@
+@@ -190,8 +190,8 @@
# Flags to enable native support of most classical image file formats, using the Magick++ library.
# ( http://www.imagemagick.org/Magick++/ )
@@ -42,7 +66,7 @@
# Flags to enable faster Discrete Fourier Transform computation, using the FFTW3 library
# ( http://www.fftw.org/ )
-@@ -181,14 +181,17 @@
+@@ -204,14 +204,17 @@
# Flags to enable the use of LAPACK routines for matrix computation
# ( http://www.netlib.org/lapack/ )
@@ -63,9 +87,9 @@
# Flags to compile on Sun Solaris
CIMG_SOLARIS_LDFLAGS = -R$(X11PATH)/lib -lrt -lnsl -lsocket
-@@ -226,6 +229,9 @@
- @echo " > mlinux : Linus/BSD/MacOSX target, no display, minimal features, optimizations enabled."
- @echo " > Mlinux : Linux/BSD/MacOSX target, X11 display, maximal features, optimizations enabled."
+@@ -245,6 +248,9 @@
+ @echo " > mlinux : Linus/BSD target, no display, minimal features, optimizations enabled."
+ @echo " > Mlinux : Linux/BSD target, X11 display, maximal features, optimizations enabled."
@echo
+ @echo " > dFreeBSD : FreeBSD, X11 display, debug mode."
+ @echo " > oFreeBSD : FreeBSD target, X11 display, maximal features for packages."
@@ -73,9 +97,9 @@
@echo " > solaris : Sun Solaris target, X11 display, optimizations disabled."
@echo " > dsolaris : Sun Solaris target, X11 display, debug mode."
@echo " > osolaris : Sun Solaris target, X11 display, optimizations enabled."
-@@ -393,6 +399,56 @@
+@@ -420,6 +426,56 @@
"STRIP_EXE=true" \
- all use_jpeg_buffer gmic4gimp gmic
+ all $(CIMG_EXTRA_FILES)
+# FreeBSD targets
+dFreeBSD:
@@ -129,4 +153,4 @@
+
# Sun Solaris targets, with X11 display.
solaris:
- @make \
+ @$(MAKE) \
diff --git a/graphics/cimg/pkg-plist b/graphics/cimg/pkg-plist
index 36db8246e885..ed1ef3ef3fdf 100644
--- a/graphics/cimg/pkg-plist
+++ b/graphics/cimg/pkg-plist
@@ -58,7 +58,22 @@ include/CImg.h
%%PORTDOCS%%%%DOCSDIR%%/img/postcard10.jpg
%%PORTDOCS%%%%DOCSDIR%%/img/postcard11.jpg
%%PORTDOCS%%%%DOCSDIR%%/img/postcard12.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/postcard13.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/postcard14.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/postcard15.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/postcard16.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/postcard17.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/postcard18.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/postcard19.jpg
%%PORTDOCS%%%%DOCSDIR%%/img/postcard2.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/postcard20.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/postcard21.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/postcard22.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/postcard23.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/postcard24.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/postcard25.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/postcard26.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/postcard27.jpg
%%PORTDOCS%%%%DOCSDIR%%/img/postcard3.jpg
%%PORTDOCS%%%%DOCSDIR%%/img/postcard4.jpg
%%PORTDOCS%%%%DOCSDIR%%/img/postcard5.jpg
@@ -67,6 +82,32 @@ include/CImg.h
%%PORTDOCS%%%%DOCSDIR%%/img/postcard8.jpg
%%PORTDOCS%%%%DOCSDIR%%/img/postcard9.jpg
%%PORTDOCS%%%%DOCSDIR%%/img/project-support.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/reference/ref_box3d.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/reference/ref_cone3d.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/reference/ref_contrast_LUT256.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/reference/ref_cut.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/reference/ref_cylinder3d.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/reference/ref_default_LUT256.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/reference/ref_elevation3d.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/reference/ref_ellipsoid3d.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/reference/ref_equalize.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/reference/ref_histogram.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/reference/ref_image.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/reference/ref_index.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/reference/ref_isoline3d.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/reference/ref_isosurface3d.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/reference/ref_label_regions.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/reference/ref_map.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/reference/ref_noise.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/reference/ref_norm.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/reference/ref_normalize.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/reference/ref_normalize2.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/reference/ref_plane3d.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/reference/ref_quantize.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/reference/ref_rainbow_LUT256.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/reference/ref_sphere3d.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/reference/ref_threshold.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/reference/ref_torus3d.jpg
%%PORTDOCS%%%%DOCSDIR%%/img/ss_blobs.jpg
%%PORTDOCS%%%%DOCSDIR%%/img/ss_bubble.jpg
%%PORTDOCS%%%%DOCSDIR%%/img/ss_bump.jpg
@@ -163,6 +204,7 @@ include/CImg.h
%%PORTDOCS%%%%DOCSDIR%%/reference/functions_0x67.html
%%PORTDOCS%%%%DOCSDIR%%/reference/functions_0x68.html
%%PORTDOCS%%%%DOCSDIR%%/reference/functions_0x69.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_0x6a.html
%%PORTDOCS%%%%DOCSDIR%%/reference/functions_0x6b.html
%%PORTDOCS%%%%DOCSDIR%%/reference/functions_0x6c.html
%%PORTDOCS%%%%DOCSDIR%%/reference/functions_0x6d.html
@@ -188,6 +230,7 @@ include/CImg.h
%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_0x67.html
%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_0x68.html
%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_0x69.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_0x6a.html
%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_0x6b.html
%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_0x6c.html
%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_0x6d.html
@@ -205,7 +248,6 @@ include/CImg.h
%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_0x79.html
%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_0x7e.html
%%PORTDOCS%%%%DOCSDIR%%/reference/functions_type.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_vars.html
%%PORTDOCS%%%%DOCSDIR%%/reference/group__cimg__displays.html
%%PORTDOCS%%%%DOCSDIR%%/reference/group__cimg__drawing.html
%%PORTDOCS%%%%DOCSDIR%%/reference/group__cimg__environment.html
@@ -230,6 +272,28 @@ include/CImg.h
%%PORTDOCS%%%%DOCSDIR%%/reference/namespacemembers_func.html
%%PORTDOCS%%%%DOCSDIR%%/reference/namespacemembers_vars.html
%%PORTDOCS%%%%DOCSDIR%%/reference/namespaces.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/ref_box3d.jpg
+%%PORTDOCS%%%%DOCSDIR%%/reference/ref_cone3d.jpg
+%%PORTDOCS%%%%DOCSDIR%%/reference/ref_cut.jpg
+%%PORTDOCS%%%%DOCSDIR%%/reference/ref_cylinder3d.jpg
+%%PORTDOCS%%%%DOCSDIR%%/reference/ref_elevation3d.jpg
+%%PORTDOCS%%%%DOCSDIR%%/reference/ref_ellipsoid3d.jpg
+%%PORTDOCS%%%%DOCSDIR%%/reference/ref_equalize.jpg
+%%PORTDOCS%%%%DOCSDIR%%/reference/ref_histogram.jpg
+%%PORTDOCS%%%%DOCSDIR%%/reference/ref_index.jpg
+%%PORTDOCS%%%%DOCSDIR%%/reference/ref_isoline3d.jpg
+%%PORTDOCS%%%%DOCSDIR%%/reference/ref_isosurface3d.jpg
+%%PORTDOCS%%%%DOCSDIR%%/reference/ref_label_regions.jpg
+%%PORTDOCS%%%%DOCSDIR%%/reference/ref_map.jpg
+%%PORTDOCS%%%%DOCSDIR%%/reference/ref_noise.jpg
+%%PORTDOCS%%%%DOCSDIR%%/reference/ref_norm.jpg
+%%PORTDOCS%%%%DOCSDIR%%/reference/ref_normalize.jpg
+%%PORTDOCS%%%%DOCSDIR%%/reference/ref_normalize2.jpg
+%%PORTDOCS%%%%DOCSDIR%%/reference/ref_plane3d.jpg
+%%PORTDOCS%%%%DOCSDIR%%/reference/ref_quantize.jpg
+%%PORTDOCS%%%%DOCSDIR%%/reference/ref_sphere3d.jpg
+%%PORTDOCS%%%%DOCSDIR%%/reference/ref_threshold.jpg
+%%PORTDOCS%%%%DOCSDIR%%/reference/ref_torus3d.jpg
%%PORTDOCS%%%%DOCSDIR%%/reference/structcimg__library_1_1CImg-members.html
%%PORTDOCS%%%%DOCSDIR%%/reference/structcimg__library_1_1CImg.html
%%PORTDOCS%%%%DOCSDIR%%/reference/structcimg__library_1_1CImgDisplay-members.html
@@ -247,21 +311,21 @@ include/CImg.h
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/captcha.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/check_all_functions.cpp
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/curve_editor.cpp
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dtmri_view.cpp
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/edge_explorer.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/curve_editor2d.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dtmri_view3d.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/edge_explorer2d.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fade_images.cpp
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gaussian_fit.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gaussian_fit1d.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/generate_loop_macros.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gmic.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gmic.h
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gmic4gimp.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gmic_def.gmic
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gmic_def.h
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gmic_def.raw
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hough_transform.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gmic_gimp.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hough_transform2d.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/image2ascii.cpp
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/image_registration.cpp
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/image_surface.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/image_registration2d.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/image_surface3d.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/img/CImg_demo.h
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/img/lena.pgm
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/img/logo.bmp
@@ -273,14 +337,15 @@ include/CImg.h
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/img/sh1r.pgm
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/img/tetris.h
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/jawbreaker.cpp
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mcf_levelsets.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mcf_levelsets2d.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mcf_levelsets3d.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/odykill.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pde_TschumperleDeriche2d.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pde_heatflow2d.cpp
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/plotter.cpp
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/radon_transform.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/plotter1d.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/radon_transform2d.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scene3d.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/spherical_function3d.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tetris.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tron.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tutorial.cpp
@@ -294,6 +359,7 @@ include/CImg.h
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/use_skeleton.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/wavelet_atrous.cpp
%%PORTDOCS%%@dirrm %%DOCSDIR%%/reference
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/img/reference
%%PORTDOCS%%@dirrm %%DOCSDIR%%/img
%%PORTDOCS%%@dirrm %%DOCSDIR%%
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/img