aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-10-10 21:04:44 +0000
committerKoop Mast <kwm@FreeBSD.org>2015-10-10 21:04:44 +0000
commitf28b16021bc7c3ebba3a0097921144535f4ea126 (patch)
tree147ef8eb94fb77af071ff52ef1205ad29e6db0aa /graphics
parent2af73058295ea1e5f1493b9bb162ddd9eea9ec6c (diff)
downloadports-f28b16021bc7c3ebba3a0097921144535f4ea126.tar.gz
ports-f28b16021bc7c3ebba3a0097921144535f4ea126.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/dri/Makefile44
-rw-r--r--graphics/libGL/Makefile.common52
-rw-r--r--graphics/libGL/Makefile.targets2
-rw-r--r--graphics/libGL/distinfo4
4 files changed, 54 insertions, 48 deletions
diff --git a/graphics/dri/Makefile b/graphics/dri/Makefile
index 72effc769f20..b8d4cc0f93da 100644
--- a/graphics/dri/Makefile
+++ b/graphics/dri/Makefile
@@ -25,56 +25,12 @@ PKGHELP= ${.CURDIR}/pkg-help
.include <bsd.port.options.mk>
-ALL_DRI_DRIVERS=I915 I965 R200 RADEON SWRAST
-
.include "${.CURDIR}/../../graphics/libGL/Makefile.common"
#src/mesa/libmesagallium.la
#MESA_BUILD_WRKSRC= src/util src/gallium
#MESA_INSTALL_WRKSRC= src/gallium
-PLIST_SUB+= VERSION=${MESADISTVERSION}
-
-.if ${ARCH} == amd64 || ${ARCH} == i386 || ${ARCH} == ia64
-DRI_DRIVERS= ${ALL_DRI_DRIVERS}
-.endif
-
-.if ${PORT_OPTIONS:MTEXTURE}
-CONFIGURE_ARGS+=--enable-texture-float
-.endif
-
-.if 0 #${PORT_OPTIONS:MVDPAU}
-.if ${PORT_OPTIONS:MGALLIUM} == ""
-IGNORE= VDPAU option requires GALLIUM support to be enabled
-.endif
-CONFIGURE_ARGS+=--enable-vdpau
-LIB_DEPENDS+= libvdpau.so:${PORTSDIR}/multimedia/libvdpau
-PLIST_SUB+= VDPAU=""
-.else
-CONFIGURE_ARGS+=--disable-vdpau
-PLIST_SUB+= VDPAU="@comment "
-.endif
-
-.if ${ARCH} == powerpc || ${ARCH} == powerpc64
-DRI_DRIVERS= RADEON SWRAST
-.endif
-.if ${ARCH} == sparc64 || ${ARCH} == armv6
-DRI_DRIVERS= SWRAST
-.endif
-
-# empty for unsupported arches
-DRI_DRIVERS+=
-
-.for _d in ${ALL_DRI_DRIVERS}
-. if ${DRI_DRIVERS:M${_d}}
-PLIST_SUB+= ${_d}_DRIVER=""
-. else
-PLIST_SUB+= ${_d}_DRIVER="@comment "
-. endif
-.endfor
-
-CONFIGURE_ARGS+=--with-dri-drivers="${DRI_DRIVERS:tl}"
-
.include "${.CURDIR}/../../graphics/libGL/Makefile.targets"
post-install:
diff --git a/graphics/libGL/Makefile.common b/graphics/libGL/Makefile.common
index 86e0f1e41cfe..e5040b14836e 100644
--- a/graphics/libGL/Makefile.common
+++ b/graphics/libGL/Makefile.common
@@ -18,7 +18,7 @@
MESAVERSION= ${MESABASEVERSION}${MESASUBVERSION:C/^(.)/.\1/}
MESADISTVERSION=${MESABASEVERSION}${MESASUBVERSION:C/^(.)/-\1/}
-MESABASEVERSION= 10.6.8
+MESABASEVERSION= 10.6.9
# if there is a subversion, don't include the '-' between 7.11-rc2.
MESASUBVERSION=
@@ -81,7 +81,9 @@ CONFIGURE_ARGS+= --enable-egl --with-egl-platforms=x11,drm
CONFIGURE_ARGS+= --enable-gles2
# Clover (OpenCL).
-.if ${OPSYS} == DragonFly || (${OPSYS} == FreeBSD && ${OSVERSION} >= 1000000)
+.if ${OPSYS} == DragonFly || \
+ (${OPSYS} == FreeBSD && ${OSVERSION} >= 1000000 && \
+ (${ARCH} == i386 || ${ARCH} == amd64))
BUILD_DEPENDS+= libclc>=0.0.r222830:${PORTSDIR}/devel/libclc
# We need the clang port too even if it is not used to compile because
@@ -103,19 +105,65 @@ BUILD_DEPENDS+= llvm${MESA_LLVM_VER}>=0:${PORTSDIR}/devel/llvm${MESA_LLVM_VER}
.if ${COMPONENT:Mdri} != "" || ${COMPONENT:Mclover} != "" || ${COMPONENT:Megl} != ""
RUN_DEPENDS+= llvm${MESA_LLVM_VER}>=0:${PORTSDIR}/devel/llvm${MESA_LLVM_VER}
.endif
+
CONFIGURE_ENV+= LLVM_CONFIG=${LOCALBASE}/bin/llvm-config${MESA_LLVM_VER}
CONFIGURE_ARGS+=--enable-gallium-llvm \
--enable-xvmc \
--with-gallium-drivers=r300,r600,radeonsi,svga,swrast
+.if ${PORT_OPTIONS:MTEXTURE}
+CONFIGURE_ARGS+=--enable-texture-float
+.endif
+
.if !(${ARCH} == amd64 || ${ARCH} == i386)
CONFIGURE_ARGS+=--disable-gallium-intel
.endif
+# this is disabled because our kernel driver is too old
+# merge this and the one below when support does land.
+.if 0 #${PORT_OPTIONS:MVDPAU}
+.if ${PORT_OPTIONS:MGALLIUM} == ""
+IGNORE= VDPAU option requires GALLIUM support to be enabled
+.endif
+CONFIGURE_ARGS+=--enable-vdpau
+LIB_DEPENDS+= libvdpau.so:${PORTSDIR}/multimedia/libvdpau
+PLIST_SUB+= VDPAU=""
+.else
+CONFIGURE_ARGS+=--disable-vdpau
+PLIST_SUB+= VDPAU="@comment "
+.endif
+
# what to do with this one? Currently disabled in dri.
.if ${COMPONENT:Mvdpau} == ""
CONFIGURE_ARGS+=--disable-vdpau
.else
CONFIGURE_ARGS+=--enable-vdpau
.endif
+
+ALL_DRI_DRIVERS=I915 I965 R200 RADEON SWRAST
+
+.if ${ARCH} == amd64 || ${ARCH} == i386 || ${ARCH} == ia64
+DRI_DRIVERS= ${ALL_DRI_DRIVERS}
+.endif
+
+.if ${ARCH} == powerpc || ${ARCH} == powerpc64
+DRI_DRIVERS= RADEON SWRAST
+.endif
+.if ${ARCH} == sparc64 || ${ARCH} == armv6
+DRI_DRIVERS= SWRAST
+.endif
+
+# empty for unsupported arches
+DRI_DRIVERS+=
+
+.for _d in ${ALL_DRI_DRIVERS}
+. if ${DRI_DRIVERS:M${_d}}
+PLIST_SUB+= ${_d}_DRIVER=""
+. else
+PLIST_SUB+= ${_d}_DRIVER="@comment "
+. endif
+.endfor
+
+CONFIGURE_ARGS+=--with-dri-drivers="${DRI_DRIVERS:tl}"
+
diff --git a/graphics/libGL/Makefile.targets b/graphics/libGL/Makefile.targets
index c051a98285a8..43dbc91e42dd 100644
--- a/graphics/libGL/Makefile.targets
+++ b/graphics/libGL/Makefile.targets
@@ -3,7 +3,9 @@
# this file holds common targets
post-patch:
+# Sed on 9.x and dragonfly don't support \< or \>
@${REINPLACE_CMD} -e 's|-ffast-math|${FAST_MATH}|' -e 's|x86_64|amd64|' \
+ -e "/\>\/\// s|/-|/ -|; s|\\\>||" \
-e 's|python2 python|python2disabled pythondisabled|g' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|/etc/|${PREFIX}/etc/|g' \
diff --git a/graphics/libGL/distinfo b/graphics/libGL/distinfo
index bb54e999c36e..b5bf13b0a017 100644
--- a/graphics/libGL/distinfo
+++ b/graphics/libGL/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mesa-10.6.8.tar.xz) = e36ee5ceeadb3966fb5ce5b4cf18322dbb76a4f075558ae49c3bba94f57d58fd
-SIZE (mesa-10.6.8.tar.xz) = 7042260
+SHA256 (mesa-10.6.9.tar.xz) = b04c4de6280b863babc2929573da17218d92e9e4ba6272d548d135415723e8c3
+SIZE (mesa-10.6.9.tar.xz) = 7041588