aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2012-12-20 02:23:04 +0000
committerGabor Pali <pgj@FreeBSD.org>2012-12-20 02:23:04 +0000
commitf6f83c9efc2c46d2970746758e2c682bb8a518ec (patch)
tree290f2ea61305744bf0f477895c56b92acaeb361f /graphics
parentaf071cfdc1f8578bd1523b823e683074a3139a34 (diff)
downloadports-f6f83c9efc2c46d2970746758e2c682bb8a518ec.tar.gz
ports-f6f83c9efc2c46d2970746758e2c682bb8a518ec.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile2
-rw-r--r--graphics/hs-HGL/Makefile8
-rw-r--r--graphics/hs-cairo/Makefile10
-rw-r--r--graphics/hs-cairo/distinfo4
-rw-r--r--graphics/hs-cairo/pkg-descr2
-rw-r--r--graphics/hs-dia-base/Makefile15
-rw-r--r--graphics/hs-dia-base/distinfo2
-rw-r--r--graphics/hs-dia-base/pkg-descr4
-rw-r--r--graphics/hs-dia-functions/Makefile17
-rw-r--r--graphics/hs-dia-functions/distinfo2
-rw-r--r--graphics/hs-dia-functions/pkg-descr3
-rw-r--r--graphics/hs-soegtk/Makefile7
-rw-r--r--graphics/hs-svgcairo/Makefile7
13 files changed, 55 insertions, 28 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 8d1aa0bdb55a..e63cdd7011a3 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -346,6 +346,8 @@
SUBDIR += hppsmtools
SUBDIR += hs-HGL
SUBDIR += hs-cairo
+ SUBDIR += hs-dia-base
+ SUBDIR += hs-dia-functions
SUBDIR += hs-soegtk
SUBDIR += hs-svgcairo
SUBDIR += hsetroot
diff --git a/graphics/hs-HGL/Makefile b/graphics/hs-HGL/Makefile
index b24817335e4d..c304289fa5e7 100644
--- a/graphics/hs-HGL/Makefile
+++ b/graphics/hs-HGL/Makefile
@@ -1,13 +1,9 @@
-# New ports collection makefile for: hs-HGL-ghc
-# Date created: February 25 2008
-# Whom: Giuseppe Pilichi aka Jacula Modyun <jacula@gmail.com>
-#
+# Created by: Giuseppe Pilichi aka Jacula Modyun <jacula@gmail.com>
# $FreeBSD$
-#
PORTNAME= HGL
PORTVERSION= 3.2.0.2
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= graphics haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/graphics/hs-cairo/Makefile b/graphics/hs-cairo/Makefile
index 54fe3f0f7888..26c965f0eb02 100644
--- a/graphics/hs-cairo/Makefile
+++ b/graphics/hs-cairo/Makefile
@@ -1,13 +1,7 @@
-# New ports collection makefile for: hs-cairo
-# Date created: March 13, 2011
-# Whom: haskell@FreeBSD.org
-#
# $FreeBSD$
-#
PORTNAME= cairo
-PORTVERSION= 0.12.3.1
-PORTREVISION= 1
+PORTVERSION= 0.12.4
CATEGORIES= graphics haskell
MAINTAINER= haskell@FreeBSD.org
@@ -17,7 +11,9 @@ LICENSE= BSD
FILE_LICENSE= COPYRIGHT
CABAL_SETUP= Setup.hs
+
USE_CABAL= gtk2hs-buildtools mtl
+
BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/cairo-pdf.pc:${PORTSDIR}/graphics/cairo
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
diff --git a/graphics/hs-cairo/distinfo b/graphics/hs-cairo/distinfo
index 9345f8ad3e47..73b76d2f3d3c 100644
--- a/graphics/hs-cairo/distinfo
+++ b/graphics/hs-cairo/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/cairo-0.12.3.1.tar.gz) = 91bb958e8fcdff9d5496d6e7888359902e7b0c4e8ddfbf0df949856201c5779c
-SIZE (cabal/cairo-0.12.3.1.tar.gz) = 50437
+SHA256 (cabal/cairo-0.12.4.tar.gz) = 783943379a6b02e8645dd29960e057bea8d05a7afa12a918d87e54d561b7c63f
+SIZE (cabal/cairo-0.12.4.tar.gz) = 50933
diff --git a/graphics/hs-cairo/pkg-descr b/graphics/hs-cairo/pkg-descr
index 0befcbdd0f0a..1fce59cee277 100644
--- a/graphics/hs-cairo/pkg-descr
+++ b/graphics/hs-cairo/pkg-descr
@@ -2,4 +2,4 @@ Cairo is a library to render high quality vector graphics. There exist
various backends that allows rendering to Gtk windows, PDF, PS, PNG and
SVG documents, amongst others.
-WWW: http://projects.haskell.org/gtk2hs/
+WWW: http://projects.haskell.org/gtk2hs/
diff --git a/graphics/hs-dia-base/Makefile b/graphics/hs-dia-base/Makefile
new file mode 100644
index 000000000000..4a3edcb091a8
--- /dev/null
+++ b/graphics/hs-dia-base/Makefile
@@ -0,0 +1,15 @@
+# $FreeBSD$
+
+PORTNAME= dia-base
+PORTVERSION= 0.1.1.2
+CATEGORIES= graphics haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= An EDSL for teaching Haskell with diagrams - data types
+
+LICENSE= BSD
+
+CABAL_SETUP= Setup.hs
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/graphics/hs-dia-base/distinfo b/graphics/hs-dia-base/distinfo
new file mode 100644
index 000000000000..12f7c8f7e7a6
--- /dev/null
+++ b/graphics/hs-dia-base/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/dia-base-0.1.1.2.tar.gz) = 8525de0e876a012fd39c25db34d7cc7d2a4e2434fc20a461abe8aedc9f2b4622
+SIZE (cabal/dia-base-0.1.1.2.tar.gz) = 3779
diff --git a/graphics/hs-dia-base/pkg-descr b/graphics/hs-dia-base/pkg-descr
new file mode 100644
index 000000000000..373c6b6407cf
--- /dev/null
+++ b/graphics/hs-dia-base/pkg-descr
@@ -0,0 +1,4 @@
+This package contains the Diagram data type and the user API to construct
+diagrams.
+
+WWW: http://hackage.haskell.org/package/dia-base
diff --git a/graphics/hs-dia-functions/Makefile b/graphics/hs-dia-functions/Makefile
new file mode 100644
index 000000000000..16b5f0a6e3a3
--- /dev/null
+++ b/graphics/hs-dia-functions/Makefile
@@ -0,0 +1,17 @@
+# $FreeBSD$
+
+PORTNAME= dia-functions
+PORTVERSION= 0.2.1.3
+CATEGORIES= graphics haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= An EDSL for teaching Haskell with diagrams - functions
+
+LICENSE= BSD
+
+CABAL_SETUP= Setup.hs
+
+USE_CABAL= data-pprint>=0.2 dia-base>=0.1 mtl>=2.0 xhtml>=3000.2
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/graphics/hs-dia-functions/distinfo b/graphics/hs-dia-functions/distinfo
new file mode 100644
index 000000000000..69b758429ea0
--- /dev/null
+++ b/graphics/hs-dia-functions/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/dia-functions-0.2.1.3.tar.gz) = 3460652c5b6562bbfcf82c6edbc64a0d1682d05ee825145339a1e50a89195e7d
+SIZE (cabal/dia-functions-0.2.1.3.tar.gz) = 8137
diff --git a/graphics/hs-dia-functions/pkg-descr b/graphics/hs-dia-functions/pkg-descr
new file mode 100644
index 000000000000..5a61ff8c8c78
--- /dev/null
+++ b/graphics/hs-dia-functions/pkg-descr
@@ -0,0 +1,3 @@
+This package contains diagram manipulating functions and an SVG backend.
+
+WWW: http://hackage.haskell.org/package/dia-functions
diff --git a/graphics/hs-soegtk/Makefile b/graphics/hs-soegtk/Makefile
index 6616cdfe028f..49a30ebe7739 100644
--- a/graphics/hs-soegtk/Makefile
+++ b/graphics/hs-soegtk/Makefile
@@ -1,13 +1,8 @@
-# New ports collection makefile for: hs-soegtk
-# Date created: March 13, 2011
-# Whom: haskell@FreeBSD.org
-#
# $FreeBSD$
-#
PORTNAME= soegtk
PORTVERSION= 0.12.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/graphics/hs-svgcairo/Makefile b/graphics/hs-svgcairo/Makefile
index a45b408db986..ed8f868d1b1a 100644
--- a/graphics/hs-svgcairo/Makefile
+++ b/graphics/hs-svgcairo/Makefile
@@ -1,13 +1,8 @@
-# New ports collection makefile for: hs-svgcairo
-# Date created: March 13, 2011
-# Whom: haskell@FreeBSD.org
-#
# $FreeBSD$
-#
PORTNAME= svgcairo
PORTVERSION= 0.12.1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics haskell
MAINTAINER= haskell@FreeBSD.org