aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorAlexander Nedotsukov <bland@FreeBSD.org>2004-01-26 06:55:59 +0000
committerAlexander Nedotsukov <bland@FreeBSD.org>2004-01-26 06:55:59 +0000
commit70ad794c0af0cfeebc8ac044335a0b7d287cc437 (patch)
tree496730c3a4b683a4db1fff87b7333f2b6f52f196 /graphics
parent775163639198156c2b4c8ecf54b431b45d50fa08 (diff)
downloadports-70ad794c0af0cfeebc8ac044335a0b7d287cc437.tar.gz
ports-70ad794c0af0cfeebc8ac044335a0b7d287cc437.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gphoto2/Makefile2
-rw-r--r--graphics/gphoto2/distinfo2
-rw-r--r--graphics/libgphoto2/Makefile2
-rw-r--r--graphics/libgphoto2/distinfo2
-rw-r--r--graphics/libgphoto2/files/patch-ChangeLog16
-rw-r--r--graphics/libgphoto2/files/patch-camlibs:aox:aox.c31
-rw-r--r--graphics/libgphoto2/files/patch-camlibs:aox:library.c20
-rw-r--r--graphics/libgphoto2/files/patch-camlibs:canon:canon.c19
-rw-r--r--graphics/libgphoto2/files/patch-camlibs:canon:canon.h18
-rw-r--r--graphics/libgphoto2/files/patch-camlibs:canon:usb.c10
-rw-r--r--graphics/libgphoto2/files/patch-camlibs:canon:usb.h11
-rw-r--r--graphics/libgphoto2/pkg-plist1
12 files changed, 56 insertions, 78 deletions
diff --git a/graphics/gphoto2/Makefile b/graphics/gphoto2/Makefile
index a8da29aca9f8..6f8d852a721b 100644
--- a/graphics/gphoto2/Makefile
+++ b/graphics/gphoto2/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gphoto2
-PORTVERSION= 2.1.3
+PORTVERSION= 2.1.4
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= gphoto
diff --git a/graphics/gphoto2/distinfo b/graphics/gphoto2/distinfo
index ffc9363abd4f..969b104b3a57 100644
--- a/graphics/gphoto2/distinfo
+++ b/graphics/gphoto2/distinfo
@@ -1 +1 @@
-MD5 (gphoto2-2.1.3.tar.bz2) = 7c5efceca67f4a67b9fa888609af2a03
+MD5 (gphoto2-2.1.4.tar.bz2) = 5bbee55d4e59b063d3cff0fbc9121006
diff --git a/graphics/libgphoto2/Makefile b/graphics/libgphoto2/Makefile
index 71b97acf7903..0b00a38e988a 100644
--- a/graphics/libgphoto2/Makefile
+++ b/graphics/libgphoto2/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libgphoto2
-PORTVERSION= 2.1.3
+PORTVERSION= 2.1.4
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= gphoto
diff --git a/graphics/libgphoto2/distinfo b/graphics/libgphoto2/distinfo
index 31a93eb01fc2..9114da924794 100644
--- a/graphics/libgphoto2/distinfo
+++ b/graphics/libgphoto2/distinfo
@@ -1 +1 @@
-MD5 (libgphoto2-2.1.3.tar.bz2) = af200308629fcbe0b88d3802bba04779
+MD5 (libgphoto2-2.1.4.tar.bz2) = a201650482bbc2edbd948449cf4d3f5a
diff --git a/graphics/libgphoto2/files/patch-ChangeLog b/graphics/libgphoto2/files/patch-ChangeLog
deleted file mode 100644
index e5fb899b400e..000000000000
--- a/graphics/libgphoto2/files/patch-ChangeLog
+++ /dev/null
@@ -1,16 +0,0 @@
---- ChangeLog.orig Mon Oct 20 10:31:35 2003
-+++ ChangeLog Mon Oct 20 10:31:06 2003
-@@ -1,3 +1,13 @@
-+2003-10-20 Andreas Klemm <andreas@FreeBSD.org>
-+ * Canon PowerShot G5 added
-+ * camlibs/canon/canon.c: add G5 to struct canonCamModelData models[]
-+ add G5 support in canon_int_filename2audioname
-+ * camlibs/canon/canon.h: add G5 to enum canonCamModel
-+ * camlibs/canon/usb.c: same behaviour as for G3 in canon_usb_lock_keys,
-+ lock the keys on the camera and turn off display
-+ * camlibs/canon/usb.h: CANON_USB_FUNCTION_GET_PIC_ABILITIES, expand
-+ comment, add G5 after G3.
-+
- 2003-08-10 gettextize <bug-gnu-gettext@gnu.org>
-
- * Makefile.am (SUBDIRS): Add intl.
diff --git a/graphics/libgphoto2/files/patch-camlibs:aox:aox.c b/graphics/libgphoto2/files/patch-camlibs:aox:aox.c
new file mode 100644
index 000000000000..341fdd528aae
--- /dev/null
+++ b/graphics/libgphoto2/files/patch-camlibs:aox:aox.c
@@ -0,0 +1,31 @@
+--- camlibs/aox/aox.c.orig Mon Jan 26 01:24:20 2004
++++ camlibs/aox/aox.c Mon Jan 26 01:25:54 2004
+@@ -39,10 +39,11 @@
+ int aox_init (GPPort *port, Model *model, Info *info)
+ {
+ unsigned char c[4];
+- memset(c,0,sizeof(c));
+ unsigned char hi[2];
+- memset (hi,0,2);
+ unsigned char lo[2];
++
++ memset(c,0,sizeof(c));
++ memset (hi,0,2);
+ memset (lo,0,2);
+
+ GP_DEBUG("Running aox_init\n");
+@@ -86,11 +87,12 @@
+
+ int aox_get_picture_size (GPPort *port, int lo, int hi, int n, int k)
+ {
++ unsigned char c[4];
++ unsigned int size;
++
+ GP_DEBUG("Running aox_get_picture_size\n");
+
+- unsigned char c[4];
+ memset (c,0,4);
+- unsigned int size;
+
+ if ( ( (lo) && ( n ==k ) && (k ==0)) ) {
+ READ(port, 0x04, 0x1, 0x1, c, 2);
diff --git a/graphics/libgphoto2/files/patch-camlibs:aox:library.c b/graphics/libgphoto2/files/patch-camlibs:aox:library.c
new file mode 100644
index 000000000000..bac1eafcba9b
--- /dev/null
+++ b/graphics/libgphoto2/files/patch-camlibs:aox:library.c
@@ -0,0 +1,20 @@
+--- camlibs/aox/library.c.orig Mon Jan 26 01:22:59 2004
++++ camlibs/aox/library.c Mon Jan 26 01:23:58 2004
+@@ -167,7 +167,7 @@
+ unsigned char *data;
+ unsigned char *p_data = NULL;
+ unsigned char *output = NULL;
+- int len;
++ int len, header_len;
+ char header[128];
+ unsigned char gtable[256];
+
+@@ -222,7 +222,7 @@
+ GP_DEBUG("size of data = %i\n", sizeof(data));
+ GP_DEBUG("size of p_data = %i\n", sizeof(p_data));
+ /* And now create a ppm file, with our own header */
+- int header_len = snprintf(header, 127,
++ header_len = snprintf(header, 127,
+ "P6\n"
+ "# CREATOR: gphoto2, aox library\n"
+ "%d %d\n"
diff --git a/graphics/libgphoto2/files/patch-camlibs:canon:canon.c b/graphics/libgphoto2/files/patch-camlibs:canon:canon.c
deleted file mode 100644
index af1f64583bdd..000000000000
--- a/graphics/libgphoto2/files/patch-camlibs:canon:canon.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- camlibs/canon/canon.c.orig Mon Oct 20 01:53:12 2003
-+++ camlibs/canon/canon.c Sun Oct 26 22:55:34 2003
-@@ -147,6 +147,8 @@
- /* 0x306D is S45 in PTP mode */
- {"Canon:PowerShot G3 (normal mode)", CANON_PS_G3, 0x04A9, 0x306E, CAP_SUP, S99M, S32K, S2M, NULL},
- /* 0x306F is G3 in PTP mode */
-+ {"Canon:PowerShot G5 (normal mode)", CANON_PS_G5, 0x04A9, 0x3085, CAP_SUP, S99M, S32K, S2M, NULL},
-+ /* XXX 0x???? is G5 in PTP mode */
- {"Canon:PowerShot S230 (normal mode)", CANON_PS_S230, 0x04A9, 0x3070, CAP_SUP, S99M, S32K, S2M, NULL},
- {"Canon:Digital IXUS v3 (normal mode)", CANON_PS_S230, 0x04A9, 0x3070, CAP_SUP, S99M, S32K, S2M, NULL},
- /* 0x3071 is S230/IXUS v3 in PTP mode */
-@@ -312,6 +314,7 @@
- case CANON_PS_S45:
- case CANON_PS_S400:
- case CANON_PS_G3:
-+ case CANON_PS_G5:
- break;
- default:
- GP_DEBUG ("canon_int_filename2audioname: camera model doesn't support audio files",
diff --git a/graphics/libgphoto2/files/patch-camlibs:canon:canon.h b/graphics/libgphoto2/files/patch-camlibs:canon:canon.h
deleted file mode 100644
index 852421e4ad99..000000000000
--- a/graphics/libgphoto2/files/patch-camlibs:canon:canon.h
+++ /dev/null
@@ -1,18 +0,0 @@
---- camlibs/canon/canon.h.orig Mon Oct 20 01:53:12 2003
-+++ camlibs/canon/canon.h Sun Oct 26 22:57:54 2003
-@@ -87,6 +87,7 @@
- * @CANON_PS_S330: Digital IXUS 330
- * @CANON_PS_S45: PowerShot S45
- * @CANON_PS_G3: PowerShot G3
-+ * @CANON_PS_G3: PowerShot G5
- * @CANON_PS_S230: PowerShot S230, Digital IXUS v3
- * @CANON_PS_A60: PowerShot A60
- * @CANON_MV630I: MV630i camcorder
-@@ -133,6 +134,7 @@
- CANON_PS_S50,
- CANON_PS_S45,
- CANON_PS_G3,
-+ CANON_PS_G5,
- CANON_PS_S230,
- CANON_MV630I,
- CANON_EOS_10D,
diff --git a/graphics/libgphoto2/files/patch-camlibs:canon:usb.c b/graphics/libgphoto2/files/patch-camlibs:canon:usb.c
deleted file mode 100644
index 50c768a7dc66..000000000000
--- a/graphics/libgphoto2/files/patch-camlibs:canon:usb.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- camlibs/canon/usb.c.orig Sun Aug 10 20:51:13 2003
-+++ camlibs/canon/usb.c Mon Oct 20 10:17:55 2003
-@@ -356,6 +356,7 @@
-
- case CANON_PS_S45:
- case CANON_PS_G3:
-+ case CANON_PS_G5:
- default:
- /* Special case: doesn't implement "get
- picture abilities", but isn't an EOS
diff --git a/graphics/libgphoto2/files/patch-camlibs:canon:usb.h b/graphics/libgphoto2/files/patch-camlibs:canon:usb.h
deleted file mode 100644
index c7a7ef14592d..000000000000
--- a/graphics/libgphoto2/files/patch-camlibs:canon:usb.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- camlibs/canon/usb.h.orig Sun Aug 10 20:51:13 2003
-+++ camlibs/canon/usb.h Mon Oct 20 10:17:57 2003
-@@ -38,7 +38,7 @@
- * @CANON_USB_FUNCTION_GET_PIC_ABILITIES: Command to "get picture abilities", which
- * seems to be a list of the different sizes and quality of images that are available on
- * this camera. Not implemented (and will cause an error) on the EOS cameras
-- * or on newer PowerShot cameras such as the S45 and G3.
-+ * or on newer PowerShot cameras such as the S45, G3 and G5.
- * @CANON_USB_FUNCTION_GENERIC_LOCK_KEYS: Command to lock keys (and turn on "PC" indicator)
- * on non-EOS cameras.
- * @CANON_USB_FUNCTION_EOS_LOCK_KEYS: Lock keys (EOS cameras)
diff --git a/graphics/libgphoto2/pkg-plist b/graphics/libgphoto2/pkg-plist
index a850af135970..abb7bf418575 100644
--- a/graphics/libgphoto2/pkg-plist
+++ b/graphics/libgphoto2/pkg-plist
@@ -19,6 +19,7 @@ include/gphoto2/gphoto2-version.h
include/gphoto2/gphoto2-widget.h
include/gphoto2/gphoto2.h
lib/gphoto2/%%VERSION%%/libgphoto2_agfa_cl20.so
+lib/gphoto2/%%VERSION%%/libgphoto2_aox.so
lib/gphoto2/%%VERSION%%/libgphoto2_barbie.so
lib/gphoto2/%%VERSION%%/libgphoto2_canon.so
lib/gphoto2/%%VERSION%%/libgphoto2_casio_qv.so