aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2015-12-22 04:07:14 +0000
committerMartin Wilke <miwi@FreeBSD.org>2015-12-22 04:07:14 +0000
commita71c16c37c4f9fdebc99c7288249c6475b11abfb (patch)
treec20af7a36b97dddd8e65d28557c33e107f25fa89 /graphics
parente0f113acef4b6e2ef48927ffa4cad8f3602ccf02 (diff)
downloadports-a71c16c37c4f9fdebc99c7288249c6475b11abfb.tar.gz
ports-a71c16c37c4f9fdebc99c7288249c6475b11abfb.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/fotoxx/Makefile63
-rw-r--r--graphics/fotoxx/distinfo4
-rw-r--r--graphics/fotoxx/files/patch-Makefile15
-rw-r--r--graphics/fotoxx/files/patch-f.combine.cc11
-rw-r--r--graphics/fotoxx/files/patch-f.file.cc12
-rw-r--r--graphics/fotoxx/files/patch-f.meta.cc46
-rw-r--r--graphics/fotoxx/files/patch-f.metadata.cc50
-rw-r--r--graphics/fotoxx/files/patch-f.repair.cc8
-rw-r--r--graphics/fotoxx/files/patch-fotoxx-14.02.2.cc116
-rw-r--r--graphics/fotoxx/files/patch-fotoxx-15.05.cc51
-rw-r--r--graphics/fotoxx/files/patch-fotoxx.h13
-rw-r--r--graphics/fotoxx/files/patch-zfuncs.cc32
-rw-r--r--graphics/fotoxx/files/patch-zfuncs.h36
-rw-r--r--graphics/fotoxx/pkg-plist201
14 files changed, 175 insertions, 483 deletions
diff --git a/graphics/fotoxx/Makefile b/graphics/fotoxx/Makefile
index daa7612d63f2..d0531abd5c49 100644
--- a/graphics/fotoxx/Makefile
+++ b/graphics/fotoxx/Makefile
@@ -2,10 +2,11 @@
# $FreeBSD$
PORTNAME= fotoxx
-PORTVERSION= 14.02.2
+PORTVERSION= 15.05
CATEGORIES= graphics
-MASTER_SITES= http://www.kornelix.com/uploads/1/3/0/3/13035936/ \
- LOCAL/mandree
+MASTER_SITES= GENTOO/distfiles \
+ http://fossies.org/linux/misc/legacy/ \
+ http://www.kornelix.com/uploads/1/3/0/3/13035936/
MAINTAINER= ports@FreeBSD.org
COMMENT= Application to organize and edit image collections
@@ -13,49 +14,35 @@ COMMENT= Application to organize and edit image collections
LICENSE= GPLv3
RUN_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils \
- ufraw-batch:${PORTSDIR}/graphics/ufraw \
+ dcraw:${PORTSDIR}/graphics/dcraw \
exiftool:${PORTSDIR}/graphics/p5-Image-ExifTool \
- dcraw:${PORTSDIR}/graphics/dcraw
+ ufraw-batch:${PORTSDIR}/graphics/ufraw
-USES= execinfo gmake desktop-file-utils pkgconfig
-USE_GNOME= gtk30
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USES= desktop-file-utils execinfo gmake pkgconfig
+USE_GNOME= gtk30
ALL_TARGET= fotoxx
-INSTALL_TARGET= install MANDIR=${PREFIX}/man/man1/
-LDFLAGS+= -O3 -g -Wall -rdynamic -lexecinfo
+PORTDOCS= *
+PORTDATA= *
+PLIST_FILES= bin/fotoxx \
+ man/man1/fotoxx.1.gz \
+ share/appdata/fotoxx.appdata.xml \
+ share/applications/fotoxx.desktop
OPTIONS_DEFINE= DOCS
post-patch:
- @# drop xdg-desktop-menu calls, they fail
- ${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
- -e '/xdg-desktop-menu/d' \
- -e '/rm -f -R/d' \
- ${WRKSRC}/Makefile
- @# replace obsolete include files
- ${REINPLACE_CMD} -e 's|<malloc.h>|<stdlib.h>|' \
- ${WRKSRC}/zfuncs.h
- @# fix up icon path in XDG .desktop file
- ${REINPLACE_CMD} -e 's}/usr/share/fotoxx}${DATADIR}}' \
- ${WRKSRC}/desktop
+ @${REINPLACE_CMD} -e \
+ 's|-ggdb|| ; \
+ s|-rdynamic|-Wl,-export-dynamic| ; \
+ s|share/man|man| ; \
+ s|-lpthread|-lexecinfo|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e \
+ 's|/usr/share/fotoxx|${DATADIR}|' ${WRKSRC}/desktop
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/fotoxx
-
-.include <bsd.port.pre.mk>
-
-# These hacks are required because the nginx server at the primary
-# master site and most of our fetch(1) versions do not get along well.
-# This code can be removed once r261263 has been merged from
-# base/head into all ports-supported releases.
-# We depend on cURL unless wget is in $LOCALPATH:
-DISABLE_SIZE= yes
-.if exists(${LOCALBASE}/bin/wget) && !exists(${PREFIX}/bin/curl)
-FETCH_CMD= ${LOCALBASE}/bin/wget -c -nc
-.else
-FETCH_DEPENDS= curl:${PORTSDIR}/ftp/curl
-FETCH_CMD= ${PREFIX}/bin/curl -OL0C -
-.endif
-
-.include <bsd.port.post.mk>
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/fotoxx
+
+.include <bsd.port.mk>
diff --git a/graphics/fotoxx/distinfo b/graphics/fotoxx/distinfo
index caa2c7fe3cc1..961a9fe56219 100644
--- a/graphics/fotoxx/distinfo
+++ b/graphics/fotoxx/distinfo
@@ -1,2 +1,2 @@
-SHA256 (fotoxx-14.02.2.tar.gz) = 60b6d9e8a5f19bc92b53d585cb36795d951c7a6d2d0bd1bd30ae3ca0465ed767
-SIZE (fotoxx-14.02.2.tar.gz) = 2715089
+SHA256 (fotoxx-15.05.tar.gz) = 65567adc86087a3a8acdebcb0f15ec299cf690a869129825e3d32da7e50c4604
+SIZE (fotoxx-15.05.tar.gz) = 3573278
diff --git a/graphics/fotoxx/files/patch-Makefile b/graphics/fotoxx/files/patch-Makefile
deleted file mode 100644
index efc156f54de8..000000000000
--- a/graphics/fotoxx/files/patch-Makefile
+++ /dev/null
@@ -1,15 +0,0 @@
---- ./Makefile.orig 2014-02-05 20:42:34.000000000 +0100
-+++ ./Makefile 2014-02-06 10:32:37.000000000 +0100
-@@ -3,9 +3,9 @@
- FOTOXX = fotoxx-14.02.2.cc
-
- # defaults for parameters that may be pre-defined
--CXXFLAGS ?= -O2 -Wall -ggdb
--LDFLAGS ?= -rdynamic
--PREFIX ?= /usr
-+CXXFLAGS ?= -O3 -g -Wall
-+LDFLAGS ?= -O3 -g -Wall -rdynamic
-+PREFIX ?= $(LOCALBASE)
-
- # target install directories
- BINDIR = $(PREFIX)/bin
diff --git a/graphics/fotoxx/files/patch-f.combine.cc b/graphics/fotoxx/files/patch-f.combine.cc
new file mode 100644
index 000000000000..b19d19fbf3f0
--- /dev/null
+++ b/graphics/fotoxx/files/patch-f.combine.cc
@@ -0,0 +1,11 @@
+--- f.combine.cc.orig 2015-05-01 09:40:38 UTC
++++ f.combine.cc
+@@ -6475,7 +6475,7 @@ void m_pano_PT(GtkWidget *, cchar *)
+ goto cleanup;
+ }
+
+- olddir = get_current_dir_name(); // save curr. directory
++ olddir = getcwd(NULL,PATH_MAX); // save curr. directory
+
+ err = chdir(tempdir); // use /tmp/fotoxx-xxxxx
+ if (err) {
diff --git a/graphics/fotoxx/files/patch-f.file.cc b/graphics/fotoxx/files/patch-f.file.cc
index 2df6b87c15f3..003f8847e350 100644
--- a/graphics/fotoxx/files/patch-f.file.cc
+++ b/graphics/fotoxx/files/patch-f.file.cc
@@ -1,10 +1,10 @@
---- ./f.file.cc.orig 2014-02-05 20:42:34.000000000 +0100
-+++ ./f.file.cc 2014-02-06 10:32:37.000000000 +0100
-@@ -23,6 +23,7 @@
+--- f.file.cc.orig 2015-05-01 09:40:38 UTC
++++ f.file.cc
+@@ -74,6 +74,7 @@
#define EX extern // disable extern declarations
- #include "fotoxx.h"
+ #include "fotoxx.h" // (variables in fotoxx.h are refs)
+#include <sys/wait.h>
- /**************************************************************************
- Fotoxx image edit - file menu functions
+ /**************************************************************************/
+
diff --git a/graphics/fotoxx/files/patch-f.meta.cc b/graphics/fotoxx/files/patch-f.meta.cc
deleted file mode 100644
index 65bf2a8dc312..000000000000
--- a/graphics/fotoxx/files/patch-f.meta.cc
+++ /dev/null
@@ -1,46 +0,0 @@
---- ./f.meta.cc.orig 2014-02-05 20:42:34.000000000 +0100
-+++ ./f.meta.cc 2014-02-06 10:32:37.000000000 +0100
-@@ -23,6 +23,7 @@
-
- #define EX extern // enable extern declarations
- #include "fotoxx.h"
-+#include <sys/wait.h>
-
-
- /**************************************************************************
-@@ -5786,7 +5787,7 @@
- strcpy(sxrec.size,"null");
-
- if (! sxrec.tags)
-- sxrec.tags = strdupz("null"tagdelimB,0,"search-index");
-+ sxrec.tags = strdupz("null" tagdelimB,0,"search-index");
-
- if (! sxrec.capt)
- sxrec.capt = strdupz("null",0,"search-index");
-@@ -5993,7 +5994,7 @@
-
- if (sxrec->tags)
- nn = fprintf(fid2,"tags: %s\n",sxrec->tags); // tags rec.
-- else nn = fprintf(fid2,"tags: null"tagdelimB"\n");
-+ else nn = fprintf(fid2,"tags: null" tagdelimB"\n");
- if (! nn) goto file_err;
-
- if (sxrec->capt)
-@@ -6147,7 +6148,7 @@
- strcpy(sxrec.size,"null");
-
- if (! sxrec.tags)
-- sxrec.tags = strdupz("null"tagdelimB,0,"search-index");
-+ sxrec.tags = strdupz("null" tagdelimB,0,"search-index");
-
- if (! sxrec.capt)
- sxrec.capt = strdupz("null",0,"search-index");
-@@ -6259,7 +6260,7 @@
-
- if (sxrec->tags)
- nn = fprintf(fid,"tags: %s\n",sxrec->tags); // tags rec.
-- else nn = fprintf(fid,"tags: null"tagdelimB"\n");
-+ else nn = fprintf(fid,"tags: null" tagdelimB"\n");
- if (! nn) goto file_err;
-
- if (sxrec->capt)
diff --git a/graphics/fotoxx/files/patch-f.metadata.cc b/graphics/fotoxx/files/patch-f.metadata.cc
new file mode 100644
index 000000000000..223e9b48a66b
--- /dev/null
+++ b/graphics/fotoxx/files/patch-f.metadata.cc
@@ -0,0 +1,50 @@
+--- f.metadata.cc.orig 2015-05-01 09:40:38 UTC
++++ f.metadata.cc
+@@ -92,6 +92,11 @@
+
+ #define EX extern // enable extern declarations
+ #include "fotoxx.h" // (variables in fotoxx.h are refs)
++#include <sys/wait.h>
++
++#ifndef ECOMM
++#define ECOMM EIO
++#endif
+
+ /**************************************************************************/
+
+@@ -5911,7 +5917,7 @@ int get_sxrec(sxrec_t &sxrec, cchar *fil
+ strcpy(sxrec.size,"null");
+
+ if (! sxrec.tags)
+- sxrec.tags = zstrdup("null"tagdelimB);
++ sxrec.tags = zstrdup("null" tagdelimB);
+
+ if (! sxrec.capt)
+ sxrec.capt = zstrdup("null");
+@@ -6118,7 +6124,7 @@ int put_sxrec(sxrec_t *sxrec, cchar *fil
+
+ if (sxrec->tags)
+ nn = fprintf(fid2,"tags: %s\n",sxrec->tags); // tags rec.
+- else nn = fprintf(fid2,"tags: null"tagdelimB"\n");
++ else nn = fprintf(fid2,"tags: null" tagdelimB"\n");
+ if (! nn) goto file_err;
+
+ if (sxrec->capt)
+@@ -6270,7 +6276,7 @@ int read_sxrec_seq(sxrec_t &sxrec, int &
+ strcpy(sxrec.size,"null");
+
+ if (! sxrec.tags)
+- sxrec.tags = zstrdup("null"tagdelimB);
++ sxrec.tags = zstrdup("null" tagdelimB);
+
+ if (! sxrec.capt)
+ sxrec.capt = zstrdup("null");
+@@ -6381,7 +6387,7 @@ int write_sxrec_seq(sxrec_t *sxrec, int
+
+ if (sxrec->tags)
+ nn = fprintf(fid,"tags: %s\n",sxrec->tags); // tags rec.
+- else nn = fprintf(fid,"tags: null"tagdelimB"\n");
++ else nn = fprintf(fid,"tags: null" tagdelimB"\n");
+ if (! nn) goto file_err;
+
+ if (sxrec->capt)
diff --git a/graphics/fotoxx/files/patch-f.repair.cc b/graphics/fotoxx/files/patch-f.repair.cc
index 53e698fbff80..b7b073846439 100644
--- a/graphics/fotoxx/files/patch-f.repair.cc
+++ b/graphics/fotoxx/files/patch-f.repair.cc
@@ -1,11 +1,11 @@
---- f.repair.cc.orig 2014-08-15 14:19:11.000000000 -0400
-+++ f.repair.cc 2014-08-15 14:20:01.000000000 -0400
-@@ -1571,7 +1571,7 @@
+--- f.repair.cc.orig 2015-05-01 09:40:38 UTC
++++ f.repair.cc
+@@ -2055,7 +2055,7 @@ void m_smart_erase(GtkWidget *, const ch
int smart_erase_dialog_event(zdialog *zd, const char *event) // overhauled
{
void smart_erase_func(int mode);
- void smart_erase_blur(float radius);
+ int smart_erase_blur(float radius);
-
+
float radius;
int cc;
diff --git a/graphics/fotoxx/files/patch-fotoxx-14.02.2.cc b/graphics/fotoxx/files/patch-fotoxx-14.02.2.cc
deleted file mode 100644
index e2525ee14eab..000000000000
--- a/graphics/fotoxx/files/patch-fotoxx-14.02.2.cc
+++ /dev/null
@@ -1,116 +0,0 @@
---- ./fotoxx-14.02.2.cc.orig 2014-02-05 20:42:34.000000000 +0100
-+++ ./fotoxx-14.02.2.cc 2014-02-06 10:32:37.000000000 +0100
-@@ -133,7 +133,8 @@
-
- #define EX // disable extern declarations
- #include "fotoxx.h"
--
-+#include <sys/types.h>
-+#include <sys/sysctl.h>
-
- // fotoxx main program
-
-@@ -451,7 +452,6 @@
- char procfile[20], buff[200];
- char KBshortsU[200], KBshortsI[200];
- char favorites_config[200], badnews[200];
-- double freememory, cachememory; // available memory at startup
- float exifver = 0;
- FILE *fid;
- struct stat statb;
-@@ -542,19 +542,12 @@
-
- snprintf(URS_filename,200,"%s/undo_nn",tempdir); // /run/shm/fotoxx-nnnnnn/undo_nn
-
-- // check free memory and suggest image size limits
--
-- parseprocfile("/proc/meminfo","MemFree:",&freememory,null); // get amount of free memory
-- parseprocfile("/proc/meminfo","Cached:",&cachememory,null);
-- freememory = (freememory + cachememory) / 1024; // megabytes
-- printz("free memory: %.0f MB \n",freememory);
-- printz("image size limits for good performance: \n"); // v.13.04
-- printz(" view: %.0f megapixels \n",(freememory-100)/6); // F + preview, 3 bytes/pixel each
-- printz(" edit: %.0f megapixels \n",(freememory-100)/54); // + E0/E1/E3/ER, 12 bytes/pixel each
--
- // miscellaneous
-
-- Nwt = get_nprocs(); // get SMP CPU count
-+ //Nwt = get_nprocs(); // get SMP CPU count
-+ size_t len = sizeof(Nwt);
-+ sysctlbyname("hw.ncpu",&Nwt,&len,NULL,0);
-+
- if (Nwt <= 0) Nwt = 2;
- if (Nwt > max_threads) Nwt = max_threads; // compile time limit
- printz("using %d threads \n",Nwt);
-@@ -4321,31 +4314,6 @@
- }
-
-
--/**************************************************************************/
--
--// popup a warning message if real memory is below specified threshold
--// returns margin: real memory - threshold, in megabytes
--// (+ if enough memory, - if not)
--// the popup message only appears if real memory < threshold
--// the popup message goes away after a few seconds
--
--int warn_memory(int req_mb)
--{
-- double freemem, cachemem;
-- int act_mb, gap_mb;
-- cchar *message = ZTX("warning: real memory %d MB < required %d MB \n"
-- "response time may become very long \n");
--
-- parseprocfile("/proc/meminfo","MemFree:",&freemem,null); // get current free memory
-- parseprocfile("/proc/meminfo","Cached:",&cachemem,null);
-- act_mb = (freemem + cachemem) / 1024; // megabytes
-- gap_mb = act_mb - req_mb;
-- if (gap_mb > -10) return gap_mb;
-- zpopup_message(message,act_mb,req_mb); // deficit > 10 MB
-- return gap_mb;
--}
--
--
- /**************************************************************************
- PXM pixmap functions - RGB float pixel map
- pixel RGB values may range from 0.0 to 255.99
-@@ -4386,9 +4354,6 @@
- return 0;
- }
-
-- int req_mb = ww * hh * 12 / mega; // warn if memory low
-- warn_memory(req_mb);
--
- PXM *pxm = (PXM *) zmalloc(sizeof(PXM),"PXM"); // 0.45 sec for 116 megapix image (1.4 GB)
- pxm->ww = ww;
- pxm->hh = hh;
-@@ -4806,9 +4771,6 @@
-
- PXB * PXB_make(int ww, int hh)
- {
-- int req_mb = ww * hh * 3 / mega; // warn if memory low
-- warn_memory(req_mb);
--
- PXB *pxb = (PXB *) zmalloc(sizeof(PXB),"PXB");
- strcpy(pxb->wmi,"pxbpix");
- pxb->pixbuf = gdk_pixbuf_new(GDKRGB,0,8,ww,hh);
-@@ -4857,9 +4819,6 @@
-
- PXB * PXB_copy(PXB *pxb1)
- {
-- int req_mb = pxb1->ww * pxb1->hh * 3 / mega; // warn if memory low
-- warn_memory(req_mb);
--
- PXB *pxb2 = (PXB *) zmalloc(sizeof(PXB),"PXB");
- strcpy(pxb2->wmi,"pxbpix");
- pxb2->pixbuf = gdk_pixbuf_copy(pxb1->pixbuf);
-@@ -4876,9 +4835,6 @@
- PXB * PXB_rescale(PXB *pxb1, int ww2, int hh2)
- {
- GdkPixbuf *pixbuf2 = 0;
-- int req_mb = ww2 * hh2 * 3 / mega; // warn if memory low
-- warn_memory(req_mb);
--
- if (strEqu(interpolation,"tiles")) // v.13.05
- pixbuf2 = gdk_pixbuf_scale_simple(pxb1->pixbuf,ww2,hh2,GDK_INTERP_TILES);
- else if (strEqu(interpolation,"hyperbolic"))
diff --git a/graphics/fotoxx/files/patch-fotoxx-15.05.cc b/graphics/fotoxx/files/patch-fotoxx-15.05.cc
new file mode 100644
index 000000000000..73eaa585bfc1
--- /dev/null
+++ b/graphics/fotoxx/files/patch-fotoxx-15.05.cc
@@ -0,0 +1,51 @@
+--- fotoxx-15.05.cc.orig 2015-05-01 09:40:38 UTC
++++ fotoxx-15.05.cc
+@@ -139,6 +139,8 @@
+
+ #define EX // disable extern declarations
+ #include "fotoxx.h" // (variables in fotoxx.h are defined)
++#include <sys/types.h>
++#include <sys/sysctl.h>
+
+ /**************************************************************************/
+
+@@ -335,7 +337,9 @@ int initzfunc(void *)
+ char procfile[20], buff[200];
+ char KBshortsU[200], KBshortsI[200];
+ char tonefile[200], badnews[200];
++#ifdef __linux__
+ double freememory, cachememory;
++#endif
+ float exifver = 0;
+ FILE *fid;
+ STATB statb;
+@@ -445,6 +449,7 @@ int initzfunc(void *)
+
+ // check free memory and suggest image size limits
+
++#ifdef __linux__
+ parseprocfile("/proc/meminfo","MemFree:",&freememory,0); // get amount of free memory
+ parseprocfile("/proc/meminfo","Cached:",&cachememory,0);
+ freememory = (freememory + cachememory) / 1024; // megabytes
+@@ -452,6 +457,7 @@ int initzfunc(void *)
+ printz("image size limits for good performance: \n");
+ printz(" view: %.0f megapixels \n",(freememory-100)/6); // F + preview, 3 bytes/pixel each
+ printz(" edit: %.0f megapixels \n",(freememory-100)/54); // + E0/E1/E3/ER, 12 bytes/pixel each
++#endif
+
+ // update KB shortcuts if needed
+
+@@ -531,7 +537,13 @@ int initzfunc(void *)
+ screenhh = gdk_screen_get_height(screen);
+ printz("screen width: %d height: %d \n",screenww,screenhh);
+
++#ifdef __linux__
+ NWT = get_nprocs(); // get SMP CPU count
++#endif
++#ifdef __FreeBSD__
++ size_t len = sizeof(NWT);
++ sysctlbyname("hw.ncpu",&NWT,&len,NULL,0);
++#endif
+ if (NWT <= 0) NWT = 2;
+ if (NWT > max_threads) NWT = max_threads; // compile time limit
+ printz("using %d threads \n",NWT);
diff --git a/graphics/fotoxx/files/patch-fotoxx.h b/graphics/fotoxx/files/patch-fotoxx.h
deleted file mode 100644
index 67fc9cac98d7..000000000000
--- a/graphics/fotoxx/files/patch-fotoxx.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- ./fotoxx.h.orig 2014-02-05 20:42:34.000000000 +0100
-+++ ./fotoxx.h 2014-02-06 10:32:37.000000000 +0100
-@@ -339,8 +339,8 @@
- EX int dww, dhh; // Dpxb size in drawing window, <= Dww, Dhh
- EX int zoomx, zoomy; // req. zoom center of window
-
--EX mutex Fpixmap_lock; // lock for accessing PXM pixmaps
--EX mutex preload_lock; // lock for image file preload function
-+EX mutex_tp Fpixmap_lock; // lock for accessing PXM pixmaps
-+EX mutex_tp preload_lock; // lock for image file preload function
-
- EX int Mbutton; // mouse button, 1/3 = left/right
- EX int Mwxposn, Mwyposn; // mouse position, window space
diff --git a/graphics/fotoxx/files/patch-zfuncs.cc b/graphics/fotoxx/files/patch-zfuncs.cc
index 869384303ac0..55efd163c701 100644
--- a/graphics/fotoxx/files/patch-zfuncs.cc
+++ b/graphics/fotoxx/files/patch-zfuncs.cc
@@ -1,20 +1,18 @@
---- ./zfuncs.cc.orig 2014-02-05 20:42:34.000000000 +0100
-+++ ./zfuncs.cc 2014-02-06 10:32:37.000000000 +0100
-@@ -854,7 +854,7 @@
- // A mutex lock is used to insure one thread at a time has access to the parameter.
- // Many parameters can be used but there is only one mutex lock.
+--- zfuncs.cc.orig 2015-05-01 09:40:38 UTC
++++ zfuncs.cc
+@@ -262,6 +262,7 @@ char *zstrdup(cchar *string, int addcc)
--mutex zget_lock = PTHREAD_MUTEX_INITIALIZER;
-+mutex_tp zget_lock = PTHREAD_MUTEX_INITIALIZER;
-
- int zget_locked(int &param) // lock and return parameter
+ void zmalloc_report()
{
-@@ -1276,7 +1276,7 @@
- namespace shell_asynch_names {
- char *command[10];
- int status[10];
-- mutex mlock = PTHREAD_MUTEX_INITIALIZER;
-+ mutex_tp mlock = PTHREAD_MUTEX_INITIALIZER;
- }
++#ifdef __linux__
+ using namespace zfuncs;
+
+ static double ptime = 0;
+@@ -282,6 +283,7 @@ void zmalloc_report()
- int shell_asynch(cchar *Fcommand, ...) // v.5.5
+ ptime = jobtime(); // reset some counters
+ Nmalloc = Nstrdup = Nfree = 0;
++#endif
+
+ return;
+ }
diff --git a/graphics/fotoxx/files/patch-zfuncs.h b/graphics/fotoxx/files/patch-zfuncs.h
index 350475889139..b8f37f435ee6 100644
--- a/graphics/fotoxx/files/patch-zfuncs.h
+++ b/graphics/fotoxx/files/patch-zfuncs.h
@@ -1,15 +1,19 @@
---- ./zfuncs.h.orig 2014-02-05 20:42:34.000000000 +0100
-+++ ./zfuncs.h 2014-02-06 10:32:37.000000000 +0100
-@@ -22,7 +22,7 @@
+--- zfuncs.h.orig 2015-05-01 09:40:38 UTC
++++ zfuncs.h
+@@ -22,17 +22,18 @@
- // zfuncs.h version v.5.8
+ // zfuncs.h version v.6.1
--#include <sys/sysinfo.h>
-+//#include <sys/sysinfo.h>
+-#include <sys/sysinfo.h>
++//#include <sys/sysinfo.h>
#include <sys/time.h>
#include <sys/stat.h>
#include <sys/resource.h>
-@@ -33,6 +33,7 @@
+ #include <sys/file.h>
+ #include <sys/utsname.h>
+-#include <malloc.h>
++//#include <malloc.h>
+ #include <errno.h>
#include <unistd.h>
#include <stdlib.h>
#include <stdio.h>
@@ -17,21 +21,3 @@
#include <string.h>
#include <ctype.h>
#include <math.h>
-@@ -60,7 +61,7 @@
-
- #define wstrerror(err) strerror(WEXITSTATUS(err)) // get text status for child process
-
--#define mutex pthread_mutex_t // abbreviations
-+#define mutex_tp pthread_mutex_t // abbreviations
- #define mutex_init pthread_mutex_init
- #define mutex_lock pthread_mutex_lock
- #define mutex_trylock pthread_mutex_trylock
-@@ -625,7 +626,7 @@
- {
- char wmi[8];
- Vxstring * vd; // vector of xstrings
-- mutex qmutex; // for multi-thread access
-+ mutex_tp qmutex; // for multi-thread access
- int qcap; // queue capacity
- int qcount; // curr. queue count
- int ent1; // first entry pointer
diff --git a/graphics/fotoxx/pkg-plist b/graphics/fotoxx/pkg-plist
deleted file mode 100644
index 702e303b888d..000000000000
--- a/graphics/fotoxx/pkg-plist
+++ /dev/null
@@ -1,201 +0,0 @@
-bin/fotoxx
-share/applications/fotoxx.desktop
-%%PORTDOCS%%%%DOCSDIR%%/README-ca
-%%PORTDOCS%%%%DOCSDIR%%/README-en
-%%PORTDOCS%%%%DOCSDIR%%/README-es
-%%PORTDOCS%%%%DOCSDIR%%/changelog.gz
-%%PORTDOCS%%%%DOCSDIR%%/copyright
-%%PORTDOCS%%%%DOCSDIR%%/fotoxx-release
-%%PORTDOCS%%%%DOCSDIR%%/fotoxx.man
-%%PORTDOCS%%%%DOCSDIR%%/freecode
-%%PORTDOCS%%%%DOCSDIR%%/translations-ca
-%%PORTDOCS%%%%DOCSDIR%%/translations-en
-%%PORTDOCS%%%%DOCSDIR%%/translations-es
-%%DATADIR%%/data/KB-shortcuts-ca
-%%DATADIR%%/data/KB-shortcuts-en
-%%DATADIR%%/data/KB-shortcuts-es
-%%DATADIR%%/data/edit-menus-ca
-%%DATADIR%%/data/edit-menus-en
-%%DATADIR%%/data/edit-menus-es
-%%DATADIR%%/data/favorites/menu-config
-%%DATADIR%%/data/favorites/menu-config-pixbuf-009.png
-%%DATADIR%%/data/images/F-toolbar.jpg
-%%DATADIR%%/data/images/G-toolbar.jpg
-%%DATADIR%%/data/images/HDF-paint.jpg
-%%DATADIR%%/data/images/HDR-adjust.jpg
-%%DATADIR%%/data/images/KB-shortcuts.jpg
-%%DATADIR%%/data/images/add-geotags.jpg
-%%DATADIR%%/data/images/add-text.jpg
-%%DATADIR%%/data/images/add-text2.jpg
-%%DATADIR%%/data/images/anti-alias.jpg
-%%DATADIR%%/data/images/auto-trim.jpg
-%%DATADIR%%/data/images/batch-add-geotags.jpg
-%%DATADIR%%/data/images/batch-convert.jpg
-%%DATADIR%%/data/images/batch-raw-conv.jpg
-%%DATADIR%%/data/images/brightness-distribution.jpg
-%%DATADIR%%/data/images/brightness-ramp.jpg
-%%DATADIR%%/data/images/brightness steps.jpg
-%%DATADIR%%/data/images/chromatic.jpg
-%%DATADIR%%/data/images/cmyk.jpg
-%%DATADIR%%/data/images/collections.jpg
-%%DATADIR%%/data/images/colorchart.png
-%%DATADIR%%/data/images/denoise.jpg
-%%DATADIR%%/data/images/dots.jpg
-%%DATADIR%%/data/images/drawing.jpg
-%%DATADIR%%/data/images/edit-metadata.jpg
-%%DATADIR%%/data/images/edit-translation.jpg
-%%DATADIR%%/data/images/favorites.jpg
-%%DATADIR%%/data/images/file-save.jpg
-%%DATADIR%%/data/images/flatbook.jpg
-%%DATADIR%%/data/images/fotoxx.jpg
-%%DATADIR%%/data/images/gallery-select.jpg
-%%DATADIR%%/data/images/gammachart.png
-%%DATADIR%%/data/images/geotag-groups.jpg
-%%DATADIR%%/data/images/grad_blur.jpg
-%%DATADIR%%/data/images/grid-lines.jpg
-%%DATADIR%%/data/images/index.jpg
-%%DATADIR%%/data/images/jpeg quality.jpg
-%%DATADIR%%/data/images/keystone.jpg
-%%DATADIR%%/data/images/leverage-edits.jpg
-%%DATADIR%%/data/images/mashup.jpg
-%%DATADIR%%/data/images/mashup2.jpg
-%%DATADIR%%/data/images/match-colors.jpg
-%%DATADIR%%/data/images/move-collections.jpg
-%%DATADIR%%/data/images/paint-clone.jpg
-%%DATADIR%%/data/images/paint-edits.jpg
-%%DATADIR%%/data/images/pano-color.jpg
-%%DATADIR%%/data/images/pano-pre-align.jpg
-%%DATADIR%%/data/images/plugins.jpg
-%%DATADIR%%/data/images/print.jpg
-%%DATADIR%%/data/images/remove-dust.jpg
-%%DATADIR%%/data/images/rename.jpg
-%%DATADIR%%/data/images/resize.jpg
-%%DATADIR%%/data/images/retouch-combo.jpg
-%%DATADIR%%/data/images/retouch-combo2.jpg
-%%DATADIR%%/data/images/revise-RGB.jpg
-%%DATADIR%%/data/images/search-images-metadata.jpg
-%%DATADIR%%/data/images/search-images.jpg
-%%DATADIR%%/data/images/select-area.jpg
-%%DATADIR%%/data/images/sharpen.jpg
-%%DATADIR%%/data/images/sharpen4.jpg
-%%DATADIR%%/data/images/shift-colors.jpg
-%%DATADIR%%/data/images/show-RGB.jpg
-%%DATADIR%%/data/images/sketch.jpg
-%%DATADIR%%/data/images/slide-show.jpg
-%%DATADIR%%/data/images/smart-erase.jpg
-%%DATADIR%%/data/images/stack-noise.jpg
-%%DATADIR%%/data/images/stack-paint.jpg
-%%DATADIR%%/data/images/stuck-pixels.jpg
-@comment %%DATADIR%%/data/images/synchronize.jpg
-%%DATADIR%%/data/images/tabsF&G.png
-%%DATADIR%%/data/images/texture.jpg
-%%DATADIR%%/data/images/tone-mapping.jpg
-%%DATADIR%%/data/images/trim-rotate.jpg
-%%DATADIR%%/data/images/unbend.jpg
-%%DATADIR%%/data/images/user-settings.jpg
-%%DATADIR%%/data/images/vignette.jpg
-%%DATADIR%%/data/images/warps.jpg
-%%DATADIR%%/data/quickstart-ca.html
-%%DATADIR%%/data/quickstart-de.html
-%%DATADIR%%/data/quickstart-en.html
-%%DATADIR%%/data/quickstart-es.html
-%%DATADIR%%/data/quickstart-fr.html
-%%DATADIR%%/data/quickstart-it.html
-%%DATADIR%%/data/quickstart-pt.html
-%%DATADIR%%/data/slideshow-tone.oga
-%%DATADIR%%/data/tags_defined
-%%DATADIR%%/data/userguide-en.html
-%%DATADIR%%/data/userguide-es.html
-%%DATADIR%%/data/userguide-it.html
-%%DATADIR%%/icons/F-tab.png
-%%DATADIR%%/icons/G-tab.png
-%%DATADIR%%/icons/W-tab.png
-%%DATADIR%%/icons/bottom.png
-%%DATADIR%%/icons/broken.png
-%%DATADIR%%/icons/cancel.png
-%%DATADIR%%/icons/down+.png
-%%DATADIR%%/icons/down.png
-%%DATADIR%%/icons/edit-funcs/CMYK.png
-%%DATADIR%%/icons/edit-funcs/HDF.png
-%%DATADIR%%/icons/edit-funcs/HDR.png
-%%DATADIR%%/icons/edit-funcs/RGB.png
-%%DATADIR%%/icons/edit-funcs/blur.png
-%%DATADIR%%/icons/edit-funcs/bright distrib.png
-%%DATADIR%%/icons/edit-funcs/brigth color sat.png
-%%DATADIR%%/icons/edit-funcs/brigth ramp.png
-%%DATADIR%%/icons/edit-funcs/color depth.png
-%%DATADIR%%/icons/edit-funcs/crop rotate.png
-%%DATADIR%%/icons/edit-funcs/dots.png
-%%DATADIR%%/icons/edit-funcs/drawing01.png
-%%DATADIR%%/icons/edit-funcs/embossing.png
-%%DATADIR%%/icons/edit-funcs/expand bright.png
-%%DATADIR%%/icons/edit-funcs/fix fringes.png
-%%DATADIR%%/icons/edit-funcs/fix stuck pixels.png
-%%DATADIR%%/icons/edit-funcs/flatten bright.png
-%%DATADIR%%/icons/edit-funcs/flip.png
-%%DATADIR%%/icons/edit-funcs/gamma.png
-%%DATADIR%%/icons/edit-funcs/invert.png
-%%DATADIR%%/icons/edit-funcs/keystone.png
-%%DATADIR%%/icons/edit-funcs/landscape.png
-%%DATADIR%%/icons/edit-funcs/leverage edit.png
-%%DATADIR%%/icons/edit-funcs/outlines.png
-%%DATADIR%%/icons/edit-funcs/paint edits.png
-%%DATADIR%%/icons/edit-funcs/paint pixels.png
-%%DATADIR%%/icons/edit-funcs/painting.png
-%%DATADIR%%/icons/edit-funcs/panorama.png
-%%DATADIR%%/icons/edit-funcs/pencil.png
-%%DATADIR%%/icons/edit-funcs/red eyes.png
-%%DATADIR%%/icons/edit-funcs/reduce noise.png
-%%DATADIR%%/icons/edit-funcs/remove dust.png
-%%DATADIR%%/icons/edit-funcs/resize.png
-%%DATADIR%%/icons/edit-funcs/sharpen.png
-%%DATADIR%%/icons/edit-funcs/shiftcolors.png
-%%DATADIR%%/icons/edit-funcs/smarterase.png
-%%DATADIR%%/icons/edit-funcs/stacknoise.png
-%%DATADIR%%/icons/edit-funcs/stackpaint.png
-%%DATADIR%%/icons/edit-funcs/text.png
-%%DATADIR%%/icons/edit-funcs/tiles.png
-%%DATADIR%%/icons/edit-funcs/tonemapping.png
-%%DATADIR%%/icons/edit-funcs/unbend.png
-%%DATADIR%%/icons/edit-funcs/vert panorama.png
-%%DATADIR%%/icons/edit-funcs/voodoo.png
-%%DATADIR%%/icons/edit-funcs/warp affine.png
-%%DATADIR%%/icons/edit-funcs/warp area.png
-%%DATADIR%%/icons/edit-funcs/warp curved.png
-%%DATADIR%%/icons/edit-funcs/warp linear.png
-%%DATADIR%%/icons/edit-funcs/whitebalance.png
-%%DATADIR%%/icons/favorites.png
-%%DATADIR%%/icons/fg-color.png
-%%DATADIR%%/icons/folder.png
-%%DATADIR%%/icons/fotoxx.png
-%%DATADIR%%/icons/goto.png
-%%DATADIR%%/icons/help.png
-%%DATADIR%%/icons/next.png
-%%DATADIR%%/icons/open.png
-%%DATADIR%%/icons/prev.png
-%%DATADIR%%/icons/quit.png
-%%DATADIR%%/icons/redo.png
-%%DATADIR%%/icons/rotate-left.png
-%%DATADIR%%/icons/rotate-right.png
-%%DATADIR%%/icons/save.png
-%%DATADIR%%/icons/sort.png
-%%DATADIR%%/icons/sync.G.png
-%%DATADIR%%/icons/top.png
-%%DATADIR%%/icons/trash.png
-%%DATADIR%%/icons/undo.png
-%%DATADIR%%/icons/up+.png
-%%DATADIR%%/icons/up.png
-%%DATADIR%%/icons/warning.png
-%%DATADIR%%/icons/zoom+.png
-%%DATADIR%%/icons/zoom-.png
-%%DATADIR%%/locales/translate-ca.po
-%%DATADIR%%/locales/translate-de.po
-%%DATADIR%%/locales/translate-en.po
-%%DATADIR%%/locales/translate-es.po
-%%DATADIR%%/locales/translate-fr.po
-%%DATADIR%%/locales/translate-it.po
-%%DATADIR%%/locales/translate-nl.po
-%%DATADIR%%/locales/translate-pt.po
-%%DATADIR%%/locales/translate-ru.po
-%%DATADIR%%/locales/translate-sv.po
-man/man1/fotoxx.1.gz