aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorSylvio Cesar Teixeira <sylvio@FreeBSD.org>2011-05-13 14:37:57 +0000
committerSylvio Cesar Teixeira <sylvio@FreeBSD.org>2011-05-13 14:37:57 +0000
commitab755208c5e6a1a02230cdfdbbddacbedc097584 (patch)
treefac6913c3a1760be37bdb834427ffbb74bed6f47 /graphics
parent39032cb9062662f761165f7bb6eed489acce2d64 (diff)
downloadports-ab755208c5e6a1a02230cdfdbbddacbedc097584.tar.gz
ports-ab755208c5e6a1a02230cdfdbbddacbedc097584.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/amide/Makefile3
-rw-r--r--graphics/amide/distinfo4
-rw-r--r--graphics/amide/files/patch-configure30
-rw-r--r--graphics/amide/files/patch-src-dcmtk_interface.cc115
-rw-r--r--graphics/amide/files/patch-src-mpeg_encode.c11
-rw-r--r--graphics/amide/files/patch-src-ui_common.c11
6 files changed, 8 insertions, 166 deletions
diff --git a/graphics/amide/Makefile b/graphics/amide/Makefile
index fab3ecf1ee30..badec29a6582 100644
--- a/graphics/amide/Makefile
+++ b/graphics/amide/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= amide
-PORTVERSION= 0.9.2
-PORTREVISION= 1
+PORTVERSION= 0.9.3
CATEGORIES= graphics
MASTER_SITES= SF
EXTRACT_SUFX= .tgz
diff --git a/graphics/amide/distinfo b/graphics/amide/distinfo
index ceb26aa09f7c..82d7cde67afc 100644
--- a/graphics/amide/distinfo
+++ b/graphics/amide/distinfo
@@ -1,2 +1,2 @@
-SHA256 (amide-0.9.2.tgz) = bbe230b7aef3c65ef2014d561a09d97b96e50ec4f1a09c16b4de751974ff01be
-SIZE (amide-0.9.2.tgz) = 1476952
+SHA256 (amide-0.9.3.tgz) = f664ff89363e96452a94775f645f6ca2bcee628b19f1d72258545bb715da6602
+SIZE (amide-0.9.3.tgz) = 1635189
diff --git a/graphics/amide/files/patch-configure b/graphics/amide/files/patch-configure
index cdf7955e304e..617f8283e9a2 100644
--- a/graphics/amide/files/patch-configure
+++ b/graphics/amide/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2009-12-09 07:35:12.000000000 +0100
-+++ configure 2011-02-10 18:25:18.165872253 +0100
-@@ -17889,13 +17889,13 @@
+--- configure.orig 2011-01-20 03:24:42.000000000 +0100
++++ configure 2011-05-10 15:10:45.000000000 +0200
+@@ -15399,13 +15399,13 @@
DATADIRNAME=share
else
CATOBJEXT=.mo
@@ -16,8 +16,8 @@
;;
esac
fi
-@@ -18684,12 +18684,12 @@
- if test "x$ac_cv_func_bind_textdomain_codeset" = x""yes; then
+@@ -16063,12 +16063,12 @@
+ if test "x$ac_cv_func_bind_textdomain_codeset" = x""yes; then :
DATADIRNAME=share
else
- DATADIRNAME=lib
@@ -31,23 +31,3 @@
;;
esac
fi
-@@ -19625,7 +19625,7 @@
- $as_echo_n "(cached) " >&6
- else
- ac_check_lib_save_LIBS=$LIBS
--LIBS="-ldcmdata -lofstd -lz -L/usr/local/dicom/lib -L/sw/lib $THREAD_LIBS $LIBS"
-+LIBS="-ldcmdata -lofstd -loflog -lz -L/usr/local/lib $THREAD_LIBS $LIBS"
- cat >conftest.$ac_ext <<_ACEOF
- /* confdefs.h. */
- _ACEOF
-@@ -20391,8 +20391,8 @@
-
- if (test $enable_libdcmdata = yes) && (test $FOUND_DCMDATA = yes); then
- echo "Compiling with DCMTK support for DICOM files"
-- AMIDE_LIBDCMDATA_LIBS="-L/usr/local/dicom/lib -ldcmdata -lofstd -lz $THREAD_LIBS"
-- AMIDE_LIBDCMDATA_CFLAGS="-I/usr/local/dicom/include/dcmtk/dcmdata -I/usr/local/dicom/include/dcmtk/ofstd -I/usr/local/dicom/include -I/usr/include/dcmtk/dcmdata -I/usr/local/include/dcmtk/ofstd -I/sw/include/dcmtk/dcmdata -I/sw/include/dcmtk/ofstd -I/sw/include/dcmtk"
-+ AMIDE_LIBDCMDATA_LIBS="-L/usr/local/lib -ldcmdata -lofstd -loflog -lz $THREAD_LIBS"
-+ AMIDE_LIBDCMDATA_CFLAGS="-I/usr/local/include"
-
-
-
diff --git a/graphics/amide/files/patch-src-dcmtk_interface.cc b/graphics/amide/files/patch-src-dcmtk_interface.cc
deleted file mode 100644
index 0d87608c69bc..000000000000
--- a/graphics/amide/files/patch-src-dcmtk_interface.cc
+++ /dev/null
@@ -1,115 +0,0 @@
---- src/dcmtk_interface.cc.orig 2009-12-14 05:53:11.000000000 +0100
-+++ src/dcmtk_interface.cc 2011-02-11 10:59:18.612565854 +0100
-@@ -32,7 +32,7 @@
- #include <unistd.h>
- #endif
- #include "dcmtk_interface.h"
--#include "dcddirif.h" /* for class DicomDirInterface */
-+#include "dcmtk/dcmdata/dcddirif.h" /* for class DicomDirInterface */
- #include <dirent.h>
- #include <sys/stat.h>
- #include "amitk_data_set_DOUBLE_0D_SCALING.h"
-@@ -44,7 +44,8 @@
- #undef PACKAGE_STRING
- #undef PACKAGE_TARNAME
- #undef PACKAGE_VERSION
--#include <dctk.h>
-+#include "amide_config.h"
-+#include <dcmtk/dcmdata/dctk.h>
- //#include <dcostrmb.h>
- const gchar * dcmtk_version = OFFIS_DCMTK_VERSION;
-
-@@ -188,7 +189,7 @@
- }
- dim.y = return_uint16;
-
-- if (dcm_dataset->findAndGetUint16(DCM_Planes, return_uint16).bad())
-+ if (dcm_dataset->findAndGetUint16(DCM_RETIRED_Planes, return_uint16).bad())
- dim.z = 1;
- else
- dim.z = return_uint16;
-@@ -352,7 +353,7 @@
- if (dcm_dataset->findAndGetString(DCM_PatientID, return_str, OFTrue).good())
- amitk_data_set_set_subject_id(ds, return_str);
-
-- if (dcm_dataset->findAndGetFloat64(DCM_PatientsWeight, return_float64).good()) {
-+ if (dcm_dataset->findAndGetFloat64(DCM_PatientWeight, return_float64).good()) {
- amitk_data_set_set_subject_weight(ds, return_float64);
- amitk_data_set_set_displayed_weight_unit(ds, AMITK_WEIGHT_UNIT_KILOGRAM);
- }
-@@ -429,7 +430,7 @@
- }
- }
-
-- if (dcm_dataset->findAndGetString(DCM_PatientsName, return_str, OFTrue).good()) {
-+ if (dcm_dataset->findAndGetString(DCM_PatientName, return_str, OFTrue).good()) {
- if (AMITK_OBJECT_NAME(ds) == NULL)
- amitk_object_set_name(AMITK_OBJECT(ds), return_str);
- amitk_data_set_set_subject_name(ds, return_str);
-@@ -495,7 +496,7 @@
- }
- }
-
-- if (dcm_dataset->findAndGetString(DCM_PatientsBirthDate, return_str, OFTrue).good())
-+ if (dcm_dataset->findAndGetString(DCM_PatientBirthDate, return_str, OFTrue).good())
- amitk_data_set_set_subject_dob(ds, return_str);
-
- /* because of how the dicom coordinates are setup, after reading in the patient slices,
-@@ -1257,7 +1258,7 @@
- if (return_str != NULL)
- info->patient_id = g_strdup(return_str);
-
-- dcm_dataset->findAndGetString(DCM_PatientsName, return_str, OFTrue);
-+ dcm_dataset->findAndGetString(DCM_PatientName, return_str, OFTrue);
- if (return_str != NULL)
- info->patient_name = g_strdup(return_str);
-
-@@ -1537,7 +1538,7 @@
-
- /* go through the whole directory */
- while ((patient_record = dcm_root_record->nextSub(patient_record)) != NULL) {
-- patient_record->findAndGetString(DCM_PatientsName, record_name[0]);
-+ patient_record->findAndGetString(DCM_PatientName, record_name[0]);
- patient_record->findAndGetString(DCM_PatientID, patient_id, OFTrue);
-
-
-@@ -1802,8 +1803,9 @@
- }
-
- #ifdef AMIDE_DEBUG
-- dcm_dir.enableVerboseMode(TRUE);
-- dcm_dir.setLogStream(&ofConsole);
-+// These are not defined in the latest dcmtk and could not find substitutes.
-+// dcm_dir.enableVerboseMode(TRUE);
-+// dcm_dir.setLogStream(&ofConsole);
- #endif
-
- /* create the DICOMDIR, unless already made in which case we'll append to it */
-@@ -1905,15 +1907,15 @@
-
- /* other stuff */
- if (AMITK_DATA_SET_SUBJECT_NAME(ds) != NULL)
-- insert_str(dcm_ds,DCM_PatientsName, AMITK_DATA_SET_SUBJECT_NAME(ds));
-+ insert_str(dcm_ds,DCM_PatientName, AMITK_DATA_SET_SUBJECT_NAME(ds));
- if (AMITK_DATA_SET_SUBJECT_ID(ds) != NULL)
- insert_str(dcm_ds,DCM_PatientID, AMITK_DATA_SET_SUBJECT_ID(ds));
- if (AMITK_DATA_SET_SUBJECT_DOB(ds) != NULL)
-- insert_str(dcm_ds,DCM_PatientsBirthDate, AMITK_DATA_SET_SUBJECT_DOB(ds));
-+ insert_str(dcm_ds,DCM_PatientBirthDate, AMITK_DATA_SET_SUBJECT_DOB(ds));
- if (AMITK_OBJECT_NAME(ds) != NULL)
- insert_str(dcm_ds,DCM_StudyDescription, AMITK_OBJECT_NAME(ds));
- insert_double(dcm_ds,DCM_RadionuclideTotalDose, AMITK_DATA_SET_INJECTED_DOSE(ds));
-- insert_double(dcm_ds,DCM_PatientsWeight, AMITK_DATA_SET_SUBJECT_WEIGHT(ds));
-+ insert_double(dcm_ds,DCM_PatientWeight, AMITK_DATA_SET_SUBJECT_WEIGHT(ds));
-
- switch(AMITK_DATA_SET_SUBJECT_ORIENTATION(ds)) {
- case AMITK_SUBJECT_ORIENTATION_SUPINE_HEADFIRST:
-@@ -1949,7 +1951,7 @@
- case AMITK_MODALITY_PET:
- insert_str(dcm_ds,DCM_Modality, "PT");
- dcm_metainfo->putAndInsertString(DCM_MediaStorageSOPClassUID,
-- UID_PETImageStorage);
-+ UID_EnhancedPETImageStorage);
- break;
- case AMITK_MODALITY_SPECT:
- insert_str(dcm_ds,DCM_Modality, "ST");
diff --git a/graphics/amide/files/patch-src-mpeg_encode.c b/graphics/amide/files/patch-src-mpeg_encode.c
deleted file mode 100644
index 459bc2b90310..000000000000
--- a/graphics/amide/files/patch-src-mpeg_encode.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/mpeg_encode.c.orig 2009-11-16 07:55:52.000000000 +0100
-+++ src/mpeg_encode.c 2011-02-08 16:18:47.640994869 +0100
-@@ -141,7 +141,7 @@
- /* -------------------------------------------------------- */
- #ifdef AMIDE_FFMPEG_SUPPORT
-
--#include <ffmpeg/libavcodec/avcodec.h>
-+#include <libavcodec/avcodec.h>
-
-
- typedef struct {
diff --git a/graphics/amide/files/patch-src-ui_common.c b/graphics/amide/files/patch-src-ui_common.c
deleted file mode 100644
index af9ac8ccae24..000000000000
--- a/graphics/amide/files/patch-src-ui_common.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/ui_common.c.orig 2009-11-16 06:00:11.000000000 +0100
-+++ src/ui_common.c 2011-02-08 16:21:18.283127798 +0100
-@@ -46,7 +46,7 @@
- #include <medcon.h>
- #endif
- #ifdef AMIDE_FFMPEG_SUPPORT
--#include <ffmpeg/libavcodec/avcodec.h>
-+#include <libavcodec/avcodec.h>
- #endif
- #ifdef AMIDE_LIBFAME_SUPPORT
- #include <fame_version.h>